aboutsummaryrefslogtreecommitdiffstats
path: root/www/gotty
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2016-07-12 23:13:23 +0800
committerehaupt <ehaupt@FreeBSD.org>2016-07-12 23:13:23 +0800
commit38ed7b06838f00571a14d225d99c662c020eba15 (patch)
tree1f1324584e1e5c355aaa7ec7fb6d7c706f8cb59f /www/gotty
parentee7b4a045003b30a9978d3dbf2bb8735e8443ec6 (diff)
downloadfreebsd-ports-gnome-38ed7b06838f00571a14d225d99c662c020eba15.tar.gz
freebsd-ports-gnome-38ed7b06838f00571a14d225d99c662c020eba15.tar.zst
freebsd-ports-gnome-38ed7b06838f00571a14d225d99c662c020eba15.zip
GoTTY is a simple command line tool that turns your CLI tools into web
applications. GoTTY starts a new process with the given command when a new client connects to the server. This means users cannot share a single terminal with others by default. However, you can use terminal multiplexers for sharing a single process with multiple clients. For additional security, SSL/TLS client certificate authentication and session encryption should be used. WWW: https://github.com/yudai/gotty
Diffstat (limited to 'www/gotty')
-rw-r--r--www/gotty/Makefile23
-rw-r--r--www/gotty/distinfo3
-rw-r--r--www/gotty/pkg-descr12
3 files changed, 38 insertions, 0 deletions
diff --git a/www/gotty/Makefile b/www/gotty/Makefile
new file mode 100644
index 000000000000..b140a59a6cf7
--- /dev/null
+++ b/www/gotty/Makefile
@@ -0,0 +1,23 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gotty
+PORTVERSION= 0.0.13
+DISTVERSIONPREFIX= v
+CATEGORIES= www net ipv6
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Command line tool that turns your CLI tools into web applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= yudai
+
+USES= go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/gotty
+
+.include <bsd.port.mk>
diff --git a/www/gotty/distinfo b/www/gotty/distinfo
new file mode 100644
index 000000000000..0eaa276914df
--- /dev/null
+++ b/www/gotty/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468323268
+SHA256 (yudai-gotty-v0.0.13_GH0.tar.gz) = 4082f0805e925073fb15a997012d1b9d3512fc9077de323225153c9ae5b96318
+SIZE (yudai-gotty-v0.0.13_GH0.tar.gz) = 2349389
diff --git a/www/gotty/pkg-descr b/www/gotty/pkg-descr
new file mode 100644
index 000000000000..67af34051ff9
--- /dev/null
+++ b/www/gotty/pkg-descr
@@ -0,0 +1,12 @@
+GoTTY is a simple command line tool that turns your CLI tools into web
+applications.
+
+GoTTY starts a new process with the given command when a new client connects
+to the server. This means users cannot share a single terminal with others by
+default. However, you can use terminal multiplexers for sharing a single
+process with multiple clients.
+
+For additional security, SSL/TLS client certificate authentication and
+session encryption should be used.
+
+WWW: https://github.com/yudai/gotty