aboutsummaryrefslogtreecommitdiffstats
path: root/www/gtkhtml3/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-06-16 22:47:30 +0800
committersobomax <sobomax@FreeBSD.org>2002-06-16 22:47:30 +0800
commit0ed98a8358491f3e8baff482720f49680be8105f (patch)
treeeb85ce244c8db0a5884365708962a733537f838e /www/gtkhtml3/Makefile
parentd573d439f06446663ebac8048c82e0c0d70a8506 (diff)
downloadfreebsd-ports-gnome-0ed98a8358491f3e8baff482720f49680be8105f.tar.gz
freebsd-ports-gnome-0ed98a8358491f3e8baff482720f49680be8105f.tar.zst
freebsd-ports-gnome-0ed98a8358491f3e8baff482720f49680be8105f.zip
- Update to 1.0.4;
- use REINPLACE_CMD.
Diffstat (limited to 'www/gtkhtml3/Makefile')
-rw-r--r--www/gtkhtml3/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/www/gtkhtml3/Makefile b/www/gtkhtml3/Makefile
index d6c51670b6a3..0cebe5dacec6 100644
--- a/www/gtkhtml3/Makefile
+++ b/www/gtkhtml3/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gtkhtml
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/gtkhtml
@@ -32,10 +32,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>