aboutsummaryrefslogtreecommitdiffstats
path: root/www/helixplugin
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
committermezz <mezz@FreeBSD.org>2009-01-10 10:45:46 +0800
commit867a335b88f91d457005fa0c7b3bb7c85c5fca14 (patch)
tree68af898c9a11dd756c516c49a6715cee75888e70 /www/helixplugin
parent6f64cd00171c29c1c7cdfb1e40393e23fc35151d (diff)
downloadfreebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.gz
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.tar.zst
freebsd-ports-gnome-867a335b88f91d457005fa0c7b3bb7c85c5fca14.zip
Add a new framework for browser plugins, USE_WEBPLUGINS. It is for which foo
plugins support one of web browsers and can take care of plist (depend on how you use it) at the same time. I have written a complete document and even show how it works in the www/firefox/Makefile.webplugins so be sure to read in there. If there is anything that isn't clear in the document, please feel free to ask and I will try my best to improvement it. FYI: GNOME 2.24 depends on this, so it's coming. BTW: It's based on www/linux-mplayer-plugin/Makefile.npapi with heavy modified. Approved by: portmgr
Diffstat (limited to 'www/helixplugin')
-rw-r--r--www/helixplugin/Makefile15
-rw-r--r--www/helixplugin/files/BSDmakefile2
2 files changed, 11 insertions, 6 deletions
diff --git a/www/helixplugin/Makefile b/www/helixplugin/Makefile
index 72e290792565..aa440330ee40 100644
--- a/www/helixplugin/Makefile
+++ b/www/helixplugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hxplugin
PORTVERSION= 20070318
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www multimedia
MASTER_SITES= http://virtual-estates.net/~mi/port-stuff/
@@ -17,16 +17,21 @@ COMMENT= Browser plugin for Real or Helix Players
USE_BZIP2 = yes
USE_DOS2UNIX = yes
MAKEFILE = ${FILESDIR}/BSDmakefile
-#USE_GECKO = firefox mozilla seamonkey xulrunner firefox-devel
-USE_GECKO = ${_GECKO_ALL}
+USE_GECKO = firefox mozilla seamonkey xulrunner
MAKE_ENV += TOP="${WRKSRC}" GECKO=${GECKO}
-PDIR ?= lib/browser_plugins
+USE_WEBPLUGINS= native
+WEBPLUGINS_FILES=helix.so nphelix.xpt
+
+PDIR= ${WEBPLUGINS_DIR:S,${PREFIX}/,,}
PLIST_FILES= ${PDIR}/helix.so ${PDIR}/nphelix.xpt
+PLIST_DIRS= ${PDIR}
do-install:
- ${INSTALL_DATA} ${PLIST_FILES:S|${PDIR}|${WRKSRC}|} ${PREFIX}/${PDIR}/
+ ${MKDIR} ${WEBPLUGINS_DIR}
+ ${INSTALL_DATA} ${WEBPLUGINS_FILES:S|^|${WRKSRC}/|} ${WEBPLUGINS_DIR}/
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/bsd.gecko.mk"
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.include <bsd.port.post.mk>
diff --git a/www/helixplugin/files/BSDmakefile b/www/helixplugin/files/BSDmakefile
index b69e16a1145d..34db079ddb90 100644
--- a/www/helixplugin/files/BSDmakefile
+++ b/www/helixplugin/files/BSDmakefile
@@ -20,7 +20,7 @@ SRCS = hxbackend.cpp \
XPIDL ?= ${LOCALBASE}/lib/${GECKO}/xpidl
XPTLINK ?= ${XPIDL:H}/xpt_link
-SHARE_IDL != echo ${LOCALBASE}/share/idl/${GECKO:S/-devel/-2/}*
+SHARE_IDL != echo ${LOCALBASE}/share/idl/${GECKO:S,firefox$,firefox-2,}*
.PATH: ${TOP}/player/app/plugin ${TOP}/player/app/plugin/common