aboutsummaryrefslogtreecommitdiffstats
path: root/www/htmlcxx
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2017-02-16 10:31:16 +0800
committerkevlo <kevlo@FreeBSD.org>2017-02-16 10:31:16 +0800
commit7ed7f071776f82b060f51aabfae02b020d8c5cfc (patch)
treeab5e357949ea4b1c4b87cc659e151c8b96245975 /www/htmlcxx
parent9d0bac4bed4d0c3f913f24680f4b378a860c5ca5 (diff)
downloadfreebsd-ports-gnome-7ed7f071776f82b060f51aabfae02b020d8c5cfc.tar.gz
freebsd-ports-gnome-7ed7f071776f82b060f51aabfae02b020d8c5cfc.tar.zst
freebsd-ports-gnome-7ed7f071776f82b060f51aabfae02b020d8c5cfc.zip
Update to 0.86
Diffstat (limited to 'www/htmlcxx')
-rw-r--r--www/htmlcxx/Makefile17
-rw-r--r--www/htmlcxx/distinfo5
-rw-r--r--www/htmlcxx/files/patch-ci_string.h19
-rw-r--r--www/htmlcxx/pkg-plist4
4 files changed, 8 insertions, 37 deletions
diff --git a/www/htmlcxx/Makefile b/www/htmlcxx/Makefile
index efc7acd16792..3c4d956d48ff 100644
--- a/www/htmlcxx/Makefile
+++ b/www/htmlcxx/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= htmlcxx
-PORTVERSION= 0.85
-PORTREVISION= 2
+PORTVERSION= 0.86
CATEGORIES= www textproc
MASTER_SITES= SF
@@ -12,24 +11,14 @@ COMMENT= HTML and CSS APIs for C++
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/LGPL_V2
-USES= bison iconv libtool
+USES= bison iconv libtool pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-MAKE_JOBS_UNSAFE=yes
-
-MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
-
-.include <bsd.port.pre.mk>
-
-.if !empty(ICONV_LIB)
-CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
-.endif
-
post-patch:
@${REINPLACE_CMD} 's/-liconv/${ICONV_LIB}/' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/htmlcxx/distinfo b/www/htmlcxx/distinfo
index a3e1f40fab48..76e8cf6ae811 100644
--- a/www/htmlcxx/distinfo
+++ b/www/htmlcxx/distinfo
@@ -1,2 +1,3 @@
-SHA256 (htmlcxx-0.85.tar.gz) = ab02a0c4addc82f82d564f7d163fe0cc726179d9045381c288f5b8295996bae5
-SIZE (htmlcxx-0.85.tar.gz) = 414624
+TIMESTAMP = 1487211277
+SHA256 (htmlcxx-0.86.tar.gz) = 07542b5ea2442143b125ba213b6823ff4a23fff352ecdd84bbebe1d154f4f5c1
+SIZE (htmlcxx-0.86.tar.gz) = 469416
diff --git a/www/htmlcxx/files/patch-ci_string.h b/www/htmlcxx/files/patch-ci_string.h
deleted file mode 100644
index bf8b8ab3cfce..000000000000
--- a/www/htmlcxx/files/patch-ci_string.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- html/ci_string.h.orig 2013-09-13 10:48:21.000000000 +0800
-+++ html/ci_string.h 2013-09-13 10:48:35.000000000 +0800
-@@ -4,16 +4,7 @@
- #include <cctype>
- #include <string>
-
--#if __GNUC__ >= 3
--#include <bits/char_traits.h>
- struct ci_char_traits : public std::char_traits<char>
--#elif defined(__GNUC__)
--#include <std/straits.h>
--struct ci_char_traits : public std::string_char_traits<char>
--#else
--//Hope string already include it
--struct ci_char_traits : public std::char_traits<char>
--#endif
-
- // just inherit all the other functions
- // that we don't need to override
diff --git a/www/htmlcxx/pkg-plist b/www/htmlcxx/pkg-plist
index a2b68a80c112..764b182ddcc3 100644
--- a/www/htmlcxx/pkg-plist
+++ b/www/htmlcxx/pkg-plist
@@ -12,7 +12,6 @@ include/htmlcxx/html/ci_string.h
include/htmlcxx/html/tld.h
include/htmlcxx/html/tree.h
include/htmlcxx/html/utils.h
-libdata/pkgconfig/htmlcxx.pc
lib/libcss_parser.so
lib/libcss_parser.so.0
lib/libcss_parser.so.0.0.0
@@ -22,4 +21,5 @@ lib/libcss_parser_pp.so.0.0.0
lib/libhtmlcxx.so
lib/libhtmlcxx.so.3
lib/libhtmlcxx.so.3.1.0
-share/htmlcxx/css/default.css
+libdata/pkgconfig/htmlcxx.pc
+%%DATADIR%%/css/default.css