aboutsummaryrefslogtreecommitdiffstats
path: root/www/htmlobject
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-31 00:48:45 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-31 00:48:45 +0800
commit1ed9cd35ddd007ea29abd83cfecd93595d243a7b (patch)
tree3987760764b1809566e31a8630a69970fe24ad18 /www/htmlobject
parent10f93ea4a314cd23e276d8c4a74997d779db07b7 (diff)
downloadfreebsd-ports-gnome-1ed9cd35ddd007ea29abd83cfecd93595d243a7b.tar.gz
freebsd-ports-gnome-1ed9cd35ddd007ea29abd83cfecd93595d243a7b.tar.zst
freebsd-ports-gnome-1ed9cd35ddd007ea29abd83cfecd93595d243a7b.zip
add htmlobject
HTML Document Object
Diffstat (limited to 'www/htmlobject')
-rw-r--r--www/htmlobject/Makefile25
-rw-r--r--www/htmlobject/distinfo1
-rw-r--r--www/htmlobject/pkg-comment1
-rw-r--r--www/htmlobject/pkg-descr12
-rw-r--r--www/htmlobject/pkg-plist19
5 files changed, 58 insertions, 0 deletions
diff --git a/www/htmlobject/Makefile b/www/htmlobject/Makefile
new file mode 100644
index 000000000000..e32169c39304
--- /dev/null
+++ b/www/htmlobject/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: htmlobject
+# Date created: Jul 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlobject
+PORTVERSION= 1.09
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= html_object-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTMLObject::Base.3 HTMLObject::FrameSet.3 HTMLObject::GetCookie.3 \
+ HTMLObject::Normal.3 HTMLObject::ReadCookie.3
+
+.include <bsd.port.mk>
diff --git a/www/htmlobject/distinfo b/www/htmlobject/distinfo
new file mode 100644
index 000000000000..84d46212c82c
--- /dev/null
+++ b/www/htmlobject/distinfo
@@ -0,0 +1 @@
+MD5 (html_object-1.09.tar.gz) = 918ddd6358fdd686583c5dd42095f565
diff --git a/www/htmlobject/pkg-comment b/www/htmlobject/pkg-comment
new file mode 100644
index 000000000000..ba399d2f3e92
--- /dev/null
+++ b/www/htmlobject/pkg-comment
@@ -0,0 +1 @@
+HTML Document Object
diff --git a/www/htmlobject/pkg-descr b/www/htmlobject/pkg-descr
new file mode 100644
index 000000000000..679c59cb382c
--- /dev/null
+++ b/www/htmlobject/pkg-descr
@@ -0,0 +1,12 @@
+The HTML Document Object allows you as a programmer to quickly and easily
+generate dynamic HTML documents without having to deal with all the HTML
+overhead at every step of the way. For example, you have the ability to
+generate a cookie at any point, until you actually display the document.
+
+The HTML Document Object provides a template object that you fill in with
+the content you want displayed. You still have to order your content in the
+order it should show, but you don't have to generate all your JavaScript code
+first and then your body, you can intermingle them and the HTML Document
+Object will take care of keeping track of where everything goes.
+
+WWW: http://htmlobject.sourceforge.net/
diff --git a/www/htmlobject/pkg-plist b/www/htmlobject/pkg-plist
new file mode 100644
index 000000000000..46e1dbb5c56f
--- /dev/null
+++ b/www/htmlobject/pkg-plist
@@ -0,0 +1,19 @@
+lib/perl5/site_perl/%%PERL_VER%%/HTMLObject/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTMLObject/FrameSet.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTMLObject/GetCookie.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTMLObject/Normal.pm
+lib/perl5/site_perl/%%PERL_VER%%/HTMLObject/ReadCookie.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/Base/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/FrameSet/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/GetCookie/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/Normal/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/ReadCookie/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTMLObject/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/HTMLObject
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/Base
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/FrameSet
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/GetCookie
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/Normal
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject/ReadCookie
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTMLObject
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTMLObject