aboutsummaryrefslogtreecommitdiffstats
path: root/www/interchange/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2002-09-01 03:01:45 +0800
committernetchild <netchild@FreeBSD.org>2002-09-01 03:01:45 +0800
commit4f3f40f6157a73f5e795716b99fe9a56fca9a359 (patch)
treef2e5be6c20cdd98523c3f6d19b3e606604f4c4ed /www/interchange/Makefile
parent38ee50cf9247e72ae67b1c3dfebd8584a53fcf27 (diff)
downloadfreebsd-ports-gnome-4f3f40f6157a73f5e795716b99fe9a56fca9a359.tar.gz
freebsd-ports-gnome-4f3f40f6157a73f5e795716b99fe9a56fca9a359.tar.zst
freebsd-ports-gnome-4f3f40f6157a73f5e795716b99fe9a56fca9a359.zip
Repeat after me: Always redo your tests if you get distracted while you
are testing some changes... (missing action in post-install) Noticed by: Mike Harding <mvh@ix.netcom.com> While I'm here: - add missing character in 'Whom:' - use correct path in vendor-after-install message
Diffstat (limited to 'www/interchange/Makefile')
-rw-r--r--www/interchange/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
index e2acd5fbed78..323485c25b2b 100644
--- a/www/interchange/Makefile
+++ b/www/interchange/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: interchange
# Date created: 2 July 2002
-# Whom: Seth Kingsley <sethk@meowfishies.com
+# Whom: Seth Kingsley <sethk@meowfishies.com>
#
# $FreeBSD$
#
@@ -45,6 +45,9 @@ MAKE_ARGS+= NOCPANINSTALL=1 \
CONFIGURE_ARGS+= force=1
+post-patch:
+ @${REINPLACE_CMD} -e "s:You are now ready to cd to \$$realdir:You are now ready to cd to ${PREFIX}:g" ${WRKSRC}/Makefile.PL
+
pre-configure:
.if !defined(USE_THIS_PERL) && !defined(BATCH)
@[ ! "${PERL_VER}" \< "5.6.1" ] || ( ${ECHO_CMD} -e "You use perl ${PERL_VER}, interchange should be used with 5.6.1 or better,\njust install the newer perl from ports and run 'use.perl port', this will\nmake the new perl the default perl. If you already have some perl modules\ninstalled for your old perl, you have to reinstall them for the new perl.\n\nIf you absolutely want to try to run interchange with perl ${PERL_VER},\nyou have to add '-DUSE_THIS_PERL' as an option for 'make'.\n" ; exit 1 )
@@ -60,5 +63,6 @@ post-install:
${PREFIX}/etc/rc.d/interchange.sh.sample
@${REINPLACE_CMD} -i "" -e 's:%%PREFIX%%:${PREFIX}:' \
${PREFIX}/etc/rc.d/interchange.sh.sample
+ @${REINPLACE_CMD} -i "" -e "s:${PREFIX}:${PREFIX}/interchange:g; s:${PREFIX}/interchange/lib:${PREFIX}/interchange/lib/perl5/site_perl/${PERL_VER}:g; s:${PREFIX}/interchange/bin: ${PREFIX}/bin:g" ${PREFIX}/bin/interchange
.include <bsd.port.mk>