aboutsummaryrefslogtreecommitdiffstats
path: root/www/interchange/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2002-08-31 19:25:57 +0800
committernetchild <netchild@FreeBSD.org>2002-08-31 19:25:57 +0800
commit721ead10f93a0ac19736b65b71efe56c79620d6b (patch)
treeff7f2ab018de1cd75ab2bef079139e640797304e /www/interchange/Makefile
parent0941e4ec2ba507a15e6f98f9450777b5ac8f25ec (diff)
downloadfreebsd-ports-gnome-721ead10f93a0ac19736b65b71efe56c79620d6b.tar.gz
freebsd-ports-gnome-721ead10f93a0ac19736b65b71efe56c79620d6b.tar.zst
freebsd-ports-gnome-721ead10f93a0ac19736b65b71efe56c79620d6b.zip
Add interchange 4.8.6, RedHat's database-enabled e-commerce server.
The committed port is an improved and updated version of the submitted one, thanks to Stefan (Racke) Hornburg <racke@linuxia.de> for his helpful hints about some configure/build internals of interchange. I decided to take over maintainership of this port for a while until someone more responsive than the port submitter (no answer so far from him since I decided to take over the PR) is interested in it or until I think the testing period of this port is over. PR: 41390 Submitted by: Seth Kingsley <sethk@meowfishies.com> Thanks to: Stefan (Racke) Hornburg <racke@linuxia.de>
Diffstat (limited to 'www/interchange/Makefile')
-rw-r--r--www/interchange/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/www/interchange/Makefile b/www/interchange/Makefile
new file mode 100644
index 000000000000..e2acd5fbed78
--- /dev/null
+++ b/www/interchange/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: interchange
+# Date created: 2 July 2002
+# Whom: Seth Kingsley <sethk@meowfishies.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= interchange
+PORTVERSION= 4.8.6
+CATEGORIES= www
+MASTER_SITES= http://ftp.interchange.redhat.com/interchange/4.8/tar/
+
+MAINTAINER= netchild@FreeBSB.org
+
+BUILD_DEPENDS= ${ARCH_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement
+
+RUN_DEPENDS= ${ARCH_PERL}/SQL/Statement.pm:${PORTSDIR}/databases/p5-SQL-Statement \
+ ${ARCH_PERL}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${ARCH_PERL}/Safe/Hole.pm:${PORTSDIR}/security/p5-Safe-Hole \
+ ${ARCH_PERL}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${ARCH_PERL}/MIME/Base64.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/URI/URL.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl \
+ ${ARCH_PERL}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+ARCH_PERL= ${SITE_PERL}/${PERL_ARCH}
+
+MAN1= configdump.1 config_prog.1 expire.1 localize.1 \
+ makecat.1 dump.1 compile_link.1 offline.1 update.1 \
+ restart.1 expireall.1 interchange.1
+MAN7= iccattut.7 icdatabase.7 icadvanced.7 icconfig.7 \
+ icfoundation.7 icfaq.7 ic_howto_cvs.7 icupgrade.7 \
+ ic_ecommerce.7 ictags.7 ictemplates.7
+
+USE_REINPLACE= yes
+
+MAKE_ARGS+= NOCPANINSTALL=1 \
+ INSTALLARCHLIB=${PREFIX}/interchange \
+ INSTALLPRIVLIB=${PREFIX}/interchange/lib/perl5/site_perl/${PERL_VER} \
+ INSTALLMAN1DIR=${PREFIX}/man/man1 \
+ INSTALLMAN3DIR=${PREFIX}/man/man7
+
+CONFIGURE_ARGS+= force=1
+
+pre-configure:
+.if !defined(USE_THIS_PERL) && !defined(BATCH)
+ @[ ! "${PERL_VER}" \< "5.6.1" ] || ( ${ECHO_CMD} -e "You use perl ${PERL_VER}, interchange should be used with 5.6.1 or better,\njust install the newer perl from ports and run 'use.perl port', this will\nmake the new perl the default perl. If you already have some perl modules\ninstalled for your old perl, you have to reinstall them for the new perl.\n\nIf you absolutely want to try to run interchange with perl ${PERL_VER},\nyou have to add '-DUSE_THIS_PERL' as an option for 'make'.\n" ; exit 1 )
+.endif
+.if !defined(CHECK_FOR_IC_USER) && !defined(BATCH)
+ @${ECHO_CMD} -e "This port needs a specific user account ('interch') at configure time.\n\nIf it is ok for you to add a new user at configure time of this port\nadd '-DCHECK_FOR_IC_USER' as an option for 'make'.\n"
+ @exit 1
+.endif
+ @PKG_PREFIX=${PREFIX} ${.CURDIR}/pkg-install ${PKGNAME} PRE-INSTALL
+
+post-install:
+ @${INSTALL_SCRIPT} ${FILESDIR}/interchange.sh \
+ ${PREFIX}/etc/rc.d/interchange.sh.sample
+ @${REINPLACE_CMD} -i "" -e 's:%%PREFIX%%:${PREFIX}:' \
+ ${PREFIX}/etc/rc.d/interchange.sh.sample
+
+.include <bsd.port.mk>