aboutsummaryrefslogtreecommitdiffstats
path: root/www/ismail/files
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-22 07:34:57 +0800
committeredwin <edwin@FreeBSD.org>2004-12-22 07:34:57 +0800
commiteee1efdfd8d0f9c19801193ccccbc714bed1ce1f (patch)
treec3eac3644c056f4b5f7be6a1b89f14d5a0c87ed9 /www/ismail/files
parenteec64e13fbf6696ccfb5fd425a9d6b663da01214 (diff)
downloadfreebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.tar.gz
freebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.tar.zst
freebsd-ports-gnome-eee1efdfd8d0f9c19801193ccccbc714bed1ce1f.zip
New Port: mail/ismail PHP-based webmail client
Inside Systems Mail is a web mail client that makes heavy use of JS, CSS, and DOM to create a snappy, easily configurable and familiar mail interface. PR: ports/68205 Submitted by: Kelley Reynolds <kelley@insidesystems.net>
Diffstat (limited to 'www/ismail/files')
-rw-r--r--www/ismail/files/install.sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/www/ismail/files/install.sh b/www/ismail/files/install.sh
new file mode 100644
index 000000000000..ee5c2f6422d8
--- /dev/null
+++ b/www/ismail/files/install.sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# install.sh v0.1
+#
+# Install script which reads files from the plist and copies them to the appropriate
+# location and makes directories for them if necessary
+
+%%MKDIR%% %%INSTALLDIR%%
+
+# Install the required files
+for file in `cat pkg-plist | grep -v @ | grep ISMAILDIR | sed 's,%%[A-Z]*%%,,g'`; do
+ dir=`echo "${file}" | sed 's,/[^/]*$,/,g'`
+ if [ -d %%WRKSRC%%/ISMail/${dir} ]; then
+ %%MKDIR%% %%INSTALLDIR%%/${dir}
+ fi
+ %%INSTALL_DATA%% %%WRKSRC%%/ISMail/${file} %%INSTALLDIR%%/${file}
+done