aboutsummaryrefslogtreecommitdiffstats
path: root/www/kwebkitpart
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2010-05-11 20:53:49 +0800
committerfluffy <fluffy@FreeBSD.org>2010-05-11 20:53:49 +0800
commit5baf161160e8965a335df29834c56cb8debfe9f8 (patch)
treedddd58712185ed0b67154b6baa85cb702fadafcc /www/kwebkitpart
parent158283c1045859d65559ca4d1faa28ce656a1c41 (diff)
downloadfreebsd-ports-gnome-5baf161160e8965a335df29834c56cb8debfe9f8.tar.gz
freebsd-ports-gnome-5baf161160e8965a335df29834c56cb8debfe9f8.tar.zst
freebsd-ports-gnome-5baf161160e8965a335df29834c56cb8debfe9f8.zip
- Add kwebkitpart, webkit browser component for KDE
With hat on: kde@
Diffstat (limited to 'www/kwebkitpart')
-rw-r--r--www/kwebkitpart/Makefile27
-rw-r--r--www/kwebkitpart/distinfo3
-rw-r--r--www/kwebkitpart/pkg-descr6
-rw-r--r--www/kwebkitpart/pkg-message13
-rw-r--r--www/kwebkitpart/pkg-plist20
5 files changed, 69 insertions, 0 deletions
diff --git a/www/kwebkitpart/Makefile b/www/kwebkitpart/Makefile
new file mode 100644
index 000000000000..de3749b3d843
--- /dev/null
+++ b/www/kwebkitpart/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: kwebkitpart
+# Date created: 4 March 2010
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= kwebkitpart
+DISTVERSION= 0.9.0svn1119520
+CATEGORIES= www kde
+MASTER_SITES= ${MASTER_SITE_LOCAL} \
+ http://people.freebsd.org/~avilla/distfiles/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Web browser component for KDE (KPart)
+
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix
+USE_QT_VER= 4
+QT_COMPONENTS= designer webkit \
+ moc_build qmake_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/kwebkitpart/distinfo b/www/kwebkitpart/distinfo
new file mode 100644
index 000000000000..afa8f1f55211
--- /dev/null
+++ b/www/kwebkitpart/distinfo
@@ -0,0 +1,3 @@
+MD5 (kwebkitpart-0.9.0svn1119520.tar.gz) = ac69883297f5ec27ed1ba9bf83a46cce
+SHA256 (kwebkitpart-0.9.0svn1119520.tar.gz) = d1406fd8c4c338aee276788ca00d502c46e3b558c9968f9ba5881f9749231f10
+SIZE (kwebkitpart-0.9.0svn1119520.tar.gz) = 101756
diff --git a/www/kwebkitpart/pkg-descr b/www/kwebkitpart/pkg-descr
new file mode 100644
index 000000000000..3ae5b23553bc
--- /dev/null
+++ b/www/kwebkitpart/pkg-descr
@@ -0,0 +1,6 @@
+KWebKitPart is a web browser component for KDE (KPart). You can use it
+for example for browsing the web in Konqueror. KWebKitPart is still in
+early development and thus not guaranted to be in production quality
+yet. Please report any issues to: https://bugs.kde.org.
+
+WWW: http://techbase.kde.org/Projects/WebKit
diff --git a/www/kwebkitpart/pkg-message b/www/kwebkitpart/pkg-message
new file mode 100644
index 000000000000..1f9d7a4d23d9
--- /dev/null
+++ b/www/kwebkitpart/pkg-message
@@ -0,0 +1,13 @@
+======================================================================
+
+You can now switch between the different rendering engines in
+Konqueror (a website must be open) through the menu:
+View -> View Mode -> {KHTML, WebKit}.
+If WebKit does not show up in Konqueror, run `kbuildsycoca4` and
+restart Konqueror.
+
+If you want to set KWebKitPart as default for any website, run
+`keditfiletype text/html` and move "WebKit (kwebkitpart)" in the
+"Embedding" tab to the top.
+
+======================================================================
diff --git a/www/kwebkitpart/pkg-plist b/www/kwebkitpart/pkg-plist
new file mode 100644
index 000000000000..8bac9d63232b
--- /dev/null
+++ b/www/kwebkitpart/pkg-plist
@@ -0,0 +1,20 @@
+include/KDE/KWebKitPart
+include/kwebkit_export.h
+include/kwebkitpart.h
+lib/kde4/kwebkitpart.so
+lib/kde4/kwebkitpart.so.0.9.0
+lib/kde4/kwebkitpart.so.1
+lib/libkwebkit.so
+lib/libkwebkit.so.0.9.0
+lib/libkwebkit.so.1
+share/apps/cmake/modules/FindKWebKitPart.cmake
+share/apps/kwebkitpart/error.html
+share/apps/kwebkitpart/kwebkitpart.rc
+share/icons/hicolor/128x128/apps/webkit.png
+share/icons/hicolor/16x16/apps/webkit.png
+share/icons/hicolor/22x22/apps/webkit.png
+share/icons/hicolor/32x32/apps/webkit.png
+share/icons/hicolor/48x48/apps/webkit.png
+share/icons/hicolor/64x64/apps/webkit.png
+share/kde4/services/kwebkitpart.desktop
+@dirrmtry share/apps/kwebkitpart