aboutsummaryrefslogtreecommitdiffstats
path: root/www/libxul/Makefile
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-10-15 23:48:16 +0800
committerbeat <beat@FreeBSD.org>2014-10-15 23:48:16 +0800
commita74915b4ccb3ae9027b4d6eec4fb7a4c1e9ab10a (patch)
treec910dffa13397137a5faa661668aff88ff8d1a77 /www/libxul/Makefile
parent2f11eccc78f3d494312f9e1fa4957f33886b757a (diff)
downloadfreebsd-ports-gnome-a74915b4ccb3ae9027b4d6eec4fb7a4c1e9ab10a.tar.gz
freebsd-ports-gnome-a74915b4ccb3ae9027b4d6eec4fb7a4c1e9ab10a.tar.zst
freebsd-ports-gnome-a74915b4ccb3ae9027b4d6eec4fb7a4c1e9ab10a.zip
- Update Firefox to 33.0
- Update Firefox ESR to 31.2.0 - Update NSS to 3.17.2 - Update Thunderbird to 31.2.0 - Update libxul to 31.2.0 (and mark as BROKEN) - Disable SSL 3.0 with pref (Upstream bug 1076983) - (workaround) replace USE_GCC=yes with USES=compiler:gcc-c++11-lib in order to fix runtime for PGO and powerpc/powerpc64 on libc++ systems - Add OSS audio fallback for HTML5 audio from upstream bug; not exposed yet because WebRTC still needs ALSA or PulseAudio - Kill @dirrm from gecko@ ports per CHANGES from 20140922 - Drop workaround for LLVM PR 19007: base and lang/clang34 have the fix - Improve workaround comment for LLVM PR 15840, partially rejecting r348851 by marino@ until bug 193555 PR: 194356 Submitted by: Jan Beich Security: http://www.vuxml.org/freebsd/9c1495ac-8d8c-4789-a0f3-8ca6b476619c.html
Diffstat (limited to 'www/libxul/Makefile')
-rw-r--r--www/libxul/Makefile51
1 files changed, 37 insertions, 14 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 3554824e7424..ed68631a9056 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -2,37 +2,38 @@
# $FreeBSD$
PORTNAME= libxul
-DISTVERSION= 24.8.1
+DISTVERSION= 31.2.0
CATEGORIES?= www devel
-MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source \
- https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/${DISTVERSION}esr-candidates/build1/source/
+MASTER_SITES= MOZILLA/firefox/releases/${DISTVERSION}esr/source
DISTNAME= firefox-${DISTVERSION}esr.source
MAINTAINER?= gecko@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
-BUILD_DEPENDS= nspr>=4.10.2:${PORTSDIR}/devel/nspr \
- nss>=3.15.4:${PORTSDIR}/security/nss \
- sqlite3>=3.7.17:${PORTSDIR}/databases/sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
+BUILD_DEPENDS= nspr>=4.10.6:${PORTSDIR}/devel/nspr \
+ nss>=3.16.2:${PORTSDIR}/security/nss \
libevent2>=2.0.21_2:${PORTSDIR}/devel/libevent2 \
- cairo>=1.10.2_1,1:${PORTSDIR}/graphics/cairo \
- soundtouch>=1.7.0:${PORTSDIR}/audio/soundtouch \
- harfbuzz>=0.9.16:${PORTSDIR}/print/harfbuzz \
- graphite2>=1.2.3:${PORTSDIR}/graphics/graphite2 \
+ cairo>=1.12.16_1,2:${PORTSDIR}/graphics/cairo \
+ soundtouch>=1.8.0:${PORTSDIR}/audio/soundtouch \
+ harfbuzz>=0.9.25:${PORTSDIR}/print/harfbuzz \
+ graphite2>=1.2.4:${PORTSDIR}/graphics/graphite2 \
libvorbis>=1.3.4:${PORTSDIR}/audio/libvorbis \
opus>=1.1:${PORTSDIR}/audio/opus \
+ libvpx>=1.3.0:${PORTSDIR}/multimedia/libvpx \
+ sqlite3>=3.8.4.2:${PORTSDIR}/databases/sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
v4l_compat>0:${PORTSDIR}/multimedia/v4l_compat \
autoconf-2.13:${PORTSDIR}/devel/autoconf213 \
zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip
+
LIB_DEPENDS= libv4l2.so:${PORTSDIR}/multimedia/libv4l
-WRKSRC= ${WRKDIR}/mozilla-esr24
+WRKSRC= ${WRKDIR}/mozilla-esr31
CONFLICTS= libxul-1.9.*
WANT_GNOME= yes
-USE_QT4= # empty
+USE_QT5= # empty
QT_NONSTANDARD= yes
WANT_PERL= yes
ALL_TARGET= default
@@ -52,10 +53,11 @@ OBJDIR_BUILD= # in-tree build broken after bug 789837
MOZILLA_EXEC_NAME=xulrunner
USE_MOZILLA= # empty
MOZILLA_PLIST_DIRS= bin include lib share/idl libdata
-PLIST_DIRSTRY= share/idl
MOZ_PKGCONFIG_FILES= libxul-embedding libxul mozilla-js \
mozilla-plugin
+BROKEN= build error on js/xpconnect/src/libxpconnect_s.a.desc
+
.include "${.CURDIR}/../../www/firefox/Makefile.options"
.include <bsd.port.pre.mk>
@@ -63,10 +65,31 @@ MOZ_PKGCONFIG_FILES= libxul-embedding libxul mozilla-js \
MOZ_PKGCONFIG_FILES+= mozilla-nss
.endif
+# avoid clang 3.2/3.3 crash in js/src/jsgc.cpp on refillFreeList<(js::AllowGC)1>
+# To be removed when 9.2R goes EOL. http://llvm.org/PR15840
+.if ${ARCH} == i386 && ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION:M3[23]}
+. if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+BROKEN= Cannot build with OPTIMIZED_CFLAGS option due to \
+ a ${CHOSEN_COMPILER_TYPE} bug: unset the option or \
+ use FAVORITE_COMPILER=gcc in Makefile.local/make.conf
+# apply workaround only for -O2 or greater
+. elif ${CXXFLAGS:M-O*} && ! ${CXXFLAGS:M-O[01]}
+. if ${MACHINE_CPU:Msse2}
+CXXFLAGS+= -msse2
+. else
+CXXFLAGS+= -O1
+. endif
+. endif
+.endif
+
.if ${PORT_OPTIONS:MALSA}
RUN_DEPENDS+= alsa-lib>=1.0.27.2_1:${PORTSDIR}/audio/alsa-lib
.endif
+.if ${PORT_OPTIONS:MGSTREAMER}
+RUN_DEPENDS+= gstreamer1-libav>=1.2.4_1:${PORTSDIR}/multimedia/gstreamer1-libav
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/MOZPNG/s/=[0-9]*/=10511/' \
${WRKSRC}/configure.in