aboutsummaryrefslogtreecommitdiffstats
path: root/www/libxul
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
committerFlorian Smeets <flo@FreeBSD.org>2011-08-17 02:36:10 +0800
commit8173943d73eab09d3c9ba4649d627173e9bc55b0 (patch)
tree3ce610d0fe6f85da207f911f1eefe1366b796eec /www/libxul
parent8f71e18f51f19fc09cc0deb4e8af9ac960749331 (diff)
downloadfreebsd-ports-gnome-8173943d73eab09d3c9ba4649d627173e9bc55b0.tar.gz
freebsd-ports-gnome-8173943d73eab09d3c9ba4649d627173e9bc55b0.tar.zst
freebsd-ports-gnome-8173943d73eab09d3c9ba4649d627173e9bc55b0.zip
retire GECKO_PTHREAD_LIBS just use PTHREAD_LIBS.
this will enable compilation with clang. firefox 6 and thunderbid 6 now build fine with clang. other gecko ports should become compilable as soon as they are based on the same gecko version as firefox and thunderbird 6
Diffstat (limited to 'www/libxul')
-rw-r--r--www/libxul/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index f7c936d1e79d..19851191afc5 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -51,8 +51,6 @@ OPTIONS= DBUS "Enable D-BUS support" on
.include <bsd.port.pre.mk>
-GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 '%{\!pg: %{pthread:' | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-
.if ${OSVERSION} < 700000
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
EXTRA_PATCHES= ${FILESDIR}/releng6_pulseaudio
@@ -77,7 +75,7 @@ LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS:C/-pthread/${GECKO_PTHREAD_LIBS}/}|' \
+ ${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|' \
${WRKSRC}/storage/build/Makefile.in \
${WRKSRC}/db/sqlite3/src/Makefile.in
${REINPLACE_CMD} -e 's|/usr/local/include|${LOCALBASE}/include|' \