aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2009-12-01 01:48:17 +0800
committergarga <garga@FreeBSD.org>2009-12-01 01:48:17 +0800
commita9775a9b3f211389f0272dcb5af5be6d32fd72b6 (patch)
tree1a566e9878dba84ff4a99b98facdab4c441ad4f2 /www/lighttpd
parentc64310bf2e01cacba08a3594bbc37e89a804f358 (diff)
downloadfreebsd-ports-gnome-a9775a9b3f211389f0272dcb5af5be6d32fd72b6.tar.gz
freebsd-ports-gnome-a9775a9b3f211389f0272dcb5af5be6d32fd72b6.tar.zst
freebsd-ports-gnome-a9775a9b3f211389f0272dcb5af5be6d32fd72b6.zip
Update to 1.4.25
PR: ports/141027 Submitted by: Ralf van der Enden <tremere@cainites.net> Approved by: mnag (maintainer)
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile5
-rw-r--r--www/lighttpd/distinfo6
-rw-r--r--www/lighttpd/files/patch-src_require.c20
3 files changed, 25 insertions, 6 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index d5366346fac3..08f53d82c35d 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= lighttpd
-PORTVERSION= 1.4.24
+PORTVERSION= 1.4.25
CATEGORIES= www
-MASTER_SITES= http://www.lighttpd.net/download/ \
- http://mirrors.cat.pdx.edu/lighttpd/
+MASTER_SITES= http://download.lighttpd.net/lighttpd/releases-1.4.x/
MAINTAINER= mnag@FreeBSD.org
COMMENT= A secure, fast, compliant, and very flexible Web Server
diff --git a/www/lighttpd/distinfo b/www/lighttpd/distinfo
index c6bcab1f650b..d26322926141 100644
--- a/www/lighttpd/distinfo
+++ b/www/lighttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (lighttpd-1.4.24.tar.bz2) = e2324a24e4a5bce74663c21c58ddd200
-SHA256 (lighttpd-1.4.24.tar.bz2) = 6e643dc4627d742510afee67654291a5190a316f5737dfb463b158a70f24750e
-SIZE (lighttpd-1.4.24.tar.bz2) = 622842
+MD5 (lighttpd-1.4.25.tar.bz2) = 2027c49fb46530e45338c5e2da13c02f
+SHA256 (lighttpd-1.4.25.tar.bz2) = 7e803089f18b179097cb33b64b37d8a3b537ce9c196c88e3fb09881b471c88ce
+SIZE (lighttpd-1.4.25.tar.bz2) = 628267
diff --git a/www/lighttpd/files/patch-src_require.c b/www/lighttpd/files/patch-src_require.c
new file mode 100644
index 000000000000..7ad810855ba5
--- /dev/null
+++ b/www/lighttpd/files/patch-src_require.c
@@ -0,0 +1,20 @@
+--- src/response.c.orig 2009-11-30 13:49:22.000000000 -0200
++++ src/response.c 2009-11-30 13:52:28.000000000 -0200
+@@ -136,6 +136,7 @@
+ X509 *xs;
+ X509_NAME *xn;
+ X509_NAME_ENTRY *xe;
++ int i, nentries;
+ if (
+ SSL_get_verify_result(con->ssl) != X509_V_OK
+ || !(xs = SSL_get_peer_certificate(con->ssl))
+@@ -144,7 +145,8 @@
+ }
+
+ xn = X509_get_subject_name(xs);
+- for (int i = 0, nentries = X509_NAME_entry_count(xn); i < nentries; ++i) {
++ nentries = X509_NAME_entry_count(xn);
++ for (i = 0; i < nentries; ++i) {
+ int xobjnid;
+ const char * xobjsn;
+ data_string *envds;