aboutsummaryrefslogtreecommitdiffstats
path: root/www/lighttpd
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2009-02-25 03:06:37 +0800
committermnag <mnag@FreeBSD.org>2009-02-25 03:06:37 +0800
commitf1b345479624b6c10824f6a924523afad6c4c7c8 (patch)
treeaf3ec25e04e3545a5fca01a399814f279cde0ae5 /www/lighttpd
parentcf0f5a931cc99c6b83263a9c9bf4c7d250257d45 (diff)
downloadfreebsd-ports-gnome-f1b345479624b6c10824f6a924523afad6c4c7c8.tar.gz
freebsd-ports-gnome-f1b345479624b6c10824f6a924523afad6c4c7c8.tar.zst
freebsd-ports-gnome-f1b345479624b6c10824f6a924523afad6c4c7c8.zip
- Backport EPIPE case in sendfile backend. [1]
- portlint(1) - Bump PORTREVISION Reported by: Jeroen Ruigrok van der Werven <asmodai__in-nomine.org> [1]
Diffstat (limited to 'www/lighttpd')
-rw-r--r--www/lighttpd/Makefile3
-rw-r--r--www/lighttpd/files/patch-src__network_freebsd_sendfile.c16
2 files changed, 11 insertions, 8 deletions
diff --git a/www/lighttpd/Makefile b/www/lighttpd/Makefile
index 7c5260380ea0..93af80a68cd0 100644
--- a/www/lighttpd/Makefile
+++ b/www/lighttpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lighttpd
PORTVERSION= 1.4.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.lighttpd.net/download/ \
http://mirrors.cat.pdx.edu/lighttpd/
@@ -23,7 +23,6 @@ GNU_CONFIGURE= yes
USE_GNOME= lthack
USE_RC_SUBR= lighttpd.sh
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/lighttpd
-CONFIGURE_ENV+= CFLAGS="${CFLAGS}"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/www/lighttpd/files/patch-src__network_freebsd_sendfile.c b/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
index f823657de4c1..69cc9d33fc24 100644
--- a/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
+++ b/www/lighttpd/files/patch-src__network_freebsd_sendfile.c
@@ -1,14 +1,18 @@
#
-# Backport http://redmine.lighttpd.net/projects/lighttpd/repository/revisions/2403
+# Backport http://redmine.lighttpd.net/issues/show/1913
#
---- src/network_freebsd_sendfile.c.orig 2009-02-24 11:05:06.000000000 -0300
-+++ src/network_freebsd_sendfile.c 2009-02-24 11:12:15.000000000 -0300
-@@ -167,7 +167,7 @@
+--- src/network_freebsd_sendfile.c.orig 2009-02-05 09:41:44.000000000 -0200
++++ src/network_freebsd_sendfile.c 2009-02-24 15:11:29.000000000 -0300
+@@ -167,8 +167,9 @@
switch(errno) {
case EAGAIN:
case EINTR:
- r = 0; /* try again later */
-+ /* for EAGAIN and EINTR r still contains the sent bytes */
- break;
+- break;
++ /* for EAGAIN/EINTR r still contains the sent bytes */
++ break; /* try again later */
++ case EPIPE:
case ENOTCONN:
return -2;
+ default:
+