aboutsummaryrefslogtreecommitdiffstats
path: root/www/mediawiki116
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-11 06:47:11 +0800
committermiwi <miwi@FreeBSD.org>2006-12-11 06:47:11 +0800
commit3b708ca8af76d128209ab499b13cc677c3a6b966 (patch)
tree586e156e563569749330be445d9986d470bdda29 /www/mediawiki116
parentb6bb44ba8d3dcb66fd5c84704918dc81678ae332 (diff)
downloadfreebsd-ports-gnome-3b708ca8af76d128209ab499b13cc677c3a6b966.tar.gz
freebsd-ports-gnome-3b708ca8af76d128209ab499b13cc677c3a6b966.tar.zst
freebsd-ports-gnome-3b708ca8af76d128209ab499b13cc677c3a6b966.zip
- Add PostgreSQL support
PR: ports/106558 Submitted by: Gerrit Beine<gerrit.beine@gmx.de> (maintainer)
Diffstat (limited to 'www/mediawiki116')
-rw-r--r--www/mediawiki116/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/www/mediawiki116/Makefile b/www/mediawiki116/Makefile
index 0034f5e24d80..8ca6a235bdd0 100644
--- a/www/mediawiki116/Makefile
+++ b/www/mediawiki116/Makefile
@@ -19,15 +19,22 @@ CONFLICTS= mediawiki-1.[0-79].*
NO_BUILD= yes
USE_MYSQL= yes
IGNORE_WITH_MYSQL= 323
-USE_PHP= iconv mbstring pcre session xml zlib readline mysql
+USE_PHP= iconv mbstring pcre session xml zlib readline
IGNORE_WITH_PHP= 4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
-OPTIONS= LDAP "Use LDAP authentication" off
+OPTIONS= PGSQL "Use PostgreSQL instead of MySQL (not funtional)" off \
+ LDAP "Use LDAP authentication" off
.include <bsd.port.pre.mk>
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.else
+USE_PHP+= mysql
+.endif
+
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif