aboutsummaryrefslogtreecommitdiffstats
path: root/www/mini_httpd/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2012-11-20 11:51:01 +0800
committeradamw <adamw@FreeBSD.org>2012-11-20 11:51:01 +0800
commit956fc4b3a762c73e4fea94af4a683ab502186ef7 (patch)
treef181efb579a313b002890aed41580e21520903ff /www/mini_httpd/Makefile
parent4d323b64a7e61da884c0763edafacccf3600a321 (diff)
downloadfreebsd-ports-gnome-956fc4b3a762c73e4fea94af4a683ab502186ef7.tar.gz
freebsd-ports-gnome-956fc4b3a762c73e4fea94af4a683ab502186ef7.tar.zst
freebsd-ports-gnome-956fc4b3a762c73e4fea94af4a683ab502186ef7.zip
This port installs its own version of htpasswd(1), but rather than
registering CONFLICTS between it and the various apache versions, just call mini_httpd's htpasswd by another name. Bundled manpages updated for this as well. Also, htpasswd was being moved to man8, but I'm putting it back into man1 where apache's htpasswd is. Feature safe: yes
Diffstat (limited to 'www/mini_httpd/Makefile')
-rw-r--r--www/mini_httpd/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/mini_httpd/Makefile b/www/mini_httpd/Makefile
index 3e254886a3e9..1ce151291538 100644
--- a/www/mini_httpd/Makefile
+++ b/www/mini_httpd/Makefile
@@ -17,20 +17,20 @@ COMMENT= Small HTTP server with support for GET, HEAD, POST, CGI, SSL, IPv6
MAKE_ARGS+= -DUSE_OPENSSL
.endif
-MAN8= mini_httpd.8 htpasswd.8
+MAN1= ${PORTNAME}-htpasswd.1
+MAN8= ${PORTNAME}.8
-post-build:
- -${MV} ${WRKSRC}/htpasswd.1 ${WRKSRC}/htpasswd.8
+post-patch:
+ ${REINPLACE_CMD} -e 's/htpasswd/${PORTNAME}-htpasswd/g' ${WRKSRC}/htpasswd.1
+ ${REINPLACE_CMD} -e 's/\(htpasswd(1)\)/${PORTNAME}-\1/g' ${WRKSRC}/${PORTNAME}.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mini_httpd ${PREFIX}/sbin/
- ${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${PREFIX}/sbin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/htpasswd ${PREFIX}/sbin/${PORTNAME}-htpasswd
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd_wrapper ${PREFIX}/sbin/
${INSTALL_SCRIPT} ${WRKSRC}/scripts/mini_httpd.sh ${PREFIX}/etc/rc.d/
- @for file in ${MAN8}; \
- do \
- ${INSTALL_MAN} ${WRKSRC}/$$file ${PREFIX}/man/man8/; \
- done
+ ${INSTALL_MAN} ${WRKSRC}/htpasswd ${PREFIX}/man/man1/${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${PREFIX}/man/man8
${INSTALL_DATA} ${WRKSRC}/mini_httpd.cnf ${PREFIX}/etc/mini_httpd.cnf.sample
.include <bsd.port.mk>