aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_evasive
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-03-06 07:57:00 +0800
committerJohn Marino <marino@FreeBSD.org>2016-03-06 07:57:00 +0800
commit89a819df065b8c67a3395c57093e8ce9aa334104 (patch)
tree0caaf90e57004199137d28416510a6ad6542f0dc /www/mod_evasive
parentbecf8514c620efee8a40faddd616757f8ac764d0 (diff)
downloadfreebsd-ports-gnome-89a819df065b8c67a3395c57093e8ce9aa334104.tar.gz
freebsd-ports-gnome-89a819df065b8c67a3395c57093e8ce9aa334104.tar.zst
freebsd-ports-gnome-89a819df065b8c67a3395c57093e8ce9aa334104.zip
www/mod_evasive: Add support for Apache 2.4
The solution to fixing mod_evasive support for Apache 2.4 has been available on the internet for well over a year and it's trivial. Reported by: Bill Richter Approved by: just-fix-it
Diffstat (limited to 'www/mod_evasive')
-rw-r--r--www/mod_evasive/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/www/mod_evasive/Makefile b/www/mod_evasive/Makefile
index 635b0e3e7e17..63e00d25da0d 100644
--- a/www/mod_evasive/Makefile
+++ b/www/mod_evasive/Makefile
@@ -16,20 +16,25 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_APACHE= 22
+USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
MODULENAME= ${PORTNAME}20
PORTDOCS= README test.pl
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e "s|/bin/mail|/usr/bin/mail|g" \
${WRKSRC}/mod_evasive.c ${WRKSRC}/mod_evasive20.c \
${WRKSRC}/mod_evasiveNSAPI.c
+.if ${APACHE_VERSION:M24}
+ ${REINPLACE_CMD} -e 's/remote_ip/client_ip/g' ${WRKSRC}/mod_evasive20.c
+.endif
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>