aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_frontpage
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2002-04-28 19:48:18 +0800
committermbr <mbr@FreeBSD.org>2002-04-28 19:48:18 +0800
commitc23560af96c1d85305b08124b5443e22ba9930c0 (patch)
tree65eae27229a7881a58b982b446923b6a67a412e3 /www/mod_frontpage
parent1649fd9cde1a3aa606371f66be3cee11b598d7a3 (diff)
downloadfreebsd-ports-gnome-c23560af96c1d85305b08124b5443e22ba9930c0.tar.gz
freebsd-ports-gnome-c23560af96c1d85305b08124b5443e22ba9930c0.tar.zst
freebsd-ports-gnome-c23560af96c1d85305b08124b5443e22ba9930c0.zip
Make changing passwords running. Add patch posted to sourge-forge with
little modifications. Bump PORTREVISION.
Diffstat (limited to 'www/mod_frontpage')
-rw-r--r--www/mod_frontpage/Makefile1
-rw-r--r--www/mod_frontpage/files/patch-fpstatic.c27
-rw-r--r--www/mod_frontpage/files/patch-path.h10
3 files changed, 38 insertions, 0 deletions
diff --git a/www/mod_frontpage/Makefile b/www/mod_frontpage/Makefile
index ebba13a1bf37..b7e7a3b36826 100644
--- a/www/mod_frontpage/Makefile
+++ b/www/mod_frontpage/Makefile
@@ -6,6 +6,7 @@
PORTNAME= mod_frontpage
PORTVERSION= 1.6.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://people.freebsd.org/~mbr/distfiles/
diff --git a/www/mod_frontpage/files/patch-fpstatic.c b/www/mod_frontpage/files/patch-fpstatic.c
new file mode 100644
index 000000000000..cbd4eb1ebaf2
--- /dev/null
+++ b/www/mod_frontpage/files/patch-fpstatic.c
@@ -0,0 +1,27 @@
+--- fpstatic.c.orig Tue Feb 5 16:16:46 2002
++++ fpstatic.c Sun Apr 28 13:33:01 2002
+@@ -435,6 +435,24 @@
+ snprintf((char *)fnbuf, sizeof(fnbuf), "%s%s%s%s%s",
+ FPBASE, _EXES, _VTI_ADM, _IMAGES, pos);
+ /*
++ * Check to see if the user is changing the password,
++ * which has a URL like _vti_bin/_vti_aut/ passwd.htm.
++ * It's different from other ".htm" files because it
++ * goes through _VTI_AUT instead of _VTI_ADM and it
++ * may not have the Lcid in the URL. If it's missing
++ * the Lcid, hard-code it to 1033 like the rtr patches.
++ */
++ } else if (((pos = strstr(uri, _FPPASSWD)) != NULL)) {
++ pos = strstr(uri, _VTI_AUT);
++ pos = pos + 19;
++ Lcid = (int)strtol(pos, &pos, 10);
++ if (Lcid == 0) {
++ Lcid = 1033;
++ }
++ pos = strrchr((char *)uri, '/');
++ snprintf((char *)fnbuf, sizeof(fnbuf), "%s%s%c%04d%s",
++ FPBASE, _ADMIN, '/', Lcid, pos);
++ /*
+ * If we still have .htm or .css, we end up
+ * with the admin dir. If we match, we calculate
+ * the Lcid from the string.
diff --git a/www/mod_frontpage/files/patch-path.h b/www/mod_frontpage/files/patch-path.h
new file mode 100644
index 000000000000..033e6287d936
--- /dev/null
+++ b/www/mod_frontpage/files/patch-path.h
@@ -0,0 +1,10 @@
+--- path.h.orig Tue Feb 5 16:39:14 2002
++++ path.h Sun Apr 28 13:33:08 2002
+@@ -67,6 +67,7 @@
+ #define _HELP "/help"
+ #define _EXES "/exes"
+ #define _ADMIN "/admin"
++#define _FPPASSWD "/passwd.htm"
+
+ #define VTIHELP _VTI_BIN "/_vti_adm/help"
+ #define SHTMLDLL _VTI_BIN "/shtml.dll"