aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_ntlm2
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-08 02:40:03 +0800
committermiwi <miwi@FreeBSD.org>2008-07-08 02:40:03 +0800
commit270e5789a23582529d503f12f6d51b0e078e739d (patch)
tree6688af3b03909af07ecbeec8519b27c431bbc0e1 /www/mod_ntlm2
parent9b0e4a8bb403c82389fb34ed79790987985c1f2b (diff)
downloadfreebsd-ports-gnome-270e5789a23582529d503f12f6d51b0e078e739d.tar.gz
freebsd-ports-gnome-270e5789a23582529d503f12f6d51b0e078e739d.tar.zst
freebsd-ports-gnome-270e5789a23582529d503f12f6d51b0e078e739d.zip
- Unbreak
- Fix build with gcc 4.2 PR: 125207 Submitted by: Alex Keda <admin@lissyara.su> (maintainer)
Diffstat (limited to 'www/mod_ntlm2')
-rw-r--r--www/mod_ntlm2/Makefile4
-rw-r--r--www/mod_ntlm2/files/patch-smbval-smblib.inc.c24
2 files changed, 19 insertions, 9 deletions
diff --git a/www/mod_ntlm2/Makefile b/www/mod_ntlm2/Makefile
index c225233d9ce8..34420befc226 100644
--- a/www/mod_ntlm2/Makefile
+++ b/www/mod_ntlm2/Makefile
@@ -22,8 +22,4 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/smbclient:${PORTSDIR}/net/samba3
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile
-.endif
-
.include <bsd.port.post.mk>
diff --git a/www/mod_ntlm2/files/patch-smbval-smblib.inc.c b/www/mod_ntlm2/files/patch-smbval-smblib.inc.c
index 4a985c6182b2..69b926c42998 100644
--- a/www/mod_ntlm2/files/patch-smbval-smblib.inc.c
+++ b/www/mod_ntlm2/files/patch-smbval-smblib.inc.c
@@ -1,11 +1,25 @@
---- smbval/smblib.inc.c.orig Wed Sep 26 12:42:22 2007
-+++ smbval/smblib.inc.c Wed Sep 26 12:43:08 2007
-@@ -20,7 +20,7 @@
+--- smbval/smblib.inc.c.orig 2008-07-03 01:44:33.000000000 +0400
++++ smbval/smblib.inc.c 2008-07-03 01:45:18.000000000 +0400
+@@ -20,10 +20,10 @@
* with this program; if not, write to the Free Software Foundation, Inc.,
* 675 Mass Ave, Cambridge, MA 02139, USA. */
#include <stdio.h>
-#include <malloc.h>
+#include <stdlib.h>
- static int SMBlib_errno;
- static int SMBlib_SMB_Error;
+-static int SMBlib_errno;
+-static int SMBlib_SMB_Error;
++int SMBlib_errno;
++int SMBlib_SMB_Error;
+ #define SMBLIB_ERRNO
+ #define uchar unsigned char
+ #include "smblib-priv.h"
+@@ -32,7 +32,7 @@
+
+ #include <signal.h>
+
+-static SMB_State_Types SMBlib_State;
++SMB_State_Types SMBlib_State;
+
+ /* Initialize the SMBlib package */
+ static int