aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_perl2/Makefile
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2013-04-21 00:29:57 +0800
committerohauer <ohauer@FreeBSD.org>2013-04-21 00:29:57 +0800
commitd978ea1456439a2dea7d106eb13933b6ba7ec37a (patch)
treec251fa097011d20c18650386badf5e8a90b95732 /www/mod_perl2/Makefile
parent4b81d0ee97928e926d3953e8e51c45655aa5ea81 (diff)
downloadfreebsd-ports-gnome-d978ea1456439a2dea7d106eb13933b6ba7ec37a.tar.gz
freebsd-ports-gnome-d978ea1456439a2dea7d106eb13933b6ba7ec37a.tar.zst
freebsd-ports-gnome-d978ea1456439a2dea7d106eb13933b6ba7ec37a.zip
- update to 2.0.8
2.0.8 April 17, 2013 Perl 5.16.3's fix for a rehash-based DoS makes it more difficult to invoke the workaround for the old hash collision attack, which breaks mod_perl's t/perl/hash_attack.t. Patch from rt.cpan.org #83916 improves the fix previously applied as revision 1455340. [Zefram] On Perl 5.17.6 and above, hash seeding has changed, and HvREHASH has disappeared. Patch to update mod_perl accordingly from rt.cpan.org #83921. [Zefram] Restore build with Perl 5.8.1, 5.8.2 etc: take care to use $Config{useithreads} rather than $Config{usethreads}, and supply definitions of Newx and Newxz as necessary. [Steve Hay] On Perl 5.17.9, t/apache/read2.t fails because an "uninitialized value" warning is generated for the buffer being autovivified. This is because the sv_setpvn() that's meant to vivify the buffer doesn't perform set magic; the warning is generated by the immediately following SvPV_force(). Patch to fix this from rt.cpan.org #83922. [Zefram] Fix t/perl/hash_attack.t to work with Perl 5.14.4, 5.16.3 etc, which contain a fix for CVE-2013-1667 (memory exhaustion with arbitrary hash keys). This resolves rt.perl.org #116863, from where the patch was taken. [Hugo van der Sanden] use APR::Finfo instead of Perl's stat() in ModPerl::RegistryCooker to generate HTTP code 404 even if the requested filename contains newlines [Torsten] Remove all uses of deprecated core perl symbols. [Steve Hay] Feature safe: yes with hat apache@
Diffstat (limited to 'www/mod_perl2/Makefile')
-rw-r--r--www/mod_perl2/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index cf5108ad19c4..8ef61f37fbb5 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: mod_perl2
-# Date created: February 13th 2003
-# Whom: Lars Eggert <larse@isi.edu>
-#
+# Created by: Lars Eggert <larse@isi.edu>
# $FreeBSD$
-#
PORTNAME= mod_perl
-PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTVERSION= 2.0.8
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= APACHE/perl
@@ -96,6 +91,9 @@ PLIST_SUB+= THREADRWLOCK="@comment "
post-patch:
${REINPLACE_CMD} -e 's/APR_INLINE//g' \
${PATCH_WRKSRC}/src/modules/perl/modperl_common_util.h
+ ${REINPLACE_CMD} -e "s|/usr/local/apache/bin/apxs|${APXS}|" \
+ -e "s|'bin', 'apxs'|'sbin', 'apxs'|" \
+ ${WRKSRC}/lib/Apache2/Build.pm
post-configure:
${REINPLACE_CMD} -e 's/-pthread -Wl,-E//g' \
@@ -114,4 +112,7 @@ post-install:
${APXS} -e -A -n perl ${PREFIX}/${APACHEMODDIR}/mod_perl.so
@${CAT} ${PKGMESSAGE}
+test: build
+ -@(cd ${WRKSRC} && ${MAKE} test)
+
.include <bsd.port.post.mk>