aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2000-01-13 00:46:54 +0800
committersheldonh <sheldonh@FreeBSD.org>2000-01-13 00:46:54 +0800
commitcb2c43084c8887721adcb2001bd6b779875b5e36 (patch)
tree1485341efe9354874a1fd42e4f09238c12864869 /www/mod_perl2
parent0ef44c9b5b4e11f65e5d10e6e0c02b0c4985146e (diff)
downloadfreebsd-ports-gnome-cb2c43084c8887721adcb2001bd6b779875b5e36.tar.gz
freebsd-ports-gnome-cb2c43084c8887721adcb2001bd6b779875b5e36.tar.zst
freebsd-ports-gnome-cb2c43084c8887721adcb2001bd6b779875b5e36.zip
Mark BROKEN for CURRENT with appropriate reference to a PR.
Install src/modules/perl/*.h (suggested by author). Change some ${PREFIX} to ${LOCALBASE}. Add RUN_DEPENDS for apache. Although this breaks the ability to select an Apache flavour for the package, it's necessary (asami). PR: 15988 Submitted by: Igor Vinokurov <igor@zynaps.ru>
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile20
-rw-r--r--www/mod_perl2/pkg-plist6
2 files changed, 21 insertions, 5 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 9c49317a0123..dd0c05c89b5b 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: p5-Apache
+# New ports collection makefile for: mod_perl
# Version required: 1.21
# Date created: November 5th 1999
# Whom: Sheldon Hearn <sheldonh@FreeBSD.org>
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= Apache
MAINTAINER= sheldonh@FreeBSD.org
-BUILD_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
USE_PERL5= YES
@@ -33,13 +34,22 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
mod_perl_tuning.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 400000
+BROKEN= "see PR 14924; use p5-Apache instead"
+.endif
+
do-configure:
@ cd ${WRKSRC}; \
${PERL5} Makefile.PL USE_APXS=1 EVERYTHING=1 \
- WITH_APXS=${PREFIX}/sbin/apxs \
+ WITH_APXS=${LOCALBASE}/sbin/apxs \
PERL_EXTRA_CFLAGS='-DDEFAULT_PATH=\"/bin:/usr/bin:/usr/local/bin\"'
post-install:
- @ ${SH} ${PKGINSTALL}
+ ${MKDIR} ${PREFIX}/include/apache/modules/perl
+ ${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \
+ ${PREFIX}/include/apache/modules/perl
+ ${SH} ${PKGINSTALL}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index b949dc4f4e19..bcb52606dca8 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -1,3 +1,7 @@
+include/apache/modules/perl/mod_perl.h
+include/apache/modules/perl/mod_perl_version.h
+include/apache/modules/perl/mod_perl_xs.h
+include/apache/modules/perl/perl_PL.h
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Connection.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Constants.pm
@@ -51,6 +55,8 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/mod_perl_method_handlers.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/mod_perl_traps.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/mod_perl_tuning.pod
libexec/apache/libperl.so
+@dirrm include/apache/modules/perl
+@dirrm include/apache/modules
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Constants
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bundle