aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php4/Makefile
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>1997-09-04 02:45:16 +0800
committerandreas <andreas@FreeBSD.org>1997-09-04 02:45:16 +0800
commitd7dd0c0e1b95c5793c2544097722f9e8393d436a (patch)
treed56e0d7430d816818b6ca19fe79032993721b43b /www/mod_php4/Makefile
parent1c221f8a634d795d09dda1ea0f988d79d8ae67b8 (diff)
downloadfreebsd-ports-gnome-d7dd0c0e1b95c5793c2544097722f9e8393d436a.tar.gz
freebsd-ports-gnome-d7dd0c0e1b95c5793c2544097722f9e8393d436a.tar.zst
freebsd-ports-gnome-d7dd0c0e1b95c5793c2544097722f9e8393d436a.zip
Apache 1.2.1 + PHP support
Currently 2 kind of databases will be supported, msql and mysql The problem is, that depending on the flavour of database you want to support, you need a different set of patches to apache's Makefile, so that header and loader flags, paths and libs are correctly resolved ... I marked this port as BROKEN, since I wasn't able, to exactly check the whole port due to the fact, that currently I only have one db installed. Will try to get it managed next weekend. Well if someone is so keen, then simply remove BROKEN and you should be able to use what's already possible ...
Diffstat (limited to 'www/mod_php4/Makefile')
-rw-r--r--www/mod_php4/Makefile65
1 files changed, 56 insertions, 9 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index a5bd21906cdd..81f04ae3aa0d 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -1,20 +1,49 @@
-# New ports collection makefile for: apache HTTPD
-# Version required: 1.2.1
-# Date created: Fri Aug 25 16:42:36 CDT 1995
-# Whom: erich@rrnet.com
+# New ports collection makefile for: apache HTTPD / php 2.0b12
+# Version required: 1.2.1 / 2.0b12
+# Date created: Wed Sep 3 18:28:20 CEST 1997
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
#
-# $Id: Makefile,v 1.37 1997/08/13 15:05:03 ache Exp $
+# $Id$
#
DISTNAME= apache_1.2.1
-PKGNAME= apache-1.2.1
CATEGORIES= www
-MASTER_SITES= ftp://www.apache.org/apache/dist/
+MASTER_SITES= ftp://www.apache.org/apache/dist/ \
+ ftp://ftp.nerosworld.com/pub/php/dist/ \
+ ftp://ftp.u-aizu.ac.jp/pub/net/www/php \
+ ftp://ftpza.co.za/pub/mirrors/php/
+DISTFILES= apache_1.2.1.tar.gz \
+ php-2.0b12.tar.gz
-MAINTAINER= ports@freebsd.org
+MAINTAINER= andreas@FreeBSD.ORG
+
+NO_PACKAGE= "Too many questions"
+IS_INTERACTIVE= yes
+BROKEN= "Am working on it..."
+
+#
+# Currently we support two db's: msql and mysql
+#
+.if !defined(PHP_DBTYPE)
+pre-fetch:
+ @echo
+ @echo "You must set variable PHP_DBTYPE to msql or mysql by typing"
+ @echo "make PHP_DBTYPE=[ msql | mysql ]"
+ @false
+
+.elif defined(PHP_DBTYPE)
+.if ${PHP_DBTYPE} == msql
+BUILD_DEPENDS= msql:${PORTSDIR}/databases/msql
+PATCHDIR= ${.CURDIR}/patches.msql
+
+.elif ${PHP_DBTYPE} == mysql
+BUILD_DEPENDS= mysql:${PORTSDIR}/databases/mysql
+PATCHDIR= ${.CURDIR}/patches.mysql
+.endif
+.endif
# Set it for local-supplied patch, f.e.
-# VERS_ID = mods-1.0/me
+VERS_ID = php-2.0b12/andreas
.if defined(VERS_ID)
post-patch:
@@ -24,6 +53,19 @@ post-patch:
< Configuration.old > Configuration
.endif
+
+pre-configure:
+ echo "Don\'t forget to add ${PREFIX}/include/gd to additional path !!!"
+ ( cd ${WRKDIR}/php-2.0b12; ./install )
+ ( cd ${WRKDIR}/php-2.0b12/src; make )
+ ( cd ${WRKDIR}/php-2.0b12/src \
+ && cp mod_php.c mod_php.h libphp.a ../../apache_1.2.1/src )
+ ( cd ${WRKDIR}/apache_1.2.1/src \
+ && echo "Module php_module mod_php.o" \
+ >> Configuration \
+ && echo "EXTRA_LIBS=-lmd libphp.a -L/usr/local/lib -lmsql -lgd -lm" \
+ >> Configuration )
+
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
@@ -31,5 +73,10 @@ post-install:
echo "[ -x /usr/local/sbin/httpd ] && /usr/local/sbin/httpd && echo -n ' httpd'" >> ${PREFIX}/etc/rc.d/apache.sh; \
chmod 751 ${PREFIX}/etc/rc.d/apache.sh; \
fi
+ echo "AddType application/x-httpd-php .phtml" \
+ > ${PREFIX}/etc/apache/srm.conf.php
+ echo "Don't forget to enable php support in \
+ ${PREFIX}/etc/apache/srm.conf"
+ echo "See ${PREFIX}/etc/apache/srm.conf.php"
.include <bsd.port.mk>