aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php4
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-12-04 15:27:41 +0800
committerdirk <dirk@FreeBSD.org>2001-12-04 15:27:41 +0800
commit91775af8739f6bf96349cfba787ebb559d7939a4 (patch)
tree435226a051b26855ae39f1db46d0b51f7b39a4b8 /www/mod_php4
parent1165520cdc17fb6787668568df6959b757ee1465 (diff)
downloadfreebsd-ports-gnome-91775af8739f6bf96349cfba787ebb559d7939a4.tar.gz
freebsd-ports-gnome-91775af8739f6bf96349cfba787ebb559d7939a4.tar.zst
freebsd-ports-gnome-91775af8739f6bf96349cfba787ebb559d7939a4.zip
Add --enable-discard-path and --with-readline to lang/php4.
Submitted by: Rafal Michalski <rafal.michalski@altech.com.pl>
Diffstat (limited to 'www/mod_php4')
-rw-r--r--www/mod_php4/Makefile4
-rw-r--r--www/mod_php4/files/patch-ext_readline_readline.c38
2 files changed, 41 insertions, 1 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index 165cbdbdba0d..b7c0dc78d678 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -40,7 +40,9 @@ IS_INTERACTIVE= yes
.if defined(STANDALONE)
CONFIGURE_ARGS= --with-config-file-path=${PREFIX}/etc/php.standalone \
- --disable-pear
+ --disable-pear \
+ --enable-discard-path \
+ --with-readline=/usr
.else
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--with-config-file-path=${PREFIX}/etc
diff --git a/www/mod_php4/files/patch-ext_readline_readline.c b/www/mod_php4/files/patch-ext_readline_readline.c
new file mode 100644
index 000000000000..a757f740e64a
--- /dev/null
+++ b/www/mod_php4/files/patch-ext_readline_readline.c
@@ -0,0 +1,38 @@
+--- ext/readline/readline.c.orig Thu May 24 14:42:05 2001
++++ ext/readline/readline.c Tue Dec 4 08:14:49 2001
+@@ -57,7 +57,7 @@
+ PHP_FE(readline_info, NULL)
+ PHP_FE(readline_add_history, NULL)
+ PHP_FE(readline_clear_history, NULL)
+-#ifdef HAVE_READLINE
++#ifdef HAVE_LIBREADLINE
+ PHP_FE(readline_list_history, NULL)
+ #else
+ PHP_FALIAS(readline_list_history, warn_not_available, NULL)
+@@ -147,7 +147,7 @@
+ add_assoc_string(return_value,"line_buffer",SAFE_STRING(rl_line_buffer),1);
+ add_assoc_long(return_value,"point",rl_point);
+ add_assoc_long(return_value,"end",rl_end);
+-#ifdef HAVE_READLINE
++#ifdef HAVE_LIBREADLINE
+ add_assoc_long(return_value,"mark",rl_mark);
+ add_assoc_long(return_value,"done",rl_done);
+ add_assoc_long(return_value,"pending_input",rl_pending_input);
+@@ -174,7 +174,7 @@
+ RETVAL_LONG(rl_point);
+ } else if (! strcasecmp((*what)->value.str.val,"end")) {
+ RETVAL_LONG(rl_end);
+-#ifdef HAVE_READLINE
++#ifdef HAVE_LIBREADLINE
+ } else if (! strcasecmp((*what)->value.str.val,"mark")) {
+ RETVAL_LONG(rl_mark);
+ } else if (! strcasecmp((*what)->value.str.val,"done")) {
+@@ -256,7 +256,7 @@
+ /* }}} */
+ /* {{{ proto array readline_list_history(void)
+ Lists the history */
+-#ifdef HAVE_READLINE
++#ifdef HAVE_LIBREADLINE
+ PHP_FUNCTION(readline_list_history)
+ {
+ HIST_ENTRY **history;