aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-06-25 02:19:17 +0800
committerDirk Froemberg <dirk@FreeBSD.org>2001-06-25 02:19:17 +0800
commit479004b56ba865d19eebca75dc410e178aad778f (patch)
treec7e73b65e3901539bb11ab68c5b95fd52234c318 /www/mod_php5
parent129b7f43c4e8ffe4db20dffa9480e753ffc01dd6 (diff)
downloadfreebsd-ports-gnome-479004b56ba865d19eebca75dc410e178aad778f.tar.gz
freebsd-ports-gnome-479004b56ba865d19eebca75dc410e178aad778f.tar.zst
freebsd-ports-gnome-479004b56ba865d19eebca75dc410e178aad778f.zip
Upgrade to 4.0.6:
jstring support was included in php (as mbstring), so split japanese support into mbregex and mbstring support.
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/Makefile3
-rw-r--r--www/mod_php5/distinfo3
-rw-r--r--www/mod_php5/scripts/configure.php19
3 files changed, 13 insertions, 12 deletions
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 17a96ace54b3..35eb0477d115 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME?= mod_php4
-PORTVERSION= 4.0.5
-PORTREVISION= 2
+PORTVERSION= 4.0.6
CATEGORIES?= www
MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php.he.net/${PHP_DISTDIR}/ \
diff --git a/www/mod_php5/distinfo b/www/mod_php5/distinfo
index 68aee9d38251..db01ee6dac3c 100644
--- a/www/mod_php5/distinfo
+++ b/www/mod_php5/distinfo
@@ -1,3 +1,2 @@
-MD5 (php-4.0.5.tar.gz) = 763739f64eeac7099035fd86c1d39ad2
-MD5 (php4_jstring-1.1.1.tar.gz) = ac23be7b9ceb107641f2c5dcbd027cee
+MD5 (php-4.0.6.tar.gz) = 5f698521cf2b392cf9bfa87fc1a0fe90
MD5 (php4_mbregex-1.2.1.tar.gz) = 46d151afa9ab668df880a70cf786a2c2
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index e05851470ad8..96e34687d33b 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -36,7 +36,8 @@ CURL "CURL support" OFF \
gettext "gettext library support" OFF \
iconv "iconv support" OFF \
pspell "pspell support" OFF \
-japanese "jstring and mbregex module" OFF \
+mbregex "multibyte regular expressions module" OFF \
+mbstring "multibyte string module" OFF \
YP "YP/NIS support" OFF \
BCMath "BCMath support" OFF \
Hyperwave "Hyperwave support" OFF \
@@ -209,25 +210,27 @@ while [ "$1" ]; do
echo "LIB_DEPENDS+= pspell.4:\${PORTSDIR}/textproc/pspell"
echo "CONFIGURE_ARGS+=--with-pspell=\${PREFIX}"
;;
- \"japanese\")
+ \"mbregex\")
${CAT} << EOF
MASTER_SITES+= ftp://night.fminn.nagano.nagano.jp/php4/
-DISTFILES= \${DISTNAME}\${EXTRACT_SUFX} php4_jstring-1.1.1.tar.gz php4_mbregex-1.2.1.tar.gz
-CONFIGURE_ARGS+=--enable-jstring --enable-mbregex
+DISTFILES= \${DISTNAME}\${EXTRACT_SUFX} php4_mbregex-1.2.1.tar.gz
+CONFIGURE_ARGS+=--enable-mbregex
BUILD_DEPENDS+= automake:\${PORTSDIR}/devel/automake
BUILD_DEPENDS+= autoconf:\${PORTSDIR}/devel/autoconf
-POSTEXTRACT+= post-extract-japanese
+POSTEXTRACT+= post-extract-mbregex
-post-extract-japanese:
- [ -d \${WRKDIR}/jstring -a \${WRKDIR}/mbregex ] && \\
+post-extract-mbregex:
+ [ -d \${WRKDIR}/mbregex ] && \\
(cd \${WRKSRC}; \\
- \${MV} ${WRKDIR}/jstring ext; \\
\${MV} ${WRKDIR}/mbregex ext; \\
\${RM} configure; \\
./buildconf)
EOF
;;
+ \"mbstring\")
+ echo "CONFIGURE_ARGS+=--enable-mbstring"
+ ;;
\"YP\")
echo "CONFIGURE_ARGS+=--enable-yp"
;;