aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2000-01-03 01:17:29 +0800
committerdirk <dirk@FreeBSD.org>2000-01-03 01:17:29 +0800
commit4dd0d6cb085098d1ed27f03bccb7321105975d90 (patch)
tree00c7ae55e8819303a96ce7532eb83f0a45f49924 /www/mod_php5
parent3aaeee764299c4b205ca4e985a55fd515380bca0 (diff)
downloadfreebsd-ports-gnome-4dd0d6cb085098d1ed27f03bccb7321105975d90.tar.gz
freebsd-ports-gnome-4dd0d6cb085098d1ed27f03bccb7321105975d90.tar.zst
freebsd-ports-gnome-4dd0d6cb085098d1ed27f03bccb7321105975d90.zip
- Use CC and CFLAGS for first configure run.
- gd depends on freetype, now. So join gd and freetype support in one option.
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/Makefile2
-rw-r--r--www/mod_php5/scripts/configure.php14
2 files changed, 3 insertions, 13 deletions
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 5676d2e82dfd..fa1f9318f137 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -118,7 +118,7 @@ post-extract:
pre-configure:
@cd ${WRKSRC} \
- && ./configure > /dev/null \
+ && CC="${CC}" CFLAGS="${CFLAGS}" ./configure > /dev/null \
&& cd ${WRKDIR}/php-${VERSION_PHP} \
&& ${ECHO_MSG} "===> Configuring for PHP-${VERSION_PHP}" \
&& CC="${CC}" \
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 0d64999efa95..69c82360556e 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -15,8 +15,7 @@ fi
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
-GD "PHP: GD library support" OFF \
-FreeType "PHP: TrueType font rendering (implies GD)" OFF \
+GD "PHP: GD support & FreeType font rendering" OFF \
zlib "PHP: zlib library support" ON \
mcrypt "PHP: Encryption support" OFF \
mhash "PHP: Crypto-hashing support" OFF \
@@ -61,18 +60,9 @@ while [ "$1" ]; do
;;
\"nothing\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"
- echo "PHP_CONF_ARGS+= --with-gd=\${PREFIX}"
- GD=1
- ;;
- \"FreeType\")
- echo "FreeType is DISABLED for now. Ignoring." > /dev/stderr
- ;;
- \"nothing\")
echo "LIB_DEPENDS+= ttf.4:\${PORTSDIR}/print/freetype"
+ echo "PHP_CONF_ARGS+= --with-gd=\${PREFIX}"
echo "PHP_CONF_ARGS+= --with-ttf=\${PREFIX}"
- if [ -z "$GD" ]; then
- set $* \"GD\"
- fi
;;
\"zlib\")
echo "PHP_CONF_ARGS+= --with-zlib"