aboutsummaryrefslogtreecommitdiffstats
path: root/www/mod_php5
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-04-16 19:50:14 +0800
committerdirk <dirk@FreeBSD.org>2001-04-16 19:50:14 +0800
commit6545a0761675e7e5d68f15cf050a8fd867ea663d (patch)
tree3a24cbfd25a7b684816e8414c046822b15e34389 /www/mod_php5
parent57c9cd66757b59a758c618d361c31371345b89fd (diff)
downloadfreebsd-ports-gnome-6545a0761675e7e5d68f15cf050a8fd867ea663d.tar.gz
freebsd-ports-gnome-6545a0761675e7e5d68f15cf050a8fd867ea663d.tar.zst
freebsd-ports-gnome-6545a0761675e7e5d68f15cf050a8fd867ea663d.zip
Use /usr/bin/mktemp to generate temporary file.
Taken from: ports/net/netsaint-plugins/scripts/configure 8-)
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/scripts/configure.php10
1 files changed, 6 insertions, 4 deletions
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index a5d1ef18bf77..fa48d59f9730 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -5,6 +5,8 @@ if [ -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc ]; then
exit
fi
+tempfile=`/usr/bin/mktemp -t checklist`
+
if [ "${BATCH}" ]; then
set \"zlib\" \"MySQL\"
else
@@ -39,14 +41,14 @@ sockets "sockets support" OFF \
sysvsem "System V semaphore support" OFF \
sysvshm "System V shared memory support" OFF \
transsid "Transparent session id" OFF \
-2> /tmp/checklist.tmp.$$
+2> $tempfile
retval=$?
- if [ -s /tmp/checklist.tmp.$$ ]; then
- set `cat /tmp/checklist.tmp.$$`
+ if [ -s $tempfile ]; then
+ set `cat $tempfile`
fi
- rm -f /tmp/checklist.tmp.$$
+ rm -f $tempfile
case $retval in
0) if [ -z "$*" ]; then