aboutsummaryrefslogtreecommitdiffstats
path: root/www/moonshine
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2010-08-04 00:18:58 +0800
committerromain <romain@FreeBSD.org>2010-08-04 00:18:58 +0800
commitb4929834200d9139536cc6d1dfb508494dfae079 (patch)
tree73a49069c14cc1e952abdd8264cc5ea8bf058153 /www/moonshine
parentdc325d7b6bf178999ce1ae560a8c24b054e0c275 (diff)
downloadfreebsd-ports-gnome-b4929834200d9139536cc6d1dfb508494dfae079.tar.gz
freebsd-ports-gnome-b4929834200d9139536cc6d1dfb508494dfae079.tar.zst
freebsd-ports-gnome-b4929834200d9139536cc6d1dfb508494dfae079.zip
Update to 0.7.
PR: ports/148851 Submitted by: decke@
Diffstat (limited to 'www/moonshine')
-rw-r--r--www/moonshine/Makefile26
-rw-r--r--www/moonshine/distinfo6
-rw-r--r--www/moonshine/files/patch-autogen.sh38
-rw-r--r--www/moonshine/files/patch-configure10
-rw-r--r--www/moonshine/files/patch-configure.ac30
-rw-r--r--www/moonshine/files/patch-plugin-generate-resource76
-rw-r--r--www/moonshine/files/patch-plugin-xpi-Makefile.am15
-rw-r--r--www/moonshine/files/patch-xulrunner-Makefile.am11
-rw-r--r--www/moonshine/files/patch-xulrunner-moonshine.in14
-rw-r--r--www/moonshine/pkg-plist6
10 files changed, 205 insertions, 27 deletions
diff --git a/www/moonshine/Makefile b/www/moonshine/Makefile
index 18797133e9ec..91743d09a362 100644
--- a/www/moonshine/Makefile
+++ b/www/moonshine/Makefile
@@ -6,20 +6,25 @@
#
PORTNAME= moonshine
-PORTVERSION= 0.2
-PORTREVISION= 2
+PORTVERSION= 0.7
CATEGORIES= www multimedia
-MASTER_SITES= http://abock.org/${PORTNAME}/releases/
+MASTER_SITES= http://github.com/abock/moonshine/tarball/${PORTVERSION}/
+DISTNAME= abock-${PORTNAME}-${GITCOMMIT}
MAINTAINER= mono@FreeBSD.org
COMMENT= Windows Media playback through Moonlight and Firefox
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+FETCH_BEFORE_ARGS= -o ${DISTNAME}${EXTRACT_SUFX}
+FETCH_ARGS= -apRr
+GITCOMMIT= 35085a4
-USE_BZIP2= yes
USE_GMAKE= yes
USE_GECKO= libxul
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:22 libtoolize aclocal:110 autoconf:262 autoheader:262 automake:110
+LIBTOOLIZE_ARGS= --force --copy --automake
+AUTOMAKE_ARGS= --gnu --add-missing --force --copy -Wno-portability
+ACLOCAL_ARGS=
CONFIGURE_ARGS= --with-browser-plugin-dir=${PREFIX}/lib/browser_plugins/${PORTNAME}/
USE_WEBPLUGINS= gecko19
@@ -32,10 +37,6 @@ WEBPLUGINS_FILES= libmoonshine-plugin.so
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.endif
-
.if defined(WITH_XPI_PLUGIN_ONLY)
CONFIGURE_ARGS+=--enable-xpi-build
PLIST= ${NONEXISTENT}
@@ -43,10 +44,11 @@ PLIST_FILES= ${WEBPLUGINS_DIR}/${PKGNAME}-freebsd-${OSREL}.xpi
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|^SHELL=.*|SHELL=${LOCALBASE}/bin/bash|' \
- ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|#!/bin/bash|#!${LOCALBASE}/bin/bash|' \
+ ${WRKSRC}/plugin/xpi/dist-build/build-all-arch \
+ ${WRKSRC}/xulrunner/icon-theme-hicolor/icon-theme-installer
${REINPLACE_CMD} -e 's|sed -r|sed -E|' \
- ${WRKSRC}/plugin/Makefile.in \
+ ${WRKSRC}/plugin/Makefile.am \
${WRKSRC}/plugin/generate-resource
.if defined(WITH_XPI_PLUGIN_ONLY)
diff --git a/www/moonshine/distinfo b/www/moonshine/distinfo
index dec121ab9fb9..725b89d84b32 100644
--- a/www/moonshine/distinfo
+++ b/www/moonshine/distinfo
@@ -1,3 +1,3 @@
-MD5 (moonshine-0.2.tar.bz2) = 471ddae37a45395bf996645a52911456
-SHA256 (moonshine-0.2.tar.bz2) = aac0c4f8dcd2ae26f4a597c7584ed072ca6186856f4280bc048df6dd371d6984
-SIZE (moonshine-0.2.tar.bz2) = 321716
+MD5 (abock-moonshine-35085a4.tar.gz) = 05f358d80f5c248b3ea721506b870048
+SHA256 (abock-moonshine-35085a4.tar.gz) = db99dadefb81b607d191c3c7baf01efae6baca8c80586b72fb4042fa4cd93a7a
+SIZE (abock-moonshine-35085a4.tar.gz) = 1424041
diff --git a/www/moonshine/files/patch-autogen.sh b/www/moonshine/files/patch-autogen.sh
new file mode 100644
index 000000000000..8ff3a3d9f85c
--- /dev/null
+++ b/www/moonshine/files/patch-autogen.sh
@@ -0,0 +1,38 @@
+--- autogen.sh.orig 2010-06-22 21:46:11.000000000 +0200
++++ autogen.sh 2010-07-01 12:58:23.000000000 +0200
+@@ -1,11 +1,11 @@
+-#!/bin/bash
++#!/bin/sh
+
+-function error () {
++error () {
+ echo "Error: $1" 1>&2
+ exit 1
+ }
+
+-function check_autotool_version () {
++check_autotool_version () {
+ which $1 &>/dev/null || {
+ error "$1 is not installed, and is required to configure $PACKAGE"
+ }
+@@ -20,9 +20,9 @@
+
+ if [ $major -lt $major_check ]; then
+ do_bail=yes
+- elif [[ $minor -lt $minor_check && $major = $major_check ]]; then
++ elif [ $minor -lt $minor_check ] && [ $major = $major_check ]; then
+ do_bail=yes
+- elif [[ $rev -lt $rev_check && $minor = $minor_check && $major = $major_check ]]; then
++ elif [ $rev -lt $rev_check ] && [ $minor = $minor_check ] && [ $major = $major_check ]; then
+ do_bail=yes
+ fi
+
+@@ -31,7 +31,7 @@
+ fi
+ }
+
+-function run () {
++run () {
+ echo "$@ ..."
+ $@ 2>.autogen.log || {
+ cat .autogen.log 1>&2
diff --git a/www/moonshine/files/patch-configure b/www/moonshine/files/patch-configure
deleted file mode 100644
index 0a0bb3e84d1a..000000000000
--- a/www/moonshine/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig 2009-04-15 21:26:53.000000000 +0100
-+++ configure 2009-04-15 21:28:20.000000000 +0100
-@@ -11543,6 +11543,7 @@
-
- case "$target_os" in
- *linux*) TARGET_PLATFORM="Linux" ;;
-+ *freebsd*) TARGET_PLATFORM="FreeBSD" ;;
- *) { { $as_echo "$as_me:$LINENO: error: Target os $target_os is not supported" >&5
- $as_echo "$as_me: error: Target os $target_os is not supported" >&2;}
- { (exit 1); exit 1; }; } ;;
diff --git a/www/moonshine/files/patch-configure.ac b/www/moonshine/files/patch-configure.ac
new file mode 100644
index 000000000000..cc3bd697b7fd
--- /dev/null
+++ b/www/moonshine/files/patch-configure.ac
@@ -0,0 +1,30 @@
+--- configure.ac.orig 2010-06-22 21:46:11.000000000 +0200
++++ configure.ac 2010-07-01 13:00:22.000000000 +0200
+@@ -18,7 +18,7 @@
+
+ dnl Plugin build configuration
+ PKG_CHECK_MODULES(MOZILLA, libxul mozilla-plugin)
+-PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.14 gmodule-2.0 >= 2.14 uuid)
++PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.14 gmodule-2.0 >= 2.14)
+ PKG_CHECK_MODULES(XULRUNNER_192, libxul >= 1.9.2,
+ HAVE_XULRUNNER_192=yes, HAVE_XULRUNNER_192=no)
+ if test "$HAVE_XULRUNNER_192" = "yes"; then
+@@ -45,6 +45,7 @@
+
+ case "$target_os" in
+ *linux*) TARGET_PLATFORM="Linux" ;;
++ *freebsd*) TARGET_PLATFORM="FreeBSD" ;;
+ *) AC_MSG_ERROR([Target os $target_os is not supported]) ;;
+ esac
+
+@@ -57,6 +58,10 @@
+ TARGET_PLATFORM="$TARGET_PLATFORM"_x86_64-gcc3
+ INSTALL_ARCH=x86_64
+ ;;
++ amd64)
++ TARGET_PLATFORM="$TARGET_PLATFORM"_amd64
++ INSTALL_ARCH=x86_64
++ ;;
+ *) AC_MSG_ERROR([Target cpu $target_cpu is unsupported or unknown]) ;;
+ esac
+ AC_SUBST([TARGET_PLATFORM])
diff --git a/www/moonshine/files/patch-plugin-generate-resource b/www/moonshine/files/patch-plugin-generate-resource
new file mode 100644
index 000000000000..5f331d8365da
--- /dev/null
+++ b/www/moonshine/files/patch-plugin-generate-resource
@@ -0,0 +1,76 @@
+--- plugin/generate-resource.orig 2010-06-22 21:46:11.000000000 +0200
++++ plugin/generate-resource 2010-07-01 12:39:33.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+
+ # generate-resource by Aaron Bockover
+ # Copyright (C) 2008 Novell
+@@ -6,7 +6,7 @@
+ #
+ # Turns a set of files into a C header file
+
+-function bail () {
++bail () {
+ echo "ERROR: $1" 1>&2
+ exit 1
+ }
+@@ -23,17 +23,19 @@
+ all_name=$1; shift
+ all_array=""
+
+-[[ -z $out ]] &&
++if [ -z "$out" ]; then
+ bail "You must specify an output file first"
++fi
+
+-while (($# > 0)); do
++while [ $# -gt 0 ]; do
+ var=$1
+ input=$2
+
+- [[ -z $var || ! -f $input ]] &&
++ if [ -z $var ] || [ ! -f $input ]; then
+ bail "Invalid variable/input file argument pair ($var, $input)"
++ fi
+
+- [[ $inputs -eq 0 ]] && {
++ if [ $inputs -eq 0 ]; then
+ (echo "/* "
+ echo " * $out: auto-generated embedded resources "
+ echo " */ "
+@@ -41,24 +43,29 @@
+ echo "#ifndef $out_define"
+ echo "#define $out_define"
+ echo) > $out
+- }
++ fi
+
+- ((inputs++))
++ inputs=$((inputs+1))
+ all_array="$all_array $var"
+
+ (echo "/* Embedded Resource $inputs ($input) */"
+- table=$(hexdump -e '" " 16/1 "0x%02x, " "\n"' $input | sed -r 's/, 0x[ ,]+.*/, 0x00/')
++ table=$(hexdump -e '" " 16/1 "0x%02x, " "\n"' $input | sed -E 's/, 0x[ ,]+.*/, 0x00/')
+ echo "static const char $var [] = {"
+ echo "$table"
+- [[ ${table:$((${#table}-1))} = "," ]] && echo " 0x00"
++ tablelen=${#table}
++ tablestr=$(echo $table | awk -v var=$tablelen '{ string=substr($1, 0, var); print string; }' )
++ if [ $tablestr = "," ]; then
++ echo " 0x00"
++ fi
+ echo "};"
+ echo) >> $out
+
+ shift; shift
+ done
+
+-[[ $inputs -eq 0 ]] &&
++if [ $inputs -eq 0 ]; then
+ bail "You must specify at least one variable/input file pair"
++fi
+
+ echo "static const char const * $all_name [] = {" >> $out
+ for var in $all_array; do
diff --git a/www/moonshine/files/patch-plugin-xpi-Makefile.am b/www/moonshine/files/patch-plugin-xpi-Makefile.am
new file mode 100644
index 000000000000..99ce93fb366d
--- /dev/null
+++ b/www/moonshine/files/patch-plugin-xpi-Makefile.am
@@ -0,0 +1,15 @@
+--- plugin/xpi/Makefile.am.orig 2010-06-22 21:46:11.000000000 +0200
++++ plugin/xpi/Makefile.am 2010-07-19 10:14:26.000000000 +0200
+@@ -11,9 +11,9 @@
+ -rm -rf $(XPI_BUILD_ROOT)
+ mkdir -p $(XPI_BUILD_ROOT)/plugins
+ mkdir -p $(XPI_BUILD_ROOT)/skin
+- cp -aL $(srcdir)/install.rdf $(XPI_BUILD_ROOT)
+- cp -aL $(top_srcdir)/xulrunner/icon-theme-hicolor/moonshine-32.png $(XPI_BUILD_ROOT)/skin/icon.png
+- cp -aL $(PLUGIN_FILE) $(XPI_BUILD_ROOT)/plugins
++ cp -RpPL $(srcdir)/install.rdf $(XPI_BUILD_ROOT)
++ cp -RpPL $(top_srcdir)/xulrunner/icon-theme-hicolor/moonshine-32.png $(XPI_BUILD_ROOT)/skin/icon.png
++ cp -RpPL $(PLUGIN_FILE) $(XPI_BUILD_ROOT)/plugins
+ echo "$(CHROME_MANIFEST)" > $(XPI_BUILD_ROOT)/chrome.manifest
+ find $(XPI_BUILD_ROOT) -name \*.so -exec strip '{}' ';'
+ cd $(XPI_BUILD_ROOT) && zip -r9 ../$@ *
diff --git a/www/moonshine/files/patch-xulrunner-Makefile.am b/www/moonshine/files/patch-xulrunner-Makefile.am
new file mode 100644
index 000000000000..d646eeb4b32d
--- /dev/null
+++ b/www/moonshine/files/patch-xulrunner-Makefile.am
@@ -0,0 +1,11 @@
+--- xulrunner/Makefile.am.orig 2010-06-22 21:46:11.000000000 +0200
++++ xulrunner/Makefile.am 2010-07-19 10:25:41.000000000 +0200
+@@ -55,7 +55,7 @@
+
+ chrome/content/player/%: $(top_srcdir)/player/%
+ mkdir -p $(dir $@)
+- cp -a $< $@
++ cp -RpP $< $@
+
+ XULAPP_FILES = `find $(srcdir)/chrome $(srcdir)/defaults application.ini -type f | grep -v debug.js`
+
diff --git a/www/moonshine/files/patch-xulrunner-moonshine.in b/www/moonshine/files/patch-xulrunner-moonshine.in
new file mode 100644
index 000000000000..cf24c9c53d85
--- /dev/null
+++ b/www/moonshine/files/patch-xulrunner-moonshine.in
@@ -0,0 +1,14 @@
+--- xulrunner/moonshine.in.orig 2010-06-22 21:46:11.000000000 +0200
++++ xulrunner/moonshine.in 2010-07-22 21:49:39.000000000 +0200
+@@ -1,7 +1,8 @@
+-#!/bin/bash
++#!/bin/sh
+
+-XULRUNNER=$(readlink -e $(which xulrunner))
+-BROWSER_PLUGIN_DIR=@BROWSER_PLUGIN_DIR@
++XULRUNNERBINARY=$(which xulrunner)
++XULRUNNER=$(echo $(cd $(dirname $XULRUNNERBINARY); pwd -P)/$(basename $XULRUNNERBINARY))
++BROWSER_PLUGIN_DIR=@BROWSER_PLUGIN_DIR@../symlinks/gecko19
+ LIBDIR=${XULRUNNER%%/xulrunner*}
+
+ FF_PROFILES_PATH="$HOME/.mozilla/firefox"
diff --git a/www/moonshine/pkg-plist b/www/moonshine/pkg-plist
index e38123336774..f308c61517e0 100644
--- a/www/moonshine/pkg-plist
+++ b/www/moonshine/pkg-plist
@@ -1,4 +1,5 @@
bin/moonshine
+lib/browser_plugins/moonshine/libmoonshine-plugin.a
lib/browser_plugins/moonshine/libmoonshine-plugin.la
lib/browser_plugins/moonshine/libmoonshine-plugin.so
share/applications/moonshine.desktop
@@ -36,6 +37,7 @@ share/applications/moonshine.desktop
%%DATADIR%%/chrome/skin/dialog-error.png
%%DATADIR%%/chrome/skin/player-shell.css
%%DATADIR%%/defaults/preferences/prefs.js
+@dirrmtry %%DATADIR%%/extensions
@dirrm %%DATADIR%%/defaults/preferences
@dirrm %%DATADIR%%/defaults
@dirrm %%DATADIR%%/chrome/skin
@@ -47,6 +49,6 @@ share/applications/moonshine.desktop
@dirrm %%DATADIR%%/chrome/content/player
@dirrm %%DATADIR%%/chrome/content
@dirrm %%DATADIR%%/chrome
-@dirrm %%DATADIR%%
+@dirrmtry %%DATADIR%%
@dirrm lib/browser_plugins/moonshine
-@dirrm lib/browser_plugins
+@dirrmtry lib/browser_plugins