aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2004-01-18 15:27:03 +0800
committeradamw <adamw@FreeBSD.org>2004-01-18 15:27:03 +0800
commitf82b9bf370e2176bf21a44ea6a9629ef4a1f3f40 (patch)
tree774d628f522b3f7ba04e2f0f61a4d0cc2e8d32e5 /www/mozilla/Makefile
parent19b7134ab95bdb63f50f6263e8e1c94f8e0a99d8 (diff)
downloadfreebsd-ports-gnome-f82b9bf370e2176bf21a44ea6a9629ef4a1f3f40.tar.gz
freebsd-ports-gnome-f82b9bf370e2176bf21a44ea6a9629ef4a1f3f40.tar.zst
freebsd-ports-gnome-f82b9bf370e2176bf21a44ea6a9629ef4a1f3f40.zip
Remove mozilla-headers.
This integrates the headers from mozilla-headers and mozilla-headers-devel into mozilla and mozilla-devel.
Diffstat (limited to 'www/mozilla/Makefile')
-rw-r--r--www/mozilla/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 7862580a2c89..255b8a97546b 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mozilla
PORTVERSION= 1.6
-PORTREVISION?= 0
+PORTREVISION?= 1
PORTEPOCH?= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
@@ -258,6 +258,11 @@ pre-install:
for pcfile in ${PKGCONFIG_FILES}; do \
${ECHO_CMD} libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc >> ${PLIST} ; \
done
+ cd ${WRKSRC}/dist/include && ${FIND} -s * -type f -o -type l | \
+ ${SED} -e 's:^:include/mozilla/:' >> ${PLIST} \
+ && ${FIND} -d * -type d | \
+ ${SED} -e 's:^:@dirrm include/mozilla/:' >> ${PLIST}
+ ${ECHO_CMD} @dirrm include/mozilla >> ${PLIST}
do-install:
${MKDIR} ${PREFIX}/lib/${MOZILLA}
@@ -284,6 +289,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/build/unix/$${pcfile}.pc \
${PREFIX}/libdata/pkgconfig/$${pcfile}${MOZ_SUFX}${PKGNAMESUFFIX}.pc ; \
done
+ -${RM} -fr ${PREFIX}/include/mozilla
+ ${MKDIR} ${PREFIX}/include/mozilla
+ ${CHMOD} 755 ${PREFIX}/include/mozilla
+ cd ${WRKSRC}/dist/include && ${FIND} . | \
+ cpio -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/include/mozilla
post-install:
@${CHMOD} -R u-w ${PREFIX}/lib/${MOZILLA}/components