aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-11-01 21:20:11 +0800
committerahze <ahze@FreeBSD.org>2006-11-01 21:20:11 +0800
commit23f6c0cea9451a21768d2d14c01556112e833e5e (patch)
treeac91ec2a295e5660843dd97e3772b012231bae67 /www/mozilla
parent9cf13a2bdc07e3126f9dbb16754591de41aff293 (diff)
downloadfreebsd-ports-gnome-23f6c0cea9451a21768d2d14c01556112e833e5e.tar.gz
freebsd-ports-gnome-23f6c0cea9451a21768d2d14c01556112e833e5e.tar.zst
freebsd-ports-gnome-23f6c0cea9451a21768d2d14c01556112e833e5e.zip
- Update to 2.0
Release notes: http://www.mozilla.com/en-US/firefox/2.0/releasenotes/ Special thanks to marcus and many others for helping test and fixing bugs!
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile2
-rw-r--r--www/mozilla/Makefile.common4
-rw-r--r--www/mozilla/bsd.gecko.mk6
-rw-r--r--www/mozilla/pkg-deinstall.in3
-rw-r--r--www/mozilla/pkg-install.in3
5 files changed, 8 insertions, 10 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index f646e50a54d4..f60906ca05f9 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,7 +3,7 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile,v 1.38 2006/07/18 15:03:40 ahze Exp $
+# $MCom: ports-stable/www/mozilla/Makefile,v 1.15 2006/10/18 17:29:07 ahze Exp $
PORTNAME= mozilla
PORTVERSION= 1.7.13
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index 540aeaac9fa4..f01ad81cdfdd 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -4,7 +4,7 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/Makefile.common,v 1.31 2006/10/14 03:49:21 ahze Exp $
+# $MCom: ports-stable/www/mozilla/Makefile.common,v 1.1 2006/10/18 17:29:07 ahze Exp $
# This file contains some reusable components for mozilla ports. It's of
# use primarily to apps from the mozilla project itself (such as Firefox,
@@ -340,7 +340,7 @@ gecko-pre-install:
@${RM} -rf ${FAKEDIR} ${PLIST}
@${TOUCH} -f ${PLIST}
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
+ ${MAKEFILE} ${MAKE_ARGS} prefix=${FAKEDIR} ${INSTALL_TARGET}
.if defined(MOZILLA_SUFX) && ${MOZILLA_SUFX}!="none"
${MV} ${FAKEDIR}/bin/${MOZILLA:S/${MOZILLA_SUFX}//} ${FAKEDIR}/bin/${MOZILLA}
${MV} ${FAKEDIR}/bin/${MOZILLA:S/${MOZILLA_SUFX}//}-config ${FAKEDIR}/bin/${MOZILLA}-config
diff --git a/www/mozilla/bsd.gecko.mk b/www/mozilla/bsd.gecko.mk
index 10dd6ef7d966..d6923aa368b5 100644
--- a/www/mozilla/bsd.gecko.mk
+++ b/www/mozilla/bsd.gecko.mk
@@ -2,7 +2,7 @@
# ex:ts=4
#
# $FreeBSD$
-# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.26 2006/10/13 04:20:21 ahze Exp $
+# $MCom: ports-stable/www/mozilla/bsd.gecko.mk,v 1.3 2006/10/24 17:48:39 ahze Exp $
#
# 4 column tabs prevent hair loss and tooth decay!
@@ -35,7 +35,7 @@ Gecko_Pre_Include= bsd.gecko.mk
#
# Ports should use the following:
#
-# USE_GECKO= mozilla firefox-devel firefox seamonkey
+# USE_GECKO= mozilla firefox seamonkey
# The list of gecko backends that the port supports. Unless the user
# overrides it with WITH_GECKO, the first gecko listed in USE_GECKO
# will be the default. In the above example, www/mozilla will be used
@@ -69,7 +69,7 @@ Gecko_Pre_Include= bsd.gecko.mk
.if ${OSVERSION} >= 500000
.if (${ARCH}!="sparc64" || ${OSVERSION} >= 601101) && ${ARCH}!="ia64"
-_GECKO_ALL= firefox nvu seamonkey thunderbird xulrunner firefox-devel flock
+_GECKO_ALL= firefox nvu seamonkey thunderbird xulrunner flock firefox15
.endif
.endif
_GECKO_ALL+= mozilla
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index e11caf5589e6..535f0f50ae43 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,7 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.15 2006/08/01 21:09:04 ahze Exp $
+# $MCom: ports-stable/www/mozilla/pkg-deinstall.in,v 1.9 2006/10/18 17:29:07 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index bc083ae6da01..f3d6e6f1a67f 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,7 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
-# $MCom: ports/www/mozilla/pkg-install.in,v 1.15 2006/08/01 21:09:04 ahze Exp $
+# $MCom: ports-stable/www/mozilla/pkg-install.in,v 1.9 2006/10/18 17:29:07 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)