aboutsummaryrefslogtreecommitdiffstats
path: root/www/mozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
committermarcus <marcus@FreeBSD.org>2007-03-19 13:14:07 +0800
commite83248f2b323aa90dfea75471b86ccc444a80f88 (patch)
treef4fc2dbabf96cb67c502479d9fc13f40bf0d0108 /www/mozilla
parent52dd0c5de1d6a7165dc355ecf161f52bb7dbbfda (diff)
downloadfreebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.gz
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.tar.zst
freebsd-ports-gnome-e83248f2b323aa90dfea75471b86ccc444a80f88.zip
Presenting GNOME 2.18 for FreeBSD. GNOME 2.18 is a departure from recent GNOME
releases in that it focuses more on stability and functionality than on new features. Not that it doesn't have its share of new and exciting items. See http://www.gnome.org/start/2.18/ for all the goodies in this release. GNOME 2.18 for FreeBSD would not have been possible without the hard work of the FreeBSD GNOME Team and our intrepid band of testers including J. W. Ballantine, Pawel Worach, Yasuda Keisuke, Pascal Hofstee, miwi, Yoshihiro Ota, Vladimir Grebenschikov, Jukka A. Ukkonen, Phillip Neumann, Franz Klammer, and Neal Delmonico.
Diffstat (limited to 'www/mozilla')
-rw-r--r--www/mozilla/Makefile5
-rw-r--r--www/mozilla/Makefile.common31
-rw-r--r--www/mozilla/bsd.gecko.mk2
-rw-r--r--www/mozilla/pkg-deinstall.in2
-rw-r--r--www/mozilla/pkg-install.in2
5 files changed, 16 insertions, 26 deletions
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index ea04ea242d34..9fe9ba00a314 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -3,12 +3,11 @@
# Whom: eivind/dima/jseger
#
# $FreeBSD$
-# $MCom: ports-stable/www/mozilla/Makefile,v 1.15 2006/10/18 17:29:07 ahze Exp $
-#
+# $MCom: ports/www/mozilla/Makefile,v 1.43 2007/03/16 15:29:49 ahze Exp $
PORTNAME= mozilla
PORTVERSION= 1.7.13
-PORTREVISION?= 2
+PORTREVISION?= 1
PORTEPOCH= 2
CATEGORIES?= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index ba37784260a8..784085b98cf0 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -4,7 +4,7 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/www/mozilla/Makefile.common,v 1.1 2006/10/18 17:29:07 ahze Exp $
+# $MCom: ports/www/mozilla/Makefile.common,v 1.45 2007/02/06 00:05:55 ahze Exp $
# This file contains some reusable components for mozilla ports. It's of
# use primarily to apps from the mozilla project itself (such as Firefox,
@@ -87,19 +87,16 @@ GENERIC_MOZCONFIG?= ${.CURDIR}/../../www/mozilla/files/mozconfig-generic.in
PORT_MOZCONFIG?= ${FILESDIR}/mozconfig.in
MOZCONFIG?= ${WRKSRC}/.mozconfig
MOZILLA_PLIST_DIRS?= bin include lib share/idl
-
+GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
-MASTER_MOZDIR?= ${.CURDIR}/../../www/mozilla
+MASTER_MOZDIR?= ${PORTSDIR}/www/mozilla
PKGINSTALL_INC?= ${MASTER_MOZDIR}/pkg-install.in
PKGDEINSTALL_INC?= ${MASTER_MOZDIR}/pkg-deinstall.in
EXTRACT_AFTER_ARGS?= | ${TAR} -xf - --exclude */CVS/* \
--exclude */macbuild/* \
--exclude */package/* \
- --exclude .cvsignore \
- --exclude makefile.win \
- --exclude MANIFEST \
--exclude mozilla/modules/libimg/png \
--exclude mozilla/jpeg \
--exclude mozilla/dbm \
@@ -111,12 +108,12 @@ JPI_LIST?=\
${LOCALBASE}/jdk1.5.0/jre/plugin/${ARCH}/ns7/libjavaplugin_oji.so \
${LOCALBASE}/jdk1.4.2/jre/plugin/${ARCH}/ns610/libjavaplugin_oji.so
-PKGCONFIG_FILES?= ${MOZILLA}-gtkmozembed ${MOZILLA}-js \
+MOZ_PKGCONFIG_FILES?= ${MOZILLA}-gtkmozembed ${MOZILLA}-js \
${MOZILLA}-xpcom ${MOZILLA}-plugin
-CPPFLAGS+= -I${X11BASE}/include
+CPPFLAGS+= -I${X11BASE}/include -I${LOCALBASE}/include/nss -I${LOCALBASE}/include/nss/nss
CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${X11BASE}/lib -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
+LDFLAGS+= -L${X11BASE}/lib -L${LOCALBASE}/lib/nss -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
LIBS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib -liconv
_USE_GECKO_OPTIONS_ALL= java debug logging optimized_cflags
@@ -138,9 +135,10 @@ _${option}= ${TRUE}
.endfor
# Standard options from README
+MOZ_TOOLKIT?= gtk2
MOZ_OPTIONS+= --enable-crypto \
--disable-tests \
- --enable-default-toolkit=gtk2 \
+ --enable-default-toolkit=${MOZ_TOOLKIT} \
--enable-xft \
--with-pthreads
# Configure options for install
@@ -222,13 +220,6 @@ MOZ_OPTIONS+= --enable-logging
MOZ_OPTIONS+= --disable-logging
.endif
-.if exists(${LOCALBASE}/include/freetype/freetype.h)
-BROKEN= "You must upgrade your freetype port to 1.3.1_2 or higher before \
- installing ${PORTNAME}. If you have 1.3.1_2 installed, please remove \
- ${LOCALBASE}/include/freetype, then build ${PORTNAME}"
-.endif
-
-# Makefile.common defines
MOZ_SED_ARGS+= -e's|@CPPFLAGS@|${CPPFLAGS}|g' \
-e 's|@CFLAGS@|${CFLAGS}|g' \
-e 's|@LDFLAGS@|${LDFLAGS}|g' \
@@ -351,7 +342,7 @@ gecko-pre-install:
.if defined(MOZILLA_SUFX) && ${MOZILLA_SUFX}!="none"
${MV} ${FAKEDIR}/bin/${MOZILLA:S/${MOZILLA_SUFX}//} ${FAKEDIR}/bin/${MOZILLA}
${MV} ${FAKEDIR}/bin/${MOZILLA:S/${MOZILLA_SUFX}//}-config ${FAKEDIR}/bin/${MOZILLA}-config
-.for pc in ${PKGCONFIG_FILES:S|${MOZILLA_SUFX}||}
+.for pc in ${MOZ_PKGCONFIG_FILES:S|${MOZILLA_SUFX}||}
${SED} -e 's|Requires: ${MOZILLA:S/${MOZILLA_SUFX}//}|Requires: ${MOZILLA}|' \
${FAKEDIR}/lib/pkgconfig/${pc}.pc > ${FAKEDIR}/lib/pkgconfig/${pc:S/${MOZILLA:S,${MOZILLA_SUFX},,}/${MOZILLA}/}.pc
.endfor
@@ -386,7 +377,7 @@ gecko-create-plist:
${FIND} -d * -type d | \
${SED} -e 's|^|@dirrm ${dir}/|' >> ${PLIST}
.endfor
-.for pcfile in ${PKGCONFIG_FILES}
+.for pcfile in ${MOZ_PKGCONFIG_FILES}
${ECHO_CMD} "libdata/pkgconfig/${pcfile}.pc" >> ${PLIST}
@${REINPLACE_CMD} -e 's|${FAKEDIR}|${PREFIX}|g' \
-e 's|${MOZILLA}-nspr = ${PORTVERSION}|nspr|' \
@@ -409,7 +400,7 @@ gecko-do-install:
cd ${FAKEDIR}/${dir} && ${FIND} . | \
${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${PREFIX}/${dir}
.endfor
-.for pcfile in ${PKGCONFIG_FILES}
+.for pcfile in ${MOZ_PKGCONFIG_FILES}
${INSTALL_DATA} ${FAKEDIR}/libdata/pkgconfig/${pcfile}.pc \
${PREFIX}/libdata/pkgconfig/${pcfile}.pc
.endfor
diff --git a/www/mozilla/bsd.gecko.mk b/www/mozilla/bsd.gecko.mk
index d6923aa368b5..b27dc306b473 100644
--- a/www/mozilla/bsd.gecko.mk
+++ b/www/mozilla/bsd.gecko.mk
@@ -2,7 +2,7 @@
# ex:ts=4
#
# $FreeBSD$
-# $MCom: ports-stable/www/mozilla/bsd.gecko.mk,v 1.3 2006/10/24 17:48:39 ahze Exp $
+# $MCom: ports/www/mozilla/bsd.gecko.mk,v 1.30 2006/12/09 15:32:06 ahze Exp $
#
# 4 column tabs prevent hair loss and tooth decay!
diff --git a/www/mozilla/pkg-deinstall.in b/www/mozilla/pkg-deinstall.in
index 535f0f50ae43..4a0a2fba8c36 100644
--- a/www/mozilla/pkg-deinstall.in
+++ b/www/mozilla/pkg-deinstall.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $MCom: ports-stable/www/mozilla/pkg-deinstall.in,v 1.9 2006/10/18 17:29:07 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-deinstall.in,v 1.19 2006/12/09 15:32:06 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)
diff --git a/www/mozilla/pkg-install.in b/www/mozilla/pkg-install.in
index f3d6e6f1a67f..8fcc2b0ea088 100644
--- a/www/mozilla/pkg-install.in
+++ b/www/mozilla/pkg-install.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $MCom: ports-stable/www/mozilla/pkg-install.in,v 1.9 2006/10/18 17:29:07 ahze Exp $
+# $MCom: ports/www/mozilla/pkg-install.in,v 1.19 2006/12/09 15:32:06 ahze Exp $
#
# Date created: Mon Nov 29, 2003
# Whom: Thierry Thomas (<thierry@pompo.net>)