aboutsummaryrefslogtreecommitdiffstats
path: root/www/nanoblogger-extra/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
committermat <mat@FreeBSD.org>2016-07-19 19:04:13 +0800
commit363acdd313a37f491e4b2d6b9a807df489cfc5d9 (patch)
treebe6eebf3e77ddf9fcf383081091d8b8b336dd71c /www/nanoblogger-extra/Makefile
parent64a47229a8791073130cac02039b944cc8102750 (diff)
downloadfreebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.gz
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.tar.zst
freebsd-ports-gnome-363acdd313a37f491e4b2d6b9a807df489cfc5d9.zip
When there is a do-install target, do not use a post-install target, do
everything at once. Sometime, rename post-install into a options helper target. I did not fix ports that were such a mess that I could not figure out what they really wanted to do. I also did not change ports that had some version of an auto-plist code in post-install, for the same reason. With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'www/nanoblogger-extra/Makefile')
-rw-r--r--www/nanoblogger-extra/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/nanoblogger-extra/Makefile b/www/nanoblogger-extra/Makefile
index eb42d47256a9..f3cae13dcc50 100644
--- a/www/nanoblogger-extra/Makefile
+++ b/www/nanoblogger-extra/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nanoblogger-extra
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://nanoblogger.sourceforge.net/downloads/
@@ -18,7 +19,7 @@ DATADIR= ${PREFIX}/share/nanoblogger
NO_BUILD= yes
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
.for data in default lang plugins
@@ -26,7 +27,7 @@ do-install:
${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR}/${data} "! -empty" )
.endfor
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in COPYING ChangeLog README
@${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
@@ -34,6 +35,7 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/html
@${INSTALL_DATA} ${WRKSRC}/docs/*.html ${STAGEDIR}${DOCSDIR}/html
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/docs/examples/nanoblogger.bash_completion ${STAGEDIR}${EXAMPLESDIR}