aboutsummaryrefslogtreecommitdiffstats
path: root/www/netscape4-navigator
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
committerasami <asami@FreeBSD.org>1999-02-03 19:12:01 +0800
commitaa52cd921c82a10ec33065084fe0edb5cf8bebbc (patch)
treeb70284a297d2e3c06462e3a3a86166c4371477f9 /www/netscape4-navigator
parentdd1603cad7e60d10dd91a2f1f918e24ed859ed24 (diff)
downloadfreebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.gz
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.tar.zst
freebsd-ports-gnome-aa52cd921c82a10ec33065084fe0edb5cf8bebbc.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Diffstat (limited to 'www/netscape4-navigator')
-rw-r--r--www/netscape4-navigator/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/www/netscape4-navigator/Makefile b/www/netscape4-navigator/Makefile
index fc4c78fdd983..bf339a5c6674 100644
--- a/www/netscape4-navigator/Makefile
+++ b/www/netscape4-navigator/Makefile
@@ -3,7 +3,7 @@
# Date created: 24 Feb 1997
# Whom: ache
#
-# $Id: Makefile,v 1.35 1999/01/06 04:18:14 simokawa Exp $
+# $Id: Makefile,v 1.36 1999/01/13 04:00:09 scrappy Exp $
#
DISTNAME= netscape-navigator-4.08
@@ -49,7 +49,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/*.jar ${NDIR}/java/classes
${INSTALL_PROGRAM} ${WRKSRC}/vreg ${NDIR}
for i in ${WRKSRC}/*.nif; do \
- ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} -C ${NDIR}; \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} ${EXTRACT_AFTER_ARGS} -C ${NDIR}; \
done
${WRKSRC}/vreg ${NDIR}/registry ${WRKSRC}/infile
${MV} -f ${NDIR}/netscape ${NDIR}/navigator-4.08.bin