aboutsummaryrefslogtreecommitdiffstats
path: root/www/netscape47-communicator
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2003-05-16 11:43:58 +0800
committerobrien <obrien@FreeBSD.org>2003-05-16 11:43:58 +0800
commitaa000e493402631f68b53edd48339d533d6e0502 (patch)
tree03cfa5bc25644af5bf7dbbb001651afbbb7b9c48 /www/netscape47-communicator
parent17d4592b50c6db3fc05bc6ee039233842115e4a3 (diff)
downloadfreebsd-ports-gnome-aa000e493402631f68b53edd48339d533d6e0502.tar.gz
freebsd-ports-gnome-aa000e493402631f68b53edd48339d533d6e0502.tar.zst
freebsd-ports-gnome-aa000e493402631f68b53edd48339d533d6e0502.zip
Bring back the last commerical Netscape for DEC Alpha.
Reviewed by: freebsd-alpha Approved by: kris
Diffstat (limited to 'www/netscape47-communicator')
-rw-r--r--www/netscape47-communicator/Makefile81
-rw-r--r--www/netscape47-communicator/distinfo2
-rw-r--r--www/netscape47-communicator/files/mailcap69
-rw-r--r--www/netscape47-communicator/files/netscape.sh7
-rw-r--r--www/netscape47-communicator/pkg-descr8
-rw-r--r--www/netscape47-communicator/pkg-plist9
6 files changed, 176 insertions, 0 deletions
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
new file mode 100644
index 000000000000..0d0914951dc8
--- /dev/null
+++ b/www/netscape47-communicator/Makefile
@@ -0,0 +1,81 @@
+# ex:ts=8
+# New ports collection makefile for: netscape (full communicator version)
+# Date created: 24 Feb 1997
+# Whom: ache
+#
+# $FreeBSD$
+#
+
+PORTNAME?= netscape-${BROWSER_NAME}
+PORTVERSION= 4.78
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_NETSCAPE}
+DISTFILES= ${BROWSER_NAME}-v${PORTVERSION:S/.//g}-us.${NETSCAPE_DIST_TAG}.tar.gz
+
+MAINTAINER= freebsd-alpha@FreeBSD.org
+COMMENT?= Netscape version 4 communicator web-surfboard for DEC Alpha
+
+RUN_DEPENDS+= /compat/osf1/usr/shlib/libc.so:${PORTSDIR}/emulators/osf1_base
+RUN_DEPENDS+= netscape:${PORTSDIR}/www/netscape-wrapper
+
+WRKSRC= ${WRKDIR}/${BROWSER_NAME}-v${PORTVERSION:S/.//g}.${NETSCAPE_DIST_TAG}
+ONLY_FOR_ARCHS= alpha
+USE_XLIB= yes
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+STRIP= # null
+#PKGDIR= ${.CURDIR}
+PLIST_SUB= BROWSER=${BROWSER_ARC} BROWSER_VER=${PORTVERSION}
+MASTER_SITE_SUBDIR= communicator/english/${PORTVERSION}/unix/supported/dec_unix40/${NETSCAPE_DIST_GRADE}
+
+BROWSER_NAME?= communicator
+BROWSER_ARC= ${BROWSER_NAME}-osf1
+.if defined(BROWSER_NAME) && ${BROWSER_NAME} == "navigator"
+NETSCAPE_DIST_GRADE= navigator_standalone
+.endif
+NETSCAPE_DIST_GRADE?= complete_install
+NETSCAPE_DIST_TAG= alpha-dec-osf4.0
+NDIR= ${PREFIX}/${NSUBDIR}
+NSUBDIR= lib/netscape
+BINDIR= ${PREFIX}/bin
+INFILE_HEAD?= 'Communicator,4.78.0.20010625'
+WRAPPER_TEMPLATE= ${MASTERDIR}/files/netscape.sh
+MAILCAP= ${MASTERDIR}/files/mailcap
+
+post-configure:
+ @${SED} -e "s;@PREFIX@;${PREFIX};g" -e "s;@NSUBDIR@;${NSUBDIR};g" \
+ -e "s;@BROWSER@;${BROWSER_ARC};g" \
+ -e "s;@BROWSER_VER@;${PORTVERSION};g" \
+ ${WRAPPER_TEMPLATE} >${WRKSRC}/netscape
+ @${CHMOD} +x ${WRKSRC}/netscape
+ @${ECHO_CMD} -n ${INFILE_HEAD},${NDIR} >${WRKSRC}/infile
+
+do-install:
+ ${MKDIR} ${NDIR}/java/classes
+ for i in ${WRKSRC}/*.nif; do \
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} ${EXTRACT_AFTER_ARGS} -C ${NDIR}; \
+ done
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${NDIR}/java/classes
+ ${INSTALL_PROGRAM} ${WRKSRC}/vreg ${NDIR}
+ ${WRKSRC}/vreg ${NDIR}/registry ${WRKSRC}/infile
+ ${MV} -f ${NDIR}/netscape ${NDIR}/${BROWSER_ARC}-${PORTVERSION}.bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/${BROWSER_ARC}-${PORTVERSION}
+ ${LN} -sf ${BROWSER_ARC}-${PORTVERSION} ${BINDIR}/${BROWSER_ARC}-4
+ ${LN} -sf ${BROWSER_ARC}-4 ${BINDIR}/netscape.run
+ if [ ! -f ${NDIR}/mailcap ] ; then \
+ ${INSTALL_DATA} ${MAILCAP} ${NDIR}; \
+ fi
+ ${RM} -rf ${NDIR}/movemail-src
+ ${CHOWN} -R root:wheel ${NDIR}
+
+post-install:
+ cd ${PREFIX} ;\
+ ${FIND} ${NSUBDIR} -type f -o -type l \
+ >${WRKDIR}/PLIST.ns-lib
+ cd ${PREFIX} ;\
+ ${FIND} ${NSUBDIR} -type d \
+ | sort -r | ${SED} -e 's/^/@dirrm /g' >>${WRKDIR}/PLIST.ns-lib
+ ${ECHO_CMD} "@unexec rmdir %D/${NSUBDIR} 2>&1 || true" >> ${WRKDIR}/PLIST.ns-lib
+ ${CAT} ${DESCR}
+
+.include <bsd.port.mk>
diff --git a/www/netscape47-communicator/distinfo b/www/netscape47-communicator/distinfo
new file mode 100644
index 000000000000..4c682438d72b
--- /dev/null
+++ b/www/netscape47-communicator/distinfo
@@ -0,0 +1,2 @@
+MD5 (communicator-v478-us.alpha-dec-osf4.0.tar.gz) = 7f1f12f4a2c1abb6b4f50739f6cdf6bd
+MD5 (navigator-v478-us.alpha-dec-osf4.0.tar.gz) = 5c4283489e79f7c2e9de6b50b97f681f
diff --git a/www/netscape47-communicator/files/mailcap b/www/netscape47-communicator/files/mailcap
new file mode 100644
index 000000000000..61daeb5db716
--- /dev/null
+++ b/www/netscape47-communicator/files/mailcap
@@ -0,0 +1,69 @@
+# Example .mailcap file for FreeBSD machines
+#
+# First a note about syntax:
+# The first token in a configuration line represents a mime type.
+# A mime type is of the form "SubGroup/Item" and either token
+# can be replaced by the wildcard character "*"
+#
+# the second token is the command that you would run
+# when the specified mime type is encountered. An example
+# would be "xv %s" where %s will be replaced by a filename
+#
+# remaining tokens represent name value pairs.
+#
+# the "test=<SOME TEST COMMAND>" pair invokes the test command
+# specified and checks the UNIX shell return code to see if the
+# test passed. If the test passes the mime mapping is made, otherwise
+# the mapping is not made.
+#
+# the "stream-buffer-size=<NUMBER>" pair tells the application
+# to use a popen command to invoke the program specified and to
+# pipe all data into the command. Only programs that can handle
+# piped input can use this method. When this method is used
+# a "%s" should not be included in the command. You should
+# make sure that the program you wish to use can accept piped
+# data by trying something like this before using it:
+# cat "YOUR_DATA_FILE_HERE" | COMMAND_TO_TEST
+#
+# You may continue lines by using the backslash character "\"
+
+# FreeBSD doesn't seem to support `sfplay' yet, but if a port comes
+# along then the following should be enabled.
+#
+# plays AIFF files
+#audio/x-aiff; sfplay %s
+
+# plays AIFC files
+#audio/x-aifc; sfplay %s
+
+# FreeBSD has no wavplay utility either, but if someone
+# would care to port one then this can also be used.
+# plays WAV files
+#audio/x-wav; wavplay %s > /dev/null 2>&1
+
+# FreeBSD /dev/audio is sun compliant
+audio/basic; cat %s > /dev/audio
+
+# use this to play MPEG audio if you have maplay installed
+audio/x-mpeg; maplay -; stream-buffer-size=2000
+
+# use this to play MPEG video files if you have mpeg_play installed
+video/mpeg; mpeg_play -quiet %s
+
+# All other anims go well with xanim (if installed)
+video/*; xanim %s > /dev/null 2>&1
+
+# use this to display postscript files
+application/postscript; ghostview %s
+
+# use this to display pdf files
+application/pdf; xpdf %s 2>/dev/null
+
+# this is the default for non GIF or JPEG images
+image/*; xv %s
+
+# if you would prefer an external viewer for GIF and JPEG images
+# uncomment the following lines for XV to act as your external viewer.
+#image/gif; xv %s
+#image/jpg; xv %s
+#image/jpeg; xv %s
diff --git a/www/netscape47-communicator/files/netscape.sh b/www/netscape47-communicator/files/netscape.sh
new file mode 100644
index 000000000000..f5b5ba66eed1
--- /dev/null
+++ b/www/netscape47-communicator/files/netscape.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+export MOZILLA_HOME; MOZILLA_HOME=${MOZILLA_HOME:=@PREFIX@/@NSUBDIR@}
+export NPX_PLUGIN_PATH; NPX_PLUGIN_PATH=${MOZILLA_HOME}/plugins
+export CLASSPATH ; CLASSPATH=.:$MOZILLA_HOME
+export XCMSDB; XCMSDB=/dev/null
+ulimit -c 0
+exec $MOZILLA_HOME/@BROWSER@-@BROWSER_VER@.bin "$@"
diff --git a/www/netscape47-communicator/pkg-descr b/www/netscape47-communicator/pkg-descr
new file mode 100644
index 000000000000..e0a83b68e9ae
--- /dev/null
+++ b/www/netscape47-communicator/pkg-descr
@@ -0,0 +1,8 @@
+This is the netscape web-surfboard. Please read the file
+"/usr/local/lib/netscape/LICENSE" for the licensing terms.
+
+Note: If Java applets fail to display. Type this as root:
+ cd /usr/X11R6/lib/X11/fonts/misc
+ /usr/X11R6/bin/mkfontdir
+ chmod 444 fonts.dir
+ And then exit and restart your X server.
diff --git a/www/netscape47-communicator/pkg-plist b/www/netscape47-communicator/pkg-plist
new file mode 100644
index 000000000000..b05219d17019
--- /dev/null
+++ b/www/netscape47-communicator/pkg-plist
@@ -0,0 +1,9 @@
+bin/%%BROWSER%%-%%BROWSER_VER%%
+@exec ln -sf %f %B/%%BROWSER%%-4
+@exec ln -sf %%BROWSER%%-4 %B/netscape.run
+@unexec rm -f %B/netscape.run
+@unexec rm -f %B/%%BROWSER%%-4
+@comment Insert PLIST.gcc-lib here
+@comment -=[ begin PLIST.ns-lib ]=-
+@comment -=[ end PLIST.ns-lib ]=-
+@unexec rmdir %D/%%NSUBDIR%% 2>/dev/null || true