aboutsummaryrefslogtreecommitdiffstats
path: root/www/nghttp2
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2019-04-20 07:26:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2019-04-20 07:26:15 +0800
commit19420ffbb2e28d57b2e8836b8d71a4aa1bc20193 (patch)
tree6062d3c48f899ea44efaa076fc0c2624275c8a0c /www/nghttp2
parentaee1e48f4d9036437b96238146c40493bacf8f43 (diff)
downloadfreebsd-ports-gnome-19420ffbb2e28d57b2e8836b8d71a4aa1bc20193.tar.gz
freebsd-ports-gnome-19420ffbb2e28d57b2e8836b8d71a4aa1bc20193.tar.zst
freebsd-ports-gnome-19420ffbb2e28d57b2e8836b8d71a4aa1bc20193.zip
Move upstream patch to files directory
Obtained from: https://github.com/nghttp2/nghttp2/commit/cbba1ebf8fcecb24392f0cc07b1235b17d0de9d8
Diffstat (limited to 'www/nghttp2')
-rw-r--r--www/nghttp2/Makefile3
-rw-r--r--www/nghttp2/files/patch-src-asio_server_connection.h35
2 files changed, 35 insertions, 3 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index fafd9e2191a6..2ce237292d07 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -6,9 +6,6 @@ PORTVERSION= 1.38.0
DISTVERSIONPREFIX= v
CATEGORIES= www net
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= cbba1ebf8fce.patch:-p1
-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
diff --git a/www/nghttp2/files/patch-src-asio_server_connection.h b/www/nghttp2/files/patch-src-asio_server_connection.h
new file mode 100644
index 000000000000..cb5336a9fce0
--- /dev/null
+++ b/www/nghttp2/files/patch-src-asio_server_connection.h
@@ -0,0 +1,35 @@
+Obtained from: https://github.com/nghttp2/nghttp2/commit/cbba1ebf8fcecb24392f0cc07b1235b17d0de9d8
+
+--- src/asio_server_connection.h.orig 2019-04-18 06:08:36 UTC
++++ src/asio_server_connection.h
+@@ -51,6 +51,12 @@
+ #include "util.h"
+ #include "template.h"
+
++#if BOOST_VERSION >= 107000
++#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
++#else
++#define GET_IO_SERVICE(s) ((s).get_io_service())
++#endif
++
+ namespace nghttp2 {
+
+ namespace asio_http2 {
+@@ -71,7 +77,7 @@ public:
+ SocketArgs &&... args)
+ : socket_(std::forward<SocketArgs>(args)...),
+ mux_(mux),
+- deadline_(socket_.get_io_service()),
++ deadline_(GET_IO_SERVICE(socket_)),
+ tls_handshake_timeout_(tls_handshake_timeout),
+ read_timeout_(read_timeout),
+ writing_(false),
+@@ -82,7 +88,7 @@ public:
+ boost::system::error_code ec;
+
+ handler_ = std::make_shared<http2_handler>(
+- socket_.get_io_service(), socket_.lowest_layer().remote_endpoint(ec),
++ GET_IO_SERVICE(socket_), socket_.lowest_layer().remote_endpoint(ec),
+ [this]() { do_write(); }, mux_);
+ if (handler_->start() != 0) {
+ stop();