aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-12-13 03:46:36 +0800
committerosa <osa@FreeBSD.org>2011-12-13 03:46:36 +0800
commit77951f446017dde24e03bd0b8676473bad88086a (patch)
tree8cd2d84e85a0bafde74451f51e74d5a217c95c14 /www/nginx-devel
parent30b4912496350e98cea8ee3434349ce356155b35 (diff)
downloadfreebsd-ports-gnome-77951f446017dde24e03bd0b8676473bad88086a.tar.gz
freebsd-ports-gnome-77951f446017dde24e03bd0b8676473bad88086a.tar.zst
freebsd-ports-gnome-77951f446017dde24e03bd0b8676473bad88086a.zip
Update from 1.1.9 to 1.1.11.
The only one third-party subs filter module using ngx_regex_capture_count(), add as extra patch. <ChangeLog> Changes with nginx 1.1.11 12 Dec 2011 *) Feature: the "so_keepalive" parameter of the "listen" directive. Thanks to Vsevolod Stakhov. *) Feature: the "if_not_empty" parameter of the "fastcgi/scgi/uwsgi_param" directives. *) Feature: the $https variable. *) Feature: the "proxy_redirect" directive supports variables in the first parameter. *) Feature: the "proxy_redirect" directive supports regular expressions. *) Bugfix: the $sent_http_cache_control variable might contain a wrong value if the "expires" directive was used. Thanks to Yichun Zhang. *) Bugfix: the "read_ahead" directive might not work combined with "try_files" and "open_file_cache". *) Bugfix: a segmentation fault might occur in a worker process if small time was used in the "inactive" parameter of the "proxy_cache_path" directive. *) Bugfix: responses from cache might hang. Changes with nginx 1.1.10 30 Nov 2011 *) Bugfix: a segmentation fault occured in a worker process if AIO was used on Linux; the bug had appeared in 1.1.9. </ChangeLog>
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/extra-patch-src:core:ngx_regex.c26
3 files changed, 30 insertions, 3 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 9424cd71c024..676ea798bdd8 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 1.1.9
+PORTVERSION= 1.1.11
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -340,6 +340,7 @@ MASTER_SITES+= ${MASTER_SITE_LOCAL:S/$/:subs_filter/}
MASTER_SITE_SUBDIR+= osa/:subs_filter
DISTFILES+= ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}.tar.gz:subs_filter
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_http_subs_filter_module-${NGINX_HTTP_SUBS_FILTER_MODULE_VERSION}
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src:core:ngx_regex.c
.endif
.if defined(WITH_HTTP_SECURE_LINK_MODULE)
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index e3f6c3329749..e6becb4e73cc 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.1.9.tar.gz) = d3c87524563e1b85860888686a6cb6d3421861aac686d3d8daf1cfe48bee6d35
-SIZE (nginx-1.1.9.tar.gz) = 701459
+SHA256 (nginx-1.1.11.tar.gz) = 0350274c7b072293f98166a44597e7dddd2c249a1be6bfbeafd97868f49b01a1
+SIZE (nginx-1.1.11.tar.gz) = 704239
SHA256 (giom-nginx_accept_language_module-02262ce.tar.gz) = 3191f4caa70d9a8942c4f10b6abaaa96af451991d4b5e1e3d7b991376b00bf0c
SIZE (giom-nginx_accept_language_module-02262ce.tar.gz) = 3398
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx-devel/files/extra-patch-src:core:ngx_regex.c b/www/nginx-devel/files/extra-patch-src:core:ngx_regex.c
new file mode 100644
index 000000000000..fd54148d9ae8
--- /dev/null
+++ b/www/nginx-devel/files/extra-patch-src:core:ngx_regex.c
@@ -0,0 +1,26 @@
+--- src/core/ngx_regex.c 2011-12-06 19:49:40.000000000 +0400
++++ src/core/ngx_regex.c 2009-11-17 13:24:45.000000000 +0300
+@@ -137,6 +137,23 @@
+
+
+ ngx_int_t
++ngx_regex_capture_count(ngx_regex_t *re)
++{
++ int rc, n;
++
++ n = 0;
++
++ rc = pcre_fullinfo(re, NULL, PCRE_INFO_CAPTURECOUNT, &n);
++
++ if (rc < 0) {
++ return (ngx_int_t) rc;
++ }
++
++ return (ngx_int_t) n;
++}
++
++
++ngx_int_t
+ ngx_regex_exec_array(ngx_array_t *a, ngx_str_t *s, ngx_log_t *log)
+ {
+ ngx_int_t n;