aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2017-07-04 23:44:05 +0800
committerosa <osa@FreeBSD.org>2017-07-04 23:44:05 +0800
commit7c05a7401039b42ebec4f7bfc38ec301e02d30ba (patch)
treeb71d09734707ebfb9675a33c9feaf67f2dfaa7f7 /www/nginx-devel
parent4f5e3402fcf1a420327f453046616ccdb5ec45f7 (diff)
downloadfreebsd-ports-gnome-7c05a7401039b42ebec4f7bfc38ec301e02d30ba.tar.gz
freebsd-ports-gnome-7c05a7401039b42ebec4f7bfc38ec301e02d30ba.tar.zst
freebsd-ports-gnome-7c05a7401039b42ebec4f7bfc38ec301e02d30ba.zip
Upgrade third-party clojure module from 0.4.4 to 0.4.5.
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile3
-rw-r--r--www/nginx-devel/distinfo6
-rw-r--r--www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c11
3 files changed, 4 insertions, 16 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 16460448e305..1cbdfcf9e1f2 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -428,13 +428,12 @@ JAVA_VERSION= 1.8
JAVA_VENDOR= openjdk
JAVA_BUILD= yes
JAVA_RUN= yes
-NGINX_CLOJURE_VERSION= 0.4.4
+NGINX_CLOJURE_VERSION= 0.4.5
GH_ACCOUNT+= nginx-clojure:clojure
GH_PROJECT+= nginx-clojure:clojure
GH_TAGNAME+= v${NGINX_CLOJURE_VERSION}:clojure
CONFIGURE_ENV+= "JNI_INCS=-I${LOCALBASE}/openjdk8/include -I${LOCALBASE}/openjdk8/include/freebsd"
CONFIGURE_ARGS+=--add-module=${WRKSRC_clojure}/src/c
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src-c-ngx_http_clojure_socket.c
.endif
.if ${PORT_OPTIONS:MCT}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 425cc29f09ae..3708e6672787 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1498921298
+TIMESTAMP = 1499182840
SHA256 (nginx-1.13.2.tar.gz) = d77f234d14989d273a363f570e1d892395c006fef2ec04789be90f41a1919b70
SIZE (nginx-1.13.2.tar.gz) = 985802
SHA256 (ngx_cache_purge-2.3.tar.gz) = 279e0d8a46d3b1521fd43b3f78bc1c08b263899142a7cc5058c1c0361a92c89c
@@ -33,8 +33,8 @@ SHA256 (yaoweibin-nginx_ajp_module-bf6cd93_GH0.tar.gz) = 9e3f78ea73e2d606a95ee64
SIZE (yaoweibin-nginx_ajp_module-bf6cd93_GH0.tar.gz) = 109704
SHA256 (anomalizer-ngx_aws_auth-1e62670_GH0.tar.gz) = db7ceef4ae22cf5bfaf5abae64830dfeef203ca85f9f40f7d1f1d90f277478c0
SIZE (anomalizer-ngx_aws_auth-1e62670_GH0.tar.gz) = 8260
-SHA256 (nginx-clojure-nginx-clojure-v0.4.4_GH0.tar.gz) = 642ebf4724fa7c3efd5349e60b442ac8671497406834804c903ec548bfdcb691
-SIZE (nginx-clojure-nginx-clojure-v0.4.4_GH0.tar.gz) = 603856
+SHA256 (nginx-clojure-nginx-clojure-v0.4.5_GH0.tar.gz) = c6d500f935dde5f87a6eb47ca473094a8ee2c9b4bb4578c9f99ccdc70a12d59e
+SIZE (nginx-clojure-nginx-clojure-v0.4.5_GH0.tar.gz) = 602064
SHA256 (grahamedgecombe-nginx-ct-v1.3.2_GH0.tar.gz) = b4ceae549b9dbf84b2e511633982e4efeee0388e3b7a038a8bac555008a77b88
SIZE (grahamedgecombe-nginx-ct-v1.3.2_GH0.tar.gz) = 6844
SHA256 (openresty-echo-nginx-module-46334b3_GH0.tar.gz) = 00d42a5f562a0be5570110d9b70c8f2cace93b292421a6f994cf4ec76a8979f0
diff --git a/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c b/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c
deleted file mode 100644
index 9ed68350ee74..000000000000
--- a/www/nginx-devel/files/extra-patch-src-c-ngx_http_clojure_socket.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../nginx-clojure-0.4.4/src/c/ngx_http_clojure_socket.c.orig 2016-05-24 17:39:48.898351000 -0400
-+++ ../nginx-clojure-0.4.4/src/c/ngx_http_clojure_socket.c 2016-05-25 19:23:44.584704000 -0400
-@@ -317,7 +317,7 @@
- }
- u->resolved->host.data = url->host.data;
- u->resolved->host.len = url->host.len;
-- ngx_http_clojure_socket_upstream_connect(u, (struct sockaddr *)url->sockaddr, url->socklen);
-+ ngx_http_clojure_socket_upstream_connect(u, &url->sockaddr, url->socklen);
- }
-
- static void ngx_http_clojure_socket_upstream_connect_inner(ngx_http_clojure_socket_upstream_t *u) {