aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-02-02 21:15:44 +0800
committerosa <osa@FreeBSD.org>2009-02-02 21:15:44 +0800
commit8b6cb5669410e47ab74524b9f408a16fd9532284 (patch)
treef6c9eadd9dd704e6b2afca760dff1ec8b7067b01 /www/nginx-devel
parenteb8d1c722a9e54447d00e35098548a29ef520dc5 (diff)
downloadfreebsd-ports-gnome-8b6cb5669410e47ab74524b9f408a16fd9532284.tar.gz
freebsd-ports-gnome-8b6cb5669410e47ab74524b9f408a16fd9532284.tar.zst
freebsd-ports-gnome-8b6cb5669410e47ab74524b9f408a16fd9532284.zip
Update from 0.7.32 to 0.7.33.
[*] Add support for http_accesskey module from http://wiki.codemongers.com/NginxHttpAccessKeyModule. [*] Spotted by: Andrey Belashkov aka manager at capsida dot net <ChangeLog> *) Bugfix: a double response might be returned if the epoll or rtsig methods are used and a redirect was returned to a request with body. Thanks to Eden Li. *) Bugfix: the $sent_http_location variable was empty for some redirects types. *) Bugfix: a segmentation fault might occur in worker process if "resolver" directive was used in SMTP proxy. </ChangeLog>
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile16
-rw-r--r--www/nginx-devel/distinfo9
2 files changed, 21 insertions, 4 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 4222c418c307..3cd8e268aec1 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.7.32
+PORTVERSION= 0.7.33
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -20,6 +20,7 @@ COMMENT= Robust and small WWW server
OPTIONS= DEBUG "Enable nginx debugging" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
HTTP_MODULE "Enable HTTP module" on \
+ HTTP_ACCESSKEY_MODULE "Enable http_accesskey module" off \
HTTP_ADDITION_MODULE "Enable http_addition module" off \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
@@ -88,6 +89,14 @@ CONFIGURE_ARGS+=--http-client-body-temp-path=${NGINX_TMPDIR}/client_body_temp \
--http-fastcgi-temp-path=${NGINX_TMPDIR}/fastcgi_temp \
--http-log-path=${NGINX_LOGDIR}/nginx-access.log
+.if defined(WITH_HTTP_ACCESSKEY_MODULE)
+NGINX_ACCESSKEY_MODULE_VERSION= 2.0.3
+MASTER_SITES+= ${MASTER_SITE_LOCAL}:accesskey
+MASTER_SITE_SUBDIR= osa:accesskey
+DISTFILES+= nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}.tar.gz:accesskey
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_ADDITION_MODULE)
CONFIGURE_ARGS+=--with-http_addition_module
.endif
@@ -204,6 +213,11 @@ post-patch:
@${REINPLACE_CMD} 's!%%HTTP_PORT%%!${HTTP_PORT}!; \
s!%%PREFIX%%!${PREFIX}!' \
${WRKSRC}/conf/nginx.conf
+.if defined(WITH_HTTP_ACCESSKEY_MODULE)
+ @${REINPLACE_CMD} \
+ 's!$$HTTP_ACCESSKEY_MODULE!ngx_http_accesskey_module!' \
+ ${WRKDIR}/nginx-accesskey-${NGINX_ACCESSKEY_MODULE_VERSION}/config
+.endif
do-build:
@cd ${WRKSRC} && ${MAKE}
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 7adf3b1760fc..44b8736ee534 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,6 +1,9 @@
-MD5 (nginx-0.7.32.tar.gz) = 6e3f8f3487ccaf3c3a33fc547d6e04c3
-SHA256 (nginx-0.7.32.tar.gz) = 713db6ebddf920b0a88a3651ce41653c087328a69c32041c202add5741412042
-SIZE (nginx-0.7.32.tar.gz) = 566286
+MD5 (nginx-0.7.33.tar.gz) = 94148f290193aeae8f579d7d8c1fc580
+SHA256 (nginx-0.7.33.tar.gz) = 3c5a0dd61e810c9d694638ede05f1c9f612234a61a2246ae703e775df9d35723
+SIZE (nginx-0.7.33.tar.gz) = 566684
+MD5 (nginx-accesskey-2.0.3.tar.gz) = 9b5304346d5139b1841f5baa01ab0cbe
+SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
+SIZE (nginx-accesskey-2.0.3.tar.gz) = 2632
MD5 (nginx_upload_module-2.0.8.tar.gz) = 308d43743158263b0d5016aeffadaaa7
SHA256 (nginx_upload_module-2.0.8.tar.gz) = eaacf4dd4d254df5f2666e13f07edd8c1c7e51ddfe625b88e422583cfbcb6165
SIZE (nginx_upload_module-2.0.8.tar.gz) = 17497