aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx-devel
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2010-09-03 21:21:31 +0800
committerosa <osa@FreeBSD.org>2010-09-03 21:21:31 +0800
commitdc845616e7ae743af0bc353d42bf8d3c472a94c9 (patch)
tree29bd2dda40f2ba4e90b4835cc3a6bc630a255eca /www/nginx-devel
parent10233b4c8cc9104ee36971cf7b1a67759ce79942 (diff)
downloadfreebsd-ports-gnome-dc845616e7ae743af0bc353d42bf8d3c472a94c9.tar.gz
freebsd-ports-gnome-dc845616e7ae743af0bc353d42bf8d3c472a94c9.tar.zst
freebsd-ports-gnome-dc845616e7ae743af0bc353d42bf8d3c472a94c9.zip
Install three plain configuration files with -dist prefix.
Do not remove *cgi_params configuration files, which may carefully edited by the user. Bump PORTREVISION.
Diffstat (limited to 'www/nginx-devel')
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx-devel/pkg-plist12
2 files changed, 12 insertions, 5 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 71d25b38e330..f365f75807b8 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nginx
PORTVERSION= 0.8.50
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -498,10 +499,10 @@ do-install:
${MKDIR} ${ETCDIR} ${NGINX_TMPDIR}
${CHOWN} ${WWWOWN}:${WWWGRP} ${NGINX_TMPDIR}
${INSTALL_PROGRAM} ${WRKSRC}/objs/nginx ${PREFIX}/sbin
-.for i in fastcgi_params koi-utf koi-win scgi_params uwsgi_params win-utf
+.for i in koi-utf koi-win win-utf
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
.endfor
-.for i in mime.types nginx.conf
+.for i in fastcgi_params mime.types nginx.conf scgi_params uwsgi_params
[ -f ${ETCDIR}/${i} ] || \
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/conf/${i} ${ETCDIR}/${i}-dist
diff --git a/www/nginx-devel/pkg-plist b/www/nginx-devel/pkg-plist
index 5faee08c592e..7a85efd5c1e4 100644
--- a/www/nginx-devel/pkg-plist
+++ b/www/nginx-devel/pkg-plist
@@ -1,9 +1,15 @@
@comment $FreeBSD$
-%%ETCDIR%%/fastcgi_params
+@unexec if cmp -s %D/%%ETCDIR%%/fastcgi_params-dist %D/%%ETCDIR%%/fastcgi_params; then rm -f %D/%%ETCDIR%%/fastcgi_params; fi
+%%ETCDIR%%/fastcgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/fastcgi_params ] ; then cp -p %D/%F %B/fastcgi_params; fi
%%ETCDIR%%/koi-utf
%%ETCDIR%%/koi-win
-%%ETCDIR%%/scgi_params
-%%ETCDIR%%/uwsgi_params
+@unexec if cmp -s %D/%%ETCDIR%%/scgi_params-dist %D/%%ETCDIR%%/scgi_params; then rm -f %D/%%ETCDIR%%/scgi_params; fi
+%%ETCDIR%%/scgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/scgi_params ] ; then cp -p %D/%F %B/scgi_params; fi
+@unexec if cmp -s %D/%%ETCDIR%%/uwsgi_params-dist %D/%%ETCDIR%%/uwsgi_params; then rm -f %D/%%ETCDIR%%/uwsgi_params; fi
+%%ETCDIR%%/uwsgi_params-dist
+@exec if [ ! -f %D/%%ETCDIR%%/uwsgi_params ] ; then cp -p %D/%F %B/uwsgi_params; fi
%%ETCDIR%%/win-utf
@unexec if cmp -s %D/%%ETCDIR%%/mime.types-dist %D/%%ETCDIR%%/mime.types; then rm -f %D/%%ETCDIR%%/mime.types; fi
%%ETCDIR%%/mime.types-dist