aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2007-04-02 19:26:05 +0800
committerosa <osa@FreeBSD.org>2007-04-02 19:26:05 +0800
commit6816c3bb3dc2396590326e064b2a4fb6f852742b (patch)
tree22fada70fc1498611cd243a65669ecc4be827bd1 /www/nginx/Makefile
parent03779b326c60907210ee513d02fe64d57e0fce4f (diff)
downloadfreebsd-ports-gnome-6816c3bb3dc2396590326e064b2a4fb6f852742b.tar.gz
freebsd-ports-gnome-6816c3bb3dc2396590326e064b2a4fb6f852742b.tar.zst
freebsd-ports-gnome-6816c3bb3dc2396590326e064b2a4fb6f852742b.zip
Update to latest bugfix release 0.5.17.
Change knob IMAP_MODULE to MAIL_MODULE (1). Keep compatibility for IMAP_MODULE, notice warning if usage. Cosmetic fixes for package list (2). (1) Anton Yuzhaninov (citrin at rambler-co dot ru) (2) portlint -a
Diffstat (limited to 'www/nginx/Makefile')
-rw-r--r--www/nginx/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 44f1b20fd4b9..75208d0a2f8f 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 0.5.15
+PORTVERSION= 0.5.17
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -52,9 +52,9 @@ NGINX_OPENSSL= yes
CONFIGURE_ARGS+=--with-http_ssl_module
.endif
-.if defined(WITH_IMAP_MODULE)
+.if defined(WITH_MAIL_MODULE) || defined(WITH_IMAP_MODULE)
NGINX_OPENSSL= yes
-CONFIGURE_ARGS+=--with-imap --with-imap_ssl_module
+CONFIGURE_ARGS+=--with-mail --with-mail_ssl_module
.endif
.if defined(NGINX_OPENSSL)
@@ -81,6 +81,14 @@ PLIST_SUB+= WWWDATA=""
PLIST_SUB+= NGINX_TMPDIR=${NGINX_TMPDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+pre-fetch:
+.if defined(WITH_IMAP_MODULE)
+ @${ECHO_MSG}
+ @${ECHO_MSG} WITH_IMAP_MODULE knob deprecated.
+ @${ECHO_MSG} Please use WITH_MAIL_MODULE knob instead.
+ @${ECHO_MSG}
+.endif
+
post-patch:
@${REINPLACE_CMD} 's!%%HTTP_PORT%%!${HTTP_PORT}!; \
s!%%PREFIX%%!${PREFIX}!' \