aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-12-22 02:46:06 +0800
committerosa <osa@FreeBSD.org>2009-12-22 02:46:06 +0800
commit1e97c037732b3368f8ece7aeb54fd60cc55d8079 (patch)
tree2701cf3da393678b03e364461bf875d241af901f /www/nginx
parent372c1b180c99983b71ef3f4794765c78b6377c40 (diff)
downloadfreebsd-ports-gnome-1e97c037732b3368f8ece7aeb54fd60cc55d8079.tar.gz
freebsd-ports-gnome-1e97c037732b3368f8ece7aeb54fd60cc55d8079.tar.zst
freebsd-ports-gnome-1e97c037732b3368f8ece7aeb54fd60cc55d8079.zip
Accordingly add third party http_push module, version 0.69.
Do not bump PORTREVISIONs.
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
-rw-r--r--www/nginx/distinfo3
2 files changed, 11 insertions, 0 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index b06ea52712e4..9fab1feec3e7 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -48,6 +48,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_MOGILEFS_MODULE "3rd party mogilefs module" off \
HTTP_MP4_H264_MODULE "3rd party mp4/h264 module" off \
HTTP_NOTICE_MODULE "3rd party notice module" off \
+ HTTP_PUSH_MODULE "3rd party push module" off \
HTTP_REDIS_MODULE "3rd party http_redis module" off \
HTTP_RESPONSE_MODULE "3rd party http_response module" off \
HTTP_UPLOAD_MODULE "3rd party upload module" off \
@@ -201,6 +202,13 @@ CONFIGURE_ARGS+=--with-http_perl_module
USE_PERL5= yes
.endif
+.if defined(WITH_HTTP_PUSH_MODULE)
+NGINX_PUSH_MODULE_VERSION= 0.69
+MASTER_SITES+= http://pushmodule.slact.net/downloads/:push
+DISTFILES+= nginx_http_push_module-${NGINX_PUSH_MODULE_VERSION}.tar.gz:push
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx_http_push_module-${NGINX_PUSH_MODULE_VERSION}
+.endif
+
.if defined(WITH_HTTP_RANDOM_INDEX_MODULE)
CONFIGURE_ARGS+=--with-http_random_index_module
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 664f152e9094..ba81c0107d37 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -22,6 +22,9 @@ SIZE (nginx_mod_h264_streaming-2.2.5.tar.gz) = 39771
MD5 (nginx-notice-2.tar.gz) = 7253bdd2b88cc981867b72efdc484772
SHA256 (nginx-notice-2.tar.gz) = 682824a9f5187831ee49e5828bafebde5c25706e681d361804f96308f24e58c2
SIZE (nginx-notice-2.tar.gz) = 3253
+MD5 (nginx_http_push_module-0.69.tar.gz) = 5722ac1ec726194a480bd19ad7e99996
+SHA256 (nginx_http_push_module-0.69.tar.gz) = 2384ff752115b5f959abf17ca466217a675796e295ba5c46d20270923fe286ec
+SIZE (nginx_http_push_module-0.69.tar.gz) = 28345
MD5 (ngx_http_redis-0.2.0.tar.gz) = 4055ed2b19e7634c40384c13e680b103
SHA256 (ngx_http_redis-0.2.0.tar.gz) = d5a5a8d55983ce55670b231c254a89d8ef0f81830d0dd2f1abe146e42a5406a3
SIZE (ngx_http_redis-0.2.0.tar.gz) = 5706