aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-25 15:46:56 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-25 15:46:56 +0800
commit242167832372268c3595eb9f69e940950faa4b95 (patch)
tree960d0cfd6e28e9f5ca13d11b26f0f76366c96ff6 /www/nginx
parent1788b0aa4ef5c8e72fb6079ecf764c0321308ad6 (diff)
downloadfreebsd-ports-gnome-242167832372268c3595eb9f69e940950faa4b95.tar.gz
freebsd-ports-gnome-242167832372268c3595eb9f69e940950faa4b95.tar.zst
freebsd-ports-gnome-242167832372268c3595eb9f69e940950faa4b95.zip
www/nginx: drop unused ImageMagick dependency
nginx-video-thumbextractor-module-0.7.0/README.textile: h2(#0_5_0). v0.5.0 * remove MagickWand dependency which cause memory leak which saved it from being BROKEN by r358176: In file included from src/ngx_http_video_thumbextractor_module.c:3: src/ngx_http_video_thumbextractor_module_utils.c:5:10: fatal error: 'wand/magick_wand.h' file not found #include <wand/magick_wand.h> ^ 1 error generated. *** Error code 1 Reported by: antoine (via exp-run for www/tengine)
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 0035e944b23c..322dbbb64589 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nginx
PORTVERSION= 1.10.2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= www
MASTER_SITES= http://nginx.org/download/
@@ -750,14 +750,12 @@ NGINX_VIDEO_THUMBEXTRACTOR_VERSION= 0.7.0
LIB_DEPENDS+= libavformat.so:multimedia/ffmpeg \
libavcodec.so:multimedia/ffmpeg \
libavutil.so:multimedia/ffmpeg \
- libswscale.so:multimedia/ffmpeg \
- ${IMAGEMAGICK_LIB_DEPENDS}
+ libswscale.so:multimedia/ffmpeg
USES+= jpeg
GH_ACCOUNT+= wandenberg:vte
GH_PROJECT+= nginx-video-thumbextractor-module:vte
GH_TAGNAME+= ${NGINX_VIDEO_THUMBEXTRACTOR_VERSION}:vte
-CONFIGURE_ARGS+=--add-module=${WRKSRC_vte} --with-cc-opt="-I ${LOCALBASE}/include \
- -I ${LOCALBASE}/include/ImageMagick"
+CONFIGURE_ARGS+=--add-module=${WRKSRC_vte}
.endif
.if ${PORT_OPTIONS:MHTTP_XSLT}