aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2012-03-01 03:53:17 +0800
committerosa <osa@FreeBSD.org>2012-03-01 03:53:17 +0800
commit2f797b93e431cf61d7d8730e29715a4b490a29ab (patch)
tree4bf02f42759388af5b8a8fb3392e6bc3ed1aab16 /www/nginx
parent9112977f23c00253433b6d1474eadf8343281d12 (diff)
downloadfreebsd-ports-gnome-2f797b93e431cf61d7d8730e29715a4b490a29ab.tar.gz
freebsd-ports-gnome-2f797b93e431cf61d7d8730e29715a4b490a29ab.tar.zst
freebsd-ports-gnome-2f797b93e431cf61d7d8730e29715a4b490a29ab.zip
Fix fetch notice third-party module.
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-ngx_http_notice_module.c4
3 files changed, 9 insertions, 7 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 0cca3a69d6df..824e7745ed05 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -322,9 +322,11 @@ EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_streaming_module.c
.endif
.if defined(WITH_HTTP_NOTICE_MODULE)
-MASTER_SITES+= http://xph.us/dist/nginx-notice/:notice2
-DISTFILES+= nginx-notice-2.tar.gz:notice2
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-notice-2
+GIT_NOTICE_MODULE_VERSION= 0-g3c95966
+FETCH_ARGS= -pRr
+MASTER_SITES+= https://github.com/kr/nginx-notice/tarball/master/:notice
+DISTFILES+= kr-nginx-notice-${GIT_NOTICE_MODULE_VERSION}.tar.gz:notice
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/kr-nginx-notice-${GIT_NOTICE_MODULE_VERSION:S/^0-g//}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_http_notice_module.c
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 15527531cee0..d98d1acefbe8 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -28,8 +28,8 @@ SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6
SIZE (nginx_mogilefs_module-1.0.4.tar.gz) = 11208
SHA256 (nginx_mod_h264_streaming-2.2.7.tar.gz) = 6d974ba630cef59de1f60996c66b401264a345d25988a76037c2856cec756c19
SIZE (nginx_mod_h264_streaming-2.2.7.tar.gz) = 44012
-SHA256 (nginx-notice-2.tar.gz) = 682824a9f5187831ee49e5828bafebde5c25706e681d361804f96308f24e58c2
-SIZE (nginx-notice-2.tar.gz) = 3253
+SHA256 (kr-nginx-notice-0-g3c95966.tar.gz) = bb0b8c603b2df206aeb13100fb60c1328aa6a69d0ac7f411e5dabe8fdb2affce
+SIZE (kr-nginx-notice-0-g3c95966.tar.gz) = 3348
SHA256 (nginx_http_push_module-0.692.tar.gz) = 64868708071aa21dbc4c7a07d149dd6ec9108fb7eaf2aad5ad069406151f17fe
SIZE (nginx_http_push_module-0.692.tar.gz) = 29119
SHA256 (ngx_http_redis-0.3.5.tar.gz) = 5398805bbc790b8ae5ddb5079cf726df63c8c206bbf9a3a4b035412194aac82e
diff --git a/www/nginx/files/extra-patch-ngx_http_notice_module.c b/www/nginx/files/extra-patch-ngx_http_notice_module.c
index 851c7392a4f3..feb39a964b23 100644
--- a/www/nginx/files/extra-patch-ngx_http_notice_module.c
+++ b/www/nginx/files/extra-patch-ngx_http_notice_module.c
@@ -1,5 +1,5 @@
---- ../nginx-notice-2/ngx_http_notice_module.c.orig 2009-07-16 18:37:57.000000000 +0200
-+++ ../nginx-notice-2/ngx_http_notice_module.c 2009-07-16 08:09:38.000000000 +0200
+--- ../kr-nginx-notice-3c95966/ngx_http_notice_module.c.orig 2009-07-16 18:37:57.000000000 +0200
++++ ../kr-nginx-notice-3c95966/ngx_http_notice_module.c 2009-07-16 08:09:38.000000000 +0200
@@ -153,7 +153,7 @@
return NGX_HTTP_NOT_ALLOWED;
}