aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2009-12-25 23:20:15 +0800
committerosa <osa@FreeBSD.org>2009-12-25 23:20:15 +0800
commit73d3d221948697da515721c68639d8ffe599a825 (patch)
tree20ee4a2c6e060dd90309bf9a6d5f891ab96cfd49 /www/nginx
parent27fb91cc7ee924461c7ecf4949599d36ea71137e (diff)
downloadfreebsd-ports-gnome-73d3d221948697da515721c68639d8ffe599a825.tar.gz
freebsd-ports-gnome-73d3d221948697da515721c68639d8ffe599a825.tar.zst
freebsd-ports-gnome-73d3d221948697da515721c68639d8ffe599a825.zip
Add one more know WITH_DEBUGLOG by split debug features
for distro (--with-debug) and system (-g) specific.
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 8e738a0768b2..4fb23613bb48 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -16,7 +16,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= osa@FreeBSD.org
COMMENT= Robust and small WWW server
-OPTIONS= DEBUG "Enable nginx debugging" off \
+OPTIONS= DEBUG "Build with debug" off \
+ DEBUGLOG "Enable debug log (--with-debug)" off \
IPV6 "Enable IPv6" off \
GOOGLE_PERFTOOLS "Enable google perftools module" off \
HTTP_MODULE "Enable HTTP module" on \
@@ -102,10 +103,13 @@ IGNORE= requires at least HTTP_MODULE or MAIL_MODULE to \
.if defined(WITH_DEBUG)
CFLAGS+= -g -DNGX_DEBUG_MALLOC
-CONFIGURE_ARGS+=--with-debug
STRIP= #do not strip if nginx with debug information
.endif
+.if defined(WITH_DEBUGLOG)
+CONFIGURE_ARGS+=--with-debug
+.endif
+
.if defined(WITH_IPV6)
CONFIGURE_ARGS+=--with-ipv6
CATEGORIES+= ipv6