aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2013-08-17 18:57:29 +0800
committerosa <osa@FreeBSD.org>2013-08-17 18:57:29 +0800
commit87b7410c10db792dabc9a6c770a12f2734ff0859 (patch)
tree4476e0aee6e0cd16f50280cb253cd5444de01a4d /www/nginx
parent85a48b686629b1f7967dfa6ac70ddab79f9ef66d (diff)
downloadfreebsd-ports-gnome-87b7410c10db792dabc9a6c770a12f2734ff0859.tar.gz
freebsd-ports-gnome-87b7410c10db792dabc9a6c770a12f2734ff0859.tar.zst
freebsd-ports-gnome-87b7410c10db792dabc9a6c770a12f2734ff0859.zip
Update third-party modsecurity module from 2.7.4 to 2.7.5.
<ChangeLog> 23 Jul 2013 - 2.7.5 ------------------- Improvements: * SecUnicodeCodePage is deprecated. SecUnicodeMapFile now accepts the code page as a second parameter. * Updated Libinjection to version 3.4.1. Many improvements were made. * Severity action now supports strings (emergency, alert, critical, error, warning, notice, info, debug). Bug Fixes: * Fixed utf8toUnicode tfn null byte conversion. * Fixed NGINX crash when issue reload command. * Fixed flush output buffer before inject modified hashed response body. * Fixed url normalization for Hash Engine. * Fixed NGINX ap_unixd_set_global_perms_mutex compilation error with apache 2.4 devel files. </ChangeLog>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-nginx-modsecurity-config4
3 files changed, 5 insertions, 5 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 759cf01dabe7..b0f01ca345b6 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -628,7 +628,7 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/agentzh-memc-nginx-module-${GIT_MEMC_VERS
.endif
.if ${PORT_OPTIONS:MMODSECURITY}
-NGINX_MODSECURITY_VERSION= 2.7.4
+NGINX_MODSECURITY_VERSION= 2.7.5
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre \
apr-1:${PORTSDIR}/devel/apr1
USE_APACHE= 22+
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index e405ec71dddd..a18d28013bba 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -70,8 +70,8 @@ SHA256 (chaoslawful-lua-nginx-module-v0.8.2-0-g3915187.tar.gz) = f10ac35781eb119
SIZE (chaoslawful-lua-nginx-module-v0.8.2-0-g3915187.tar.gz) = 480845
SHA256 (agentzh-memc-nginx-module-v0.13rc3-0-g4007350.tar.gz) = 8c6f7a421346be1f53240b370cd29edd833f8ca32f6f9b926d66230b15727f0c
SIZE (agentzh-memc-nginx-module-v0.13rc3-0-g4007350.tar.gz) = 39778
-SHA256 (modsecurity-apache_2.7.4.tar.gz) = 605d6f1b03e648001ef1c7db7b18d51c01edd443b57cbbd4e298770ffdcd0eb9
-SIZE (modsecurity-apache_2.7.4.tar.gz) = 1014983
+SHA256 (modsecurity-apache_2.7.5.tar.gz) = 9e907536278d8da80d3dbb29aeffe9c4ec37ce9b641035b2da64e993135647a2
+SIZE (modsecurity-apache_2.7.5.tar.gz) = 1045387
SHA256 (naxsi-core-0.50.tgz) = 7cece5f9d9c5df9e09af1e1023bc8e04bbbbe953e67461b893b8240e82ca52ef
SIZE (naxsi-core-0.50.tgz) = 49809
SHA256 (passenger-4.0.13.tar.gz) = 528b734bba041a7f1af7327534f9d5c22b581e477b19b49646cfc6c5a43e5a96
diff --git a/www/nginx/files/extra-patch-nginx-modsecurity-config b/www/nginx/files/extra-patch-nginx-modsecurity-config
index 0b34d169bdf0..a754631be8d4 100644
--- a/www/nginx/files/extra-patch-nginx-modsecurity-config
+++ b/www/nginx/files/extra-patch-nginx-modsecurity-config
@@ -1,5 +1,5 @@
---- ../modsecurity-apache_2.7.4/nginx/modsecurity/config.orig 2013-06-04 10:14:07.000000000 +0400
-+++ ../modsecurity-apache_2.7.4/nginx/modsecurity/config 2013-06-04 10:17:30.000000000 +0400
+--- ../modsecurity-apache_2.7.5/nginx/modsecurity/config.orig 2013-06-04 10:14:07.000000000 +0400
++++ ../modsecurity-apache_2.7.5/nginx/modsecurity/config 2013-06-04 10:17:30.000000000 +0400
@@ -3,5 +3,5 @@
HTTP_AUX_FILTER_MODULES="ngx_http_modsecurity $HTTP_AUX_FILTER_MODULES"
NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/ngx_http_modsecurity.c $ngx_addon_dir/apr_bucket_nginx.c $ngx_addon_dir/ngx_pool_context.c"