aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2014-08-11 01:47:04 +0800
committerSergey A. Osokin <osa@FreeBSD.org>2014-08-11 01:47:04 +0800
commita0541d0f6354643178de932b5aea75109fc0a1aa (patch)
tree3d002e05be6cc3b7ce9aa43ff313ce054a326717 /www/nginx
parent0d99850f54c3a7dad72169ba71e5e1be37663cf1 (diff)
downloadfreebsd-ports-gnome-a0541d0f6354643178de932b5aea75109fc0a1aa.tar.gz
freebsd-ports-gnome-a0541d0f6354643178de932b5aea75109fc0a1aa.tar.zst
freebsd-ports-gnome-a0541d0f6354643178de932b5aea75109fc0a1aa.zip
Update third-party modsecurity module from 2.7.5 to latest version 2.8.0.
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile15
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-nginx-modsecurity-config10
-rw-r--r--www/nginx/files/extra-patch-nginx-modsecurity-configure24
4 files changed, 34 insertions, 19 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 7b1b0f56f0fd..99f22275f757 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -624,15 +624,16 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/openresty-memc-nginx-module-${GIT_MEMC_VE
.endif
.if ${PORT_OPTIONS:MMODSECURITY}
-NGINX_MODSECURITY_VERSION= 2.7.5
+NGINX_MODSECURITY_VERSION= 2.8.0
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
- libapr-1.so:${PORTSDIR}/devel/apr1
+ libapr-1.so:${PORTSDIR}/devel/apr1 \
+ libyajl.so:${PORTSDIR}/devel/yajl
USE_APACHE= 22+
USE_GNOME= libxml2
MASTER_SITES+= http://www.modsecurity.org/tarball/${NGINX_MODSECURITY_VERSION}/:modsecurity
-DISTFILES+= modsecurity-apache_${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
-CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nginx-modsecurity-config
+DISTFILES+= modsecurity-${NGINX_MODSECURITY_VERSION}.tar.gz:modsecurity
+CONFIGURE_ARGS+=--add-module=${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/nginx/modsecurity
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-nginx-modsecurity-configure
.endif
.if ${PORT_OPTIONS:MNAXSI}
@@ -969,12 +970,12 @@ post-patch:
.if ${PORT_OPTIONS:MMODSECURITY}
@${REINPLACE_CMD} \
's!%%PREFIX%%!${LOCALBASE}!g' \
- ${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION}/nginx/modsecurity/config
+ ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION}/configure
.endif
pre-configure:
.if ${PORT_OPTIONS:MMODSECURITY}
- ( cd ${WRKDIR}/modsecurity-apache_${NGINX_MODSECURITY_VERSION} && \
+ ( cd ${WRKDIR}/modsecurity-${NGINX_MODSECURITY_VERSION} && \
CC="${CC}" ./${CONFIGURE_SCRIPT} --enable-standalone-module && \
${MAKE} )
.endif
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index a6724f75bc40..a555c2969bcb 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -70,8 +70,8 @@ SHA256 (openresty-lua-nginx-module-v0.9.4-0-g6169a19.tar.gz) = 4d869650d03a76d28
SIZE (openresty-lua-nginx-module-v0.9.4-0-g6169a19.tar.gz) = 470182
SHA256 (openresty-memc-nginx-module-v0.14-0-gde4cf86.tar.gz) = b60fed5921a0c19c6ffe71e5c764193283dbe635bb3bad6febd6655f94a633e9
SIZE (openresty-memc-nginx-module-v0.14-0-gde4cf86.tar.gz) = 37756
-SHA256 (modsecurity-apache_2.7.5.tar.gz) = 9e907536278d8da80d3dbb29aeffe9c4ec37ce9b641035b2da64e993135647a2
-SIZE (modsecurity-apache_2.7.5.tar.gz) = 1045387
+SHA256 (modsecurity-2.8.0.tar.gz) = 5cbbc7fc993d39106b653213753d25c4ec21771eee17b01b69122ccf3f73460e
+SIZE (modsecurity-2.8.0.tar.gz) = 3940357
SHA256 (naxsi-core-0.50.tgz) = 7cece5f9d9c5df9e09af1e1023bc8e04bbbbe953e67461b893b8240e82ca52ef
SIZE (naxsi-core-0.50.tgz) = 49809
SHA256 (passenger-4.0.48.tar.gz) = 0fe6a42c82eee59511b04aa683f65fb4eaf1acc6310de3fbbe905fa507347e24
diff --git a/www/nginx/files/extra-patch-nginx-modsecurity-config b/www/nginx/files/extra-patch-nginx-modsecurity-config
deleted file mode 100644
index a754631be8d4..000000000000
--- a/www/nginx/files/extra-patch-nginx-modsecurity-config
+++ /dev/null
@@ -1,10 +0,0 @@
---- ../modsecurity-apache_2.7.5/nginx/modsecurity/config.orig 2013-06-04 10:14:07.000000000 +0400
-+++ ../modsecurity-apache_2.7.5/nginx/modsecurity/config 2013-06-04 10:17:30.000000000 +0400
-@@ -3,5 +3,5 @@
- HTTP_AUX_FILTER_MODULES="ngx_http_modsecurity $HTTP_AUX_FILTER_MODULES"
- NGX_ADDON_SRCS="$NGX_ADDON_SRCS $ngx_addon_dir/ngx_http_modsecurity.c $ngx_addon_dir/apr_bucket_nginx.c $ngx_addon_dir/ngx_pool_context.c"
- NGX_ADDON_DEPS="$NGX_ADDON_DEPS $ngx_addon_dir/apr_bucket_nginx.h $ngx_addon_dir/ngx_pool_context.h"
--CORE_LIBS="$CORE_LIBS $ngx_addon_dir/../../standalone/.libs/standalone.a -L/usr/local/apr/lib -lapr-1 -L/usr/local/apr/lib -laprutil-1 -lpcre -lxml2 -lz -lm -ldl "
--CORE_INCS="$CORE_INCS $ngx_addon_dir $ngx_addon_dir/../../standalone $ngx_addon_dir/../../apache2 /usr/include/libxml2 /usr/local/apache2/include /usr/local/apr/include/apr-1 /usr/local/apr/include/apr-1"
-+CORE_LIBS="$CORE_LIBS $ngx_addon_dir/../../standalone/.libs/standalone.a -lapr-1 -laprutil-1 -lpcre -lxml2 -lz -lm "
-+CORE_INCS="$CORE_INCS $ngx_addon_dir $ngx_addon_dir/../../standalone $ngx_addon_dir/../../apache2 %%PREFIX%%/include/libxml2 %%PREFIX%%/include/apache22 %%PREFIX%%/include/apr-1 "
diff --git a/www/nginx/files/extra-patch-nginx-modsecurity-configure b/www/nginx/files/extra-patch-nginx-modsecurity-configure
new file mode 100644
index 000000000000..92e5aac2e6da
--- /dev/null
+++ b/www/nginx/files/extra-patch-nginx-modsecurity-configure
@@ -0,0 +1,24 @@
+--- ../modsecurity-2.8.0/configure.orig 2014-04-15 16:44:15.000000000 +0400
++++ ../modsecurity-2.8.0/configure 2014-08-10 21:24:00.000000000 +0400
+@@ -14664,7 +14664,7 @@
+ no) :
+ test_paths= ;; #(
+ yes) :
+- test_paths="/usr/local/liblua /usr/local/lua /usr/local /opt/liblua /opt/lua /opt /usr" ;; #(
++ test_paths="%%PREFIX%%/liblua %%PREFIX%%/lua %%PREFIX%% /opt/liblua /opt/lua /opt /usr" ;; #(
+ *) :
+ test_paths="${with_lua}" ;;
+ esac
+@@ -14715,10 +14715,10 @@
+ LUA_CFLAGS="`${LUA_CONFIG} ${LUA_PKGNAME} --cflags`"
+ if test "$verbose_output" -eq 1; then { $as_echo "$as_me:${as_lineno-$LINENO}: lua CFLAGS: $LUA_CFLAGS" >&5
+ $as_echo "$as_me: lua CFLAGS: $LUA_CFLAGS" >&6;}; fi
+- LUA_LDADD="`${LUA_CONFIG} ${LUA_PKGNAME} --libs-only-l`"
++ LUA_LDADD="`${LUA_CONFIG} ${LUA_PKGNAME} --libs-only-l | sed 's/lua/lua-5.1/'`"
+ if test "$verbose_output" -eq 1; then { $as_echo "$as_me:${as_lineno-$LINENO}: lua LDADD: $LUA_LDADD" >&5
+ $as_echo "$as_me: lua LDADD: $LUA_LDADD" >&6;}; fi
+- LUA_LDFLAGS="`${LUA_CONFIG} ${LUA_PKGNAME} --libs-only-L --libs-only-other`"
++ LUA_LDFLAGS="`${LUA_CONFIG} ${LUA_PKGNAME} --libs-only-L --libs-only-other | sed 's/\/lua51//'`"
+ if test "$verbose_output" -eq 1; then { $as_echo "$as_me:${as_lineno-$LINENO}: lua LDFLAGS: $LUA_LDFLAGS" >&5
+ $as_echo "$as_me: lua LDFLAGS: $LUA_LDFLAGS" >&6;}; fi
+ else