aboutsummaryrefslogtreecommitdiffstats
path: root/www/nginx
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2011-06-01 20:06:12 +0800
committerosa <osa@FreeBSD.org>2011-06-01 20:06:12 +0800
commitc634203cb5bc5ed395fe8bd9fde775be3778ef64 (patch)
treec5a7724974fe056d1a33c176cef27780a2589a80 /www/nginx
parent6937eca8a33b8d5a00630f1d31751018d4e27f87 (diff)
downloadfreebsd-ports-gnome-c634203cb5bc5ed395fe8bd9fde775be3778ef64.tar.gz
freebsd-ports-gnome-c634203cb5bc5ed395fe8bd9fde775be3778ef64.tar.zst
freebsd-ports-gnome-c634203cb5bc5ed395fe8bd9fde775be3778ef64.zip
Update from 1.0.3 to 1.0.4.
<ChangeLog> *) Change: now regular expressions case sensitivity in the "map" directive is given by prefixes "~" or "~*". *) Feature: now shared zones and caches use POSIX semaphores on Linux. Thanks to Denis F. Latypoff. *) Bugfix: "stalled" cache updating" alert. *) Bugfix: nginx could not be built --without-http_auth_basic_module; the bug had appeared in 1.0.3. </ChangeLog>
Diffstat (limited to 'www/nginx')
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/patch-src::core::ngx_crypt.c19
3 files changed, 3 insertions, 22 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 61dcc582cf2d..258c6896c014 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nginx
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www
MASTER_SITES= http://sysoev.ru/nginx/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index df4964179a32..5f98fa463a1c 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -1,5 +1,5 @@
-SHA256 (nginx-1.0.3.tar.gz) = 5a5da0e9f62e1e7306bc7bdc83850265f7f91af59ba5c5fd1c8650025415b129
-SIZE (nginx-1.0.3.tar.gz) = 661551
+SHA256 (nginx-1.0.4.tar.gz) = ff54f7deea3dc69da467f3b4c2c8167d5967a096451148ed362e20fb0203f043
+SIZE (nginx-1.0.4.tar.gz) = 661444
SHA256 (nginx_accept_language_module.tar.gz) = 7a4c2d42a83c5b6efd2b7b13ad232850b6ab0ca4261df6b46fb7d2d2738b1c0a
SIZE (nginx_accept_language_module.tar.gz) = 3299
SHA256 (nginx-accesskey-2.0.3.tar.gz) = d9e94321e78a02de16c57f3e048fd31059fd8116ed03d6de7180f435c52502b1
diff --git a/www/nginx/files/patch-src::core::ngx_crypt.c b/www/nginx/files/patch-src::core::ngx_crypt.c
deleted file mode 100644
index e457612ecd41..000000000000
--- a/www/nginx/files/patch-src::core::ngx_crypt.c
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: src/core/ngx_crypt.c
-===================================================================
---- src/core/ngx_crypt.c (revision 3925)
-+++ src/core/ngx_crypt.c (working copy)
-@@ -12,6 +12,8 @@
- #endif
-
-
-+#if (NGX_CRYPT)
-+
- static ngx_int_t ngx_crypt_apr1(ngx_pool_t *pool, u_char *key, u_char *salt,
- u_char **encrypted);
- static ngx_int_t ngx_crypt_plain(ngx_pool_t *pool, u_char *key, u_char *salt,
-@@ -232,3 +234,5 @@
- }
-
- #endif /* NGX_HAVE_SHA1 */
-+
-+#endif /* NGX_CRYPT */