aboutsummaryrefslogtreecommitdiffstats
path: root/www/node-devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-19 18:12:06 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-19 18:12:06 +0800
commit5aa8ac394547290c43ea77083bf20e21074af39a (patch)
tree64c217be55e438c7d67d27bd4d981fc1c4b24c10 /www/node-devel
parent3515eabaa4136a1122b598035723c7306ab098fb (diff)
downloadfreebsd-ports-gnome-5aa8ac394547290c43ea77083bf20e21074af39a.tar.gz
freebsd-ports-gnome-5aa8ac394547290c43ea77083bf20e21074af39a.tar.zst
freebsd-ports-gnome-5aa8ac394547290c43ea77083bf20e21074af39a.zip
- Update to 0.11.8
- While I'm here: - Add LICENSE - Convert to new LIB_DEPENDS format - Support STAGEDIR Changes: https://github.com/joyent/node/blob/v0.11.8-release/ChangeLog PR: ports/184061 Submitted by: Amim Knabben <amim.knabben@gmail.com> Approved by: Daniel Lin <linpct@gmail.com> (maintainer)
Diffstat (limited to 'www/node-devel')
-rw-r--r--www/node-devel/Makefile18
-rw-r--r--www/node-devel/distinfo4
-rw-r--r--www/node-devel/files/patch-platform-freebsd.cc11
-rw-r--r--www/node-devel/pkg-plist1
4 files changed, 22 insertions, 12 deletions
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index 72bfa3db01d2..41d98308d61c 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 0.11.7
-PORTREVISION= 1
+PORTVERSION= 0.11.8
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= -devel
@@ -11,9 +10,9 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= linpct@gmail.com
COMMENT= V8 javascript for client and server
-LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+LICENSE= MIT
-MAN1= node.1
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USES= gmake
HAS_CONFIGURE= yes
@@ -27,12 +26,11 @@ CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm --shared-zlib
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
REINPLACE_ARGS= -i ''
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${OSVERSION} >= 900033 && exists(/usr/bin/clang)
-CC= clang
-CXX= clang++
+CC= clang
+CXX= clang++
GYP_DEFINES+= clang=1
.else
USE_GCC?= yes
@@ -44,9 +42,9 @@ post-patch:
${WRKSRC}/deps/v8/tools/gyp/v8.gyp
post-install:
- ${MKDIR} ${PREFIX}/lib/node_modules/
- ${TOUCH} ${PREFIX}/lib/node_modules/.keepme
- ${CHMOD} ${MANMODE} ${PREFIX}/man/man1/node.1
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/node_modules/
+ ${TOUCH} ${STAGEDIR}${PREFIX}/lib/node_modules/.keepme
+ ${CHMOD} ${MANMODE} ${STAGEDIR}${PREFIX}/man/man1/node.1
@${ECHO_MSG}
@${ECHO_MSG} "Note: If you need npm (Node Package Manager), please install www/npm."
@${ECHO_MSG}
diff --git a/www/node-devel/distinfo b/www/node-devel/distinfo
index 04cbd3f9cacb..01f29ff76259 100644
--- a/www/node-devel/distinfo
+++ b/www/node-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.11.7.tar.gz) = d915345639e340405b01f259971f386aafb5a10544b162826514cf56ddd371fe
-SIZE (node-v0.11.7.tar.gz) = 14885051
+SHA256 (node-v0.11.8.tar.gz) = 87c809dea764d5d66f925626fba403fb2fb0c0ccfad408bf79fdb62dc246d65b
+SIZE (node-v0.11.8.tar.gz) = 14937740
diff --git a/www/node-devel/files/patch-platform-freebsd.cc b/www/node-devel/files/patch-platform-freebsd.cc
new file mode 100644
index 000000000000..210f8817ab7a
--- /dev/null
+++ b/www/node-devel/files/patch-platform-freebsd.cc
@@ -0,0 +1,11 @@
+--- deps/v8/src/platform-freebsd.orig 2013-11-18 22:50:13.000000000 -0200
++++ deps/v8/src/platform-freebsd.cc 2013-11-18 22:55:37.000000000 -0200
+@@ -189,7 +189,7 @@
+ // There may be no filename in this line. Skip to next.
+ if (start_of_path == NULL) continue;
+ buffer[bytes_read] = 0;
+- LOG(isolate SharedLibraryEvent(start_of_path, start, end));
++ LOG(isolate, SharedLibraryEvent(start_of_path, start, end));
+ }
+ close(fd);
+ }
diff --git a/www/node-devel/pkg-plist b/www/node-devel/pkg-plist
index 2440890efcfe..9a962b6b775b 100644
--- a/www/node-devel/pkg-plist
+++ b/www/node-devel/pkg-plist
@@ -2,6 +2,7 @@ bin/node
lib/dtrace/node.d
lib/node_modules/.keepme
share/systemtap/tapset/node.stp
+man/man1/node.1.gz
@dirrmtry share/systemtap/tapset
@dirrmtry share/systemtap
@dirrmtry lib/node_modules