aboutsummaryrefslogtreecommitdiffstats
path: root/www/node/Makefile
diff options
context:
space:
mode:
authorbhughes <bhughes@FreeBSD.org>2019-03-13 05:05:39 +0800
committerbhughes <bhughes@FreeBSD.org>2019-03-13 05:05:39 +0800
commit2b2594e44828b21b12b08c892bdab4f9d482cde2 (patch)
tree79caed07994988733816759664c7a4322b69077d /www/node/Makefile
parent2896b5287e5d36b2146110dbadc3c73bd648ff0d (diff)
downloadfreebsd-ports-gnome-2b2594e44828b21b12b08c892bdab4f9d482cde2.tar.gz
freebsd-ports-gnome-2b2594e44828b21b12b08c892bdab4f9d482cde2.tar.zst
freebsd-ports-gnome-2b2594e44828b21b12b08c892bdab4f9d482cde2.zip
www/node: set environment variables for host build
The Node.js build system supports cross-compilation via node-gyp, which picks up CC, CXX, LINK, C*FLAGS, and LDFLAGS from the environment for the target build, but not for the host. We need to set the environment variables for the "host" build. This unbreaks the build on powerpc64. PR: 233650 Reported by: Piotr Kubaj <pkubaj@anongoth.pl> Sponsored by: Miles AS Differential Revision: https://reviews.freebsd.org/D19250
Diffstat (limited to 'www/node/Makefile')
-rw-r--r--www/node/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 9c08dc8eb043..f1aa489af686 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -12,7 +12,6 @@ COMMENT= V8 JavaScript for client and server
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to build: KeyError: 'action'
BROKEN_SSL= openssl libressl libressl-devel
BROKEN_SSL_REASON= Node.js 11.x requires OpenSSL 1.1.x or the BUNDLED_SSL option enabled
ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc64
@@ -31,6 +30,7 @@ OPTIONS_EXCLUDE_aarch64= DTRACE
# dt_modtext:/usr/src/cddl/contrib/opensolaris/lib/libdtrace/common/dt_link.c(820): arm not implemented
OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
+OPTIONS_EXCLUDE_powerpc64= DTRACE
BUNDLED_SSL_DESC= Use node.js's bundled OpenSSL implementation
BUNDLED_SSL_USES_OFF= ssl
@@ -60,7 +60,9 @@ SHEBANG_FILES= tools/specialize_node_d.py tools/genv8constants.py
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
REINPLACE_ARGS= -i ''
-MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
+MAKE_ENV+= CC.host=${CC} CFLAGS.host="${CFLAGS}" \
+ CXX.host=${CXX} CXXFLAGS.host="${CXXFLAGS}" \
+ LINK.host=${CXX} LDFLAGS.host="${LDFLAGS}"
LIB_DEPENDS+= libcares.so:dns/c-ares\
libuv.so:devel/libuv \