aboutsummaryrefslogtreecommitdiffstats
path: root/www/node
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-04-04 00:20:05 +0800
committerdhn <dhn@FreeBSD.org>2011-04-04 00:20:05 +0800
commit19e20bb7518b6a4ef7bc67dfe4f0a70deeffa7ee (patch)
tree121155d063b08b90cc9a5f8c24bde213cf927d44 /www/node
parent924db31d4b5760b9a191698d574e7cdf1a2ad29c (diff)
downloadfreebsd-ports-gnome-19e20bb7518b6a4ef7bc67dfe4f0a70deeffa7ee.tar.gz
freebsd-ports-gnome-19e20bb7518b6a4ef7bc67dfe4f0a70deeffa7ee.tar.zst
freebsd-ports-gnome-19e20bb7518b6a4ef7bc67dfe4f0a70deeffa7ee.zip
- Update to 0.4.5
PR: ports/156120 Submitted by: Jin-Sih Lin <linpct@gmail.com> (maintainer)
Diffstat (limited to 'www/node')
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node/files/patch-man-and-pkgconfig-path8
-rw-r--r--www/node/files/patch-platform-freebsd28
-rw-r--r--www/node/files/patch-wafadmin-Node.py4
5 files changed, 9 insertions, 37 deletions
diff --git a/www/node/Makefile b/www/node/Makefile
index 09b6a98ff0de..9ab8812b004b 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.4.4
+PORTVERSION= 0.4.5
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
diff --git a/www/node/distinfo b/www/node/distinfo
index 78310335dd23..f771c3e35725 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.4.4.tar.gz) = ea4430909601340cb3e8adb15569facfeca4e1d59129f1932254535bb4bf3e17
-SIZE (node-v0.4.4.tar.gz) = 4995935
+SHA256 (node-v0.4.5.tar.gz) = 63fa6acd7dbf1ea816dc5fd64ba4d066f85380396571d29934b8b9141dc2a0ee
+SIZE (node-v0.4.5.tar.gz) = 5001301
diff --git a/www/node/files/patch-man-and-pkgconfig-path b/www/node/files/patch-man-and-pkgconfig-path
index fac4766beb77..d6e5036ca269 100644
--- a/www/node/files/patch-man-and-pkgconfig-path
+++ b/www/node/files/patch-man-and-pkgconfig-path
@@ -1,6 +1,6 @@
---- wscript.orig 2011-03-03 03:10:26.000000000 -0300
-+++ wscript 2011-02-03 05:46:45.000000000 -0200
-@@ -878,8 +878,6 @@
+--- wscript.orig 2011-04-02 11:24:56.000000000 +0800
++++ wscript 2011-04-02 11:25:54.000000000 +0800
+@@ -905,8 +905,6 @@
# Only install the man page if it exists.
# Do 'make doc install' to build and install it.
@@ -9,7 +9,7 @@
bld.install_files('${PREFIX}/bin/', 'tools/node-waf', chmod=0755)
bld.install_files('${LIBDIR}/node/wafadmin', 'tools/wafadmin/*.py')
-@@ -891,7 +889,7 @@
+@@ -918,7 +916,7 @@
node_conf.target = 'tools/nodejs.pc'
node_conf.dict = subflags(node)
diff --git a/www/node/files/patch-platform-freebsd b/www/node/files/patch-platform-freebsd
deleted file mode 100644
index 1b2684957452..000000000000
--- a/www/node/files/patch-platform-freebsd
+++ /dev/null
@@ -1,28 +0,0 @@
---- deps/v8/src/platform-freebsd.cc.orig 2011-02-05 15:15:52.000000000 +0800
-+++ deps/v8/src/platform-freebsd.cc 2011-02-05 15:34:20.000000000 +0800
-@@ -526,6 +526,16 @@
- return result;
- }
-
-+ virtual bool TryLock() {
-+ int result = pthread_mutex_trylock(&mutex_);
-+ // Return false if the lock is busy and locking failed.
-+ if (result == EBUSY) {
-+ return false;
-+ }
-+ ASSERT(result == 0); // Verify no other errors.
-+ return true;
-+ }
-+
- private:
- pthread_mutex_t mutex_; // Pthread mutex for POSIX platforms.
- };
-@@ -604,7 +614,7 @@
- TickSample sample;
-
- // We always sample the VM state.
-- sample.state = VMState::current_state();
-+ // sample.state = VMState::current_state();
-
- // If profiling, we extract the current pc and sp.
- if (active_sampler_->IsProfiling()) {
diff --git a/www/node/files/patch-wafadmin-Node.py b/www/node/files/patch-wafadmin-Node.py
index b593bc720531..f9b3dd646e96 100644
--- a/www/node/files/patch-wafadmin-Node.py
+++ b/www/node/files/patch-wafadmin-Node.py
@@ -1,5 +1,5 @@
---- tools/wafadmin/Node.py.orig 2010-10-25 05:45:39.000000000 +0800
-+++ tools/wafadmin/Node.py 2010-10-27 18:30:12.000000000 +0800
+--- tools/wafadmin/Node.py.orig 2011-04-02 11:21:17.000000000 +0800
++++ tools/wafadmin/Node.py 2011-04-02 11:22:37.000000000 +0800
@@ -349,6 +349,12 @@
if self == from_node: return '.'
if from_node.parent == self: return '..'