aboutsummaryrefslogtreecommitdiffstats
path: root/www/npm
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-01 04:25:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-01 04:25:47 +0800
commit820dcceef248ee579f07b3b0917029541bb8039c (patch)
treee9e790435feb51d278ad6cda18a24c8e4353265e /www/npm
parent3b9046cdee25e24dd1f1fe0de58e3af8b151fe1b (diff)
downloadfreebsd-ports-gnome-820dcceef248ee579f07b3b0917029541bb8039c.tar.gz
freebsd-ports-gnome-820dcceef248ee579f07b3b0917029541bb8039c.tar.zst
freebsd-ports-gnome-820dcceef248ee579f07b3b0917029541bb8039c.zip
- Update to 1.3.11
Changes: https://github.com/isaacs/npm/commits/master
Diffstat (limited to 'www/npm')
-rw-r--r--www/npm/Makefile5
-rw-r--r--www/npm/distinfo4
-rw-r--r--www/npm/pkg-plist25
3 files changed, 19 insertions, 15 deletions
diff --git a/www/npm/Makefile b/www/npm/Makefile
index c34f6054b5a2..4bad58827957 100644
--- a/www/npm/Makefile
+++ b/www/npm/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= npm
-PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTVERSION= 1.3.11
CATEGORIES= www
MASTER_SITES= LOCAL/sunpoet
@@ -17,6 +16,7 @@ NODE_DEVEL_DESC=Use www/node-devel instead of www/node
NO_BUILD= yes
NO_MANCOMPRESS= yes
+NO_STAGE= yes
USE_XZ= yes
MAN1= npm.1 npm-README.1 npm-adduser.1 npm-bin.1 npm-bugs.1 \
@@ -45,7 +45,6 @@ MAN7= npm-coding-style.7 npm-config.7 npm-developers.7 \
npm-scripts.7 removing-npm.7 semver.7
MANPREFIX= ${PREFIX}/lib/node_modules/npm
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNODE_DEVEL}
diff --git a/www/npm/distinfo b/www/npm/distinfo
index 4c56d64da5a3..98eda57adbc7 100644
--- a/www/npm/distinfo
+++ b/www/npm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (npm-1.3.8.tar.xz) = de715de676a09f6fc4b0c53f41aacd136935a9b995fdc0974ac5e1d92b28bc14
-SIZE (npm-1.3.8.tar.xz) = 1785624
+SHA256 (npm-1.3.11.tar.xz) = dd617f878240e7d4263bd860b0b13c668a5fbafd51b195a577b993cd326a25a6
+SIZE (npm-1.3.11.tar.xz) = 1785108
diff --git a/www/npm/pkg-plist b/www/npm/pkg-plist
index 0cd89c452dc2..d872b297839f 100644
--- a/www/npm/pkg-plist
+++ b/www/npm/pkg-plist
@@ -448,7 +448,9 @@ lib/node_modules/npm/node_modules/graceful-fs/polyfills.js
lib/node_modules/npm/node_modules/graceful-fs/test/open.js
lib/node_modules/npm/node_modules/inherits/LICENSE
lib/node_modules/npm/node_modules/inherits/README.md
+lib/node_modules/npm/node_modules/inherits/inherits_browser.js
lib/node_modules/npm/node_modules/inherits/inherits.js
+lib/node_modules/npm/node_modules/inherits/test.js
lib/node_modules/npm/node_modules/inherits/package.json
lib/node_modules/npm/node_modules/ini/LICENSE
lib/node_modules/npm/node_modules/ini/README.md
@@ -492,9 +494,9 @@ lib/node_modules/npm/node_modules/lru-cache/.npmignore
lib/node_modules/npm/node_modules/lru-cache/AUTHORS
lib/node_modules/npm/node_modules/lru-cache/LICENSE
lib/node_modules/npm/node_modules/lru-cache/README.md
+lib/node_modules/npm/node_modules/lru-cache/bench.js
lib/node_modules/npm/node_modules/lru-cache/lib/lru-cache.js
lib/node_modules/npm/node_modules/lru-cache/package.json
-lib/node_modules/npm/node_modules/lru-cache/s.js
lib/node_modules/npm/node_modules/lru-cache/test/basic.js
lib/node_modules/npm/node_modules/lru-cache/test/foreach.js
lib/node_modules/npm/node_modules/lru-cache/test/memory-leak.js
@@ -731,13 +733,6 @@ lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-packa
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/fixer.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/normalize.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib/typos.json
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/.npmignore
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/History.md
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/Makefile
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/Readme.md
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/index.js
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/package.json
-lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git/test.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/package.json
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/test/basic.js
lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/test/consistency.js
@@ -782,6 +777,9 @@ lib/node_modules/npm/node_modules/request/.npmignore
lib/node_modules/npm/node_modules/request/LICENSE
lib/node_modules/npm/node_modules/request/README.md
lib/node_modules/npm/node_modules/request/index.js
+lib/node_modules/npm/node_modules/request/lib/copy.js
+lib/node_modules/npm/node_modules/request/lib/debug.js
+lib/node_modules/npm/node_modules/request/lib/getSafe.js
lib/node_modules/npm/node_modules/request/node_modules/aws-sign/LICENSE
lib/node_modules/npm/node_modules/request/node_modules/aws-sign/README.md
lib/node_modules/npm/node_modules/request/node_modules/aws-sign/index.js
@@ -997,6 +995,7 @@ lib/node_modules/npm/node_modules/request/node_modules/node-uuid/benchmark/bench
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/benchmark/bench.sh
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/benchmark/benchmark-native.c
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/benchmark/benchmark.js
+lib/node_modules/npm/node_modules/request/node_modules/node-uuid/component.json
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/package.json
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/test/compare_v1.js
lib/node_modules/npm/node_modules/request/node_modules/node-uuid/test/test.html
@@ -1017,6 +1016,7 @@ lib/node_modules/npm/node_modules/request/node_modules/tunnel-agent/README.md
lib/node_modules/npm/node_modules/request/node_modules/tunnel-agent/index.js
lib/node_modules/npm/node_modules/request/node_modules/tunnel-agent/package.json
lib/node_modules/npm/node_modules/request/package.json
+lib/node_modules/npm/node_modules/request/request.js
lib/node_modules/npm/node_modules/request/tests/googledoodle.jpg
lib/node_modules/npm/node_modules/request/tests/run.js
lib/node_modules/npm/node_modules/request/tests/server.js
@@ -1051,6 +1051,7 @@ lib/node_modules/npm/node_modules/request/tests/test-http-signature.js
lib/node_modules/npm/node_modules/request/tests/test-httpModule.js
lib/node_modules/npm/node_modules/request/tests/test-https-strict.js
lib/node_modules/npm/node_modules/request/tests/test-https.js
+lib/node_modules/npm/node_modules/request/tests/test-isUrl.js
lib/node_modules/npm/node_modules/request/tests/test-localAddress.js
lib/node_modules/npm/node_modules/request/tests/test-oauth.js
lib/node_modules/npm/node_modules/request/tests/test-onelineproxy.js
@@ -1117,6 +1118,7 @@ lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/duplex.js
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/examples/CAPSLOCKTYPER.JS
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/examples/typer-fsr.js
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/examples/typer.js
+lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/float.patch
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/fs.js
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/lib/_stream_duplex.js
lib/node_modules/npm/node_modules/sha/node_modules/readable-stream/lib/_stream_passthrough.js
@@ -1289,6 +1291,9 @@ lib/node_modules/npm/test/tap/ignore-shrinkwrap.js
lib/node_modules/npm/test/tap/ignore-shrinkwrap/npm-shrinkwrap.json
lib/node_modules/npm/test/tap/ignore-shrinkwrap/package.json
lib/node_modules/npm/test/tap/noargs-install-config-save.js
+lib/node_modules/npm/test/tap/outdated.js
+lib/node_modules/npm/test/tap/outdated/package.json
+lib/node_modules/npm/test/tap/outdated/index.js
lib/node_modules/npm/test/tap/package-with-peer-dep/package.json
lib/node_modules/npm/test/tap/peer-deps-invalid.js
lib/node_modules/npm/test/tap/peer-deps-invalid/package.json
@@ -1299,6 +1304,7 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/test/tap/peer-deps-without-package-json
@dirrm lib/node_modules/npm/test/tap/peer-deps-invalid
@dirrm lib/node_modules/npm/test/tap/package-with-peer-dep
+@dirrm lib/node_modules/npm/test/tap/outdated
@dirrm lib/node_modules/npm/test/tap/ignore-shrinkwrap
@dirrm lib/node_modules/npm/test/tap/fixtures
@dirrm lib/node_modules/npm/test/tap/false_name
@@ -1444,6 +1450,7 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/node_modules/request/node_modules/cookie-jar
@dirrm lib/node_modules/npm/node_modules/request/node_modules/aws-sign
@dirrm lib/node_modules/npm/node_modules/request/node_modules
+@dirrm lib/node_modules/npm/node_modules/request/lib
@dirrm lib/node_modules/npm/node_modules/request
@dirrm lib/node_modules/npm/node_modules/read/test
@dirrm lib/node_modules/npm/node_modules/read/node_modules/mute-stream/test
@@ -1455,8 +1462,6 @@ lib/node_modules/npm/test/update-test.sh
@dirrm lib/node_modules/npm/node_modules/read-package-json/test
@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/test/fixtures
@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/test
-@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules/github-url-from-git
-@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/node_modules
@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data/lib
@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules/normalize-package-data
@dirrm lib/node_modules/npm/node_modules/read-package-json/node_modules