aboutsummaryrefslogtreecommitdiffstats
path: root/www/nspluginwrapper
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2014-02-11 04:59:11 +0800
committerjkim <jkim@FreeBSD.org>2014-02-11 04:59:11 +0800
commitaa9f67121475b4128a5f191d73795d99d8ecd08f (patch)
tree9f756527f79821ba17d93be3d8914746e024c3e8 /www/nspluginwrapper
parent3f3bedd2debb0a9a81b91a36ef53c4dfcfe9d6bb (diff)
downloadfreebsd-ports-gnome-aa9f67121475b4128a5f191d73795d99d8ecd08f.tar.gz
freebsd-ports-gnome-aa9f67121475b4128a5f191d73795d99d8ecd08f.tar.zst
freebsd-ports-gnome-aa9f67121475b4128a5f191d73795d99d8ecd08f.zip
- Catch up with glib20 changes. [1]
- Add couple of upstream patches for nspluginplayer. PR: ports/186115 [1]
Diffstat (limited to 'www/nspluginwrapper')
-rw-r--r--www/nspluginwrapper/Makefile5
-rw-r--r--www/nspluginwrapper/files/patch-src__npw-player.c39
2 files changed, 40 insertions, 4 deletions
diff --git a/www/nspluginwrapper/Makefile b/www/nspluginwrapper/Makefile
index a3fed6407218..d073bf5fd4a3 100644
--- a/www/nspluginwrapper/Makefile
+++ b/www/nspluginwrapper/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nspluginwrapper
PORTVERSION= 1.4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www linux emulators
MASTER_SITES= http://nspluginwrapper.org/download/ \
LOCAL/jkim \
@@ -59,9 +59,6 @@ PLIST_SUB+= HOST_AMD64="@comment "
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/src/npw-config.c
- @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
- ${WRKSRC}/src/npruntime.c ${WRKSRC}/src/npw-player.c \
- ${WRKSRC}/src/utils.c
post-install:
${MKDIR} ${STAGEDIR}${LIBDIR}/i386/linux
diff --git a/www/nspluginwrapper/files/patch-src__npw-player.c b/www/nspluginwrapper/files/patch-src__npw-player.c
new file mode 100644
index 000000000000..ab31511c2f85
--- /dev/null
+++ b/www/nspluginwrapper/files/patch-src__npw-player.c
@@ -0,0 +1,39 @@
+--- src/npw-player.c.orig 2011-06-30 23:18:57.000000000 -0400
++++ src/npw-player.c 2014-02-10 15:02:58.000000000 -0500
+@@ -25,7 +25,6 @@
+ #include <unistd.h>
+ #include <glib.h>
+ #include <glib/gstdio.h>
+-#include <glib/gthread.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkx.h>
+ #include <gdk/gdkkeysyms.h>
+@@ -1233,6 +1232,7 @@
+ return NULL;
+
+ curl_easy_setopt (handle, CURLOPT_URL, url);
++ curl_easy_setopt (handle, CURLOPT_NOSIGNAL, 1);
+ curl_easy_setopt (handle, CURLOPT_WRITEFUNCTION, on_stream_read_nothing_cb);
+ curl_easy_setopt (handle, CURLOPT_FILETIME, 1);
+ curl_easy_setopt (handle, CURLOPT_TIMECONDITION, CURL_TIMECOND_LASTMOD);
+@@ -1626,6 +1626,7 @@
+
+ CURL * const handle = pstream->curl_handle;
+ curl_easy_setopt (handle, CURLOPT_URL, pstream->np_stream->url);
++ curl_easy_setopt (handle, CURLOPT_NOSIGNAL, 1);
+ curl_easy_setopt (handle, CURLOPT_WRITEFUNCTION, on_stream_read_cb);
+ curl_easy_setopt (handle, CURLOPT_WRITEDATA, pstream);
+ curl_easy_setopt (handle, CURLOPT_PRIVATE, pstream);
+@@ -2667,7 +2668,11 @@
+ }
+
+ if (g_backend == BACKEND_GTK)
+- gtk_main ();
++ {
++ gdk_threads_enter ();
++ gtk_main ();
++ gdk_threads_leave ();
++ }
+
+ for (i = 0; i < plugin_descs->len; i++)
+ {